I can't boot up due to "Bad Linux ARM zImage magic!"

Post Reply
luke
Posts: 3
Joined: Tue Mar 29, 2016 4:55 pm
languages_spoken: english
ODROIDs: XU4, XU
Has thanked: 0
Been thanked: 0
Contact:

I can't boot up due to "Bad Linux ARM zImage magic!"

Post by luke »

Hi,

I'm using XU4 board, and I can't boot up now, here is the log messages.

==================================================================

Code: Select all

U-Boot 2012.07-00029-g0e9204d-dirty (Jul 17 2015 - 15:38:42) for Exynos5422

CPU: Exynos5422 Rev0.1 [Samsung SOC on SMP Platform Base on ARM CortexA7]
APLL = 800MHz, KPLL = 800MHz
MPLL = 532MHz, BPLL = 825MHz

Board: HardKernel ODROID
DRAM:  2 GiB
WARNING: Caches not enabled

TrustZone Enabled BSP
BL1 version: ▒/▒▒▒
VDD_KFC: 0x44
LDO19: 0xf2

Checking Boot Mode ... EMMC
MMC:   S5P_MSHC0: 0, S5P_MSHC2: 1
MMC Device 0: 14.7 GiB
MMC Device 1: [ERROR] response timeout error : 00000104 cmd 1
Card did not respond to voltage select!
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Double Press 'Enter' to stop autoboot:  0
reading boot.ini

** Unable to read "boot.ini" from mmc 0:1 **
Unknown command 'ext4load' - try 'help'
Unknown command 'ext4load' - try 'help'
>>> Load Boot Script from mmc 0:1 <<<
reading boot.scr

** Unable to read "boot.scr" from mmc 0:1 **
>>> Load Boot Script from mmc 0:2 <<<

** Unable to use mmc 0:2 for fatload **
>>> Run Default Bootcmd <<<
reading kernel..device 0 Start 1263, Count 16384
MMC read: dev # 0, block # 1263, count 16384 ... 16384 blocks read: OK
completed
reading RFS..device 0 Start 17647, Count 2048
MMC read: dev # 0, block # 17647, count 2048 ... 2048 blocks read: OK
completed
Bad Linux ARM zImage magic!
=================================================================

And I couldn't find boot.ini file when I connect to sdcard to PC.
Please help me to find out how to solve this problem.

thanks.

User avatar
odroid
Site Admin
Posts: 36451
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1448 times
Been thanked: 986 times
Contact:

Re: I can't boot up due to "Bad Linux ARM zImage magic!"

Post by odroid »

Which OS image did you flash? What is the file name of the OS image?

Did you use the "VERIFY" button on our Win32DiskImager when you flashed the OS image?
http://odroid.com/dokuwiki/doku.php?id= ... diskimager

luke
Posts: 3
Joined: Tue Mar 29, 2016 4:55 pm
languages_spoken: english
ODROIDs: XU4, XU
Has thanked: 0
Been thanked: 0
Contact:

Re: I can't boot up due to "Bad Linux ARM zImage magic!"

Post by luke »

Thanks for your comment.
Actually, I built my own kernel, and download it with below site.
http://odroid.com/dokuwiki/doku.php?id= ... ng_android

When I was downloading, I made a mistake to send it below command.
fatload mmc 0:1 40008000 zImage-dtb

I just wrote below command only.
movi write kernel 0 40008000

After that, I couldn't boot up this board. and this log always is shown.

Let me ask something, even when I build my own kernel , do I have to do VERIFY by using tool that you mentioned?

Thanks,

User avatar
odroid
Site Admin
Posts: 36451
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1448 times
Been thanked: 986 times
Contact:

Re: I can't boot up due to "Bad Linux ARM zImage magic!"

Post by odroid »

If your flashing tool/process is reliable, you can skip the verification.

BTW, did you follow this instruction to install the compiled images?
http://odroid.com/dokuwiki/doku.php?id= ... ndroid#xu4
Did you configure the kernel tree with "make odroidxu3_defconfig"?

luke
Posts: 3
Joined: Tue Mar 29, 2016 4:55 pm
languages_spoken: english
ODROIDs: XU4, XU
Has thanked: 0
Been thanked: 0
Contact:

Re: I can't boot up due to "Bad Linux ARM zImage magic!"

Post by luke »

Sure, did followed all instructions to install the compiled images.
I also did "make odroid3_defconfig".

User avatar
odroid
Site Admin
Posts: 36451
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1448 times
Been thanked: 986 times
Contact:

Re: I can't boot up due to "Bad Linux ARM zImage magic!"

Post by odroid »

We couldn't find what's wrong in your process.

Flash our official image again and just replace your zimage file to narrow down possible mistakes.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 1 guest