[SOLVED] Problem with Remote control and Kodi

Post Reply
soundwave
Posts: 4
Joined: Mon Feb 16, 2015 10:53 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

[SOLVED] Problem with Remote control and Kodi

Unread post by soundwave » Tue Dec 08, 2015 6:37 pm

Hello all!

I have Odroid C1 with Lubuntu 1.6 image installed and I've managed to update Lirc's database for my LG remote control. When using Kodi (Isengard), the play, pause, rewind, forward keys does not work at all. In the meantime moving controls are working properly.

Does anyone could tell me how to set up the above mentioned keys to work properly in Kodi?

Regards!

mdrjr
Site Admin
Posts: 11706
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Problem with Remote control and Kodi

Unread post by mdrjr » Tue Dec 15, 2015 5:29 am

Clearly you haven't mapped your remote correctly.

here: http://odroid.com/dokuwiki/doku.php?id=en:c1_lirc

soundwave
Posts: 4
Joined: Mon Feb 16, 2015 10:53 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Problem with Remote control and Kodi

Unread post by soundwave » Tue Dec 22, 2015 8:30 am

Thank you for the answer +mdrjr. I've used this wiki to set my remote control and while testing with irw tool it appears that all controls are working just fine.

It seems that the problem is only with Kodi itself. Is there any database which has to mapped with the Lirc's one?

sputnik
Posts: 68
Joined: Tue Aug 11, 2015 9:39 am
languages_spoken: english, some spanish
ODROIDs: C1+
Has thanked: 0
Been thanked: 0
Contact:

Re: Problem with Remote control and Kodi

Unread post by sputnik » Fri Jan 01, 2016 7:01 am

If you haven't solved it by now, you need to edit the file: /home/<username>/.kodi/userdata/keymaps/remote.xml. It interfaces the lirc values with kodi.

soundwave
Posts: 4
Joined: Mon Feb 16, 2015 10:53 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Problem with Remote control and Kodi

Unread post by soundwave » Wed Jan 06, 2016 12:45 am

sputnik, thank you for your answer. Actually there's no such file as remote.xml. Could you please give me an example of it or there's another file which should be edited.

soundwave
Posts: 4
Joined: Mon Feb 16, 2015 10:53 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Problem with Remote control and Kodi

Unread post by soundwave » Wed Jan 13, 2016 12:01 am

Hello All, I've solved the problem by making the following file : /home/<username>/.kodi/userdata/Lircmap.xml. Here's the wiki I've followed : http://kodi.wiki/view/Lircmap.xml

sputnik
Posts: 68
Joined: Tue Aug 11, 2015 9:39 am
languages_spoken: english, some spanish
ODROIDs: C1+
Has thanked: 0
Been thanked: 0
Contact:

Re: [SOLVED] Problem with Remote control and Kodi

Unread post by sputnik » Thu Jan 14, 2016 10:55 am

Yes, I seem to recall I had to seek remote.xml out on the web and created it from there. Whatever works, that's the right way!

szz
Posts: 14
Joined: Mon May 02, 2016 8:05 pm
languages_spoken: english, spanish, catalan
ODROIDs: odroid U2, odroid C1+
Has thanked: 0
Been thanked: 0
Contact:

Re: [SOLVED] Problem with Remote control and Kodi

Unread post by szz » Tue Nov 27, 2018 2:54 am

Hi; Im using archlinux ARM and Kodi V17.6, I've already set up my Lircmap.xml and my remote.xml both are parsed successfully according to kodi.log and Kodi is able to receive the buttons from my remote controller (I can see it in the log file):

Code: Select all

...
17:53:12.958 T:2943143952   DEBUG: LIRC: Update - NEW at 1459600:0000000000000017 00 BTN_1 remote (BTN_1)
17:53:14.859 T:2943143952   DEBUG: LIRC: Update - NEW at 1461501:0000000000000003 00 KEY_DOWN remote (KEY_DOWN)
17:53:15.533 T:2943143952   DEBUG: LIRC: Update - NEW at 1462175:0000000000000005 00 KEY_LEFT remote (KEY_LEFT)
17:53:16.254 T:2943143952   DEBUG: LIRC: Update - NEW at 1462895:0000000000000002 00 KEY_UP remote (KEY_UP)
17:53:17.495 T:2943143952   DEBUG: LIRC: Update - NEW at 1464137:0000000000000004 00 KEY_RIGHT remote (KEY_RIGHT)
17:53:18.060 T:2943143952   DEBUG: LIRC: Update - NEW at 1464702:0000000000000006 00 KEY_ENTER remote (KEY_ENTER)
...
However the GUI does nothing!

Any idea?

Thanks in advance.

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 0 guests