How to enable Chromium browser GPU hardware accelerate.

benkong
Posts: 7
Joined: Sat Jan 10, 2015 12:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

How to enable Chromium browser GPU hardware accelerate.

Unread post by benkong » Sat Jan 10, 2015 12:54 pm

Thanks for odriod c1. Very good price and preformance! We can make the chromium browser even faster. By default, hardware acceleration is disable. Because your GPU is only support OpenGL ES. You can enter URL as about:gpu to see this.

Here is the way.
1. Run chromium.
2. Enter about:flags as URL.
3. Disable Override software rendering list (1st one).
4. Close the browser.
5. Run the chromium with "chromium-browser --use-gl=egl"
6. Enter about:gpu as URL

You can see it is full hardware accelerated :) You can feel it now!

Now the issue I am waiting is 1366x768, 1600x1200 support and make 8192cu 40mhz mode stable.

User avatar
robroy
Posts: 3434
Joined: Mon Feb 25, 2013 2:29 am
languages_spoken: English
ODROIDs: Q2, X, X2, U2, U3, XU-E, XU3, XU4, C1, C1+, C2
Location: San Francisco, California
Has thanked: 2 times
Been thanked: 23 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by robroy » Sat Jan 10, 2015 1:53 pm

+1 for awesomeness
Rob Roy, Editor-in-Chief of ODROID Magazine (submit an article | make a donation)

User avatar
odroid
Site Admin
Posts: 33277
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 366 times
Been thanked: 446 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by odroid » Sat Jan 10, 2015 3:29 pm

I didn't know that EGL option is already available. :o

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 57 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by memeka » Sat Jan 10, 2015 3:52 pm

did not work for me on the U3 with armsoc.

gripped
Posts: 691
Joined: Tue May 21, 2013 11:34 pm
languages_spoken: english
ODROIDs: U2 XU U3 XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by gripped » Sat Jan 10, 2015 7:10 pm

If you do this on other odroids it is still using mesa not the GPU.

Could you post the output of about:gpu after your changes benkong.

I'm curious and this could be the excuse I need to add to my odroid collection :D

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 57 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by memeka » Sat Jan 10, 2015 7:28 pm

it actually recognizes the Mali GPU. Not sure if it still uses mesa. Youtube allows HD resolution.
I did not try WebGL or some complicated canvas, but HTML5 still kills the CPU :)

rflownn
Posts: 28
Joined: Sun Jan 04, 2015 12:47 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by rflownn » Sun Jan 11, 2015 11:29 pm

Trying this on my U3 chromium gave:

[15825:15825:0111/055944:ERROR:gl_surface_egl.cc(123)] eglGetDisplay failed with error EGL_SUCCESS
[15825:15825:0111/055944:ERROR:gl_surface_x11.cc(68)] GLSurfaceEGL::InitializeOneOff failed.
[15825:15825:0111/055944:ERROR:gpu_child_thread.cc(143)] Exiting GPU process due to errors during initialization
[15792:15792:0111/055944:ERROR:gpu_process_transport_factory.cc(437)] Failed to establish GPU channel.
getrlimit(RLIMIT_NOFILE) failed
getrlimit(RLIMIT_NOFILE) failed
getrlimit(RLIMIT_NOFILE) failed
getrlimit(RLIMIT_NOFILE) failed
[15792:15819:0111/060025:ERROR:channel.cc(290)] RawChannel read error (connection broken)
getrlimit(RLIMIT_NOFILE) failed
getrlimit(RLIMIT_NOFILE) failed
getrlimit(RLIMIT_NOFILE) failed
getrlimit(RLIMIT_NOFILE) failed
[etc..]

Chromium dev site says a similar error to this is a non-essential for their current Milestone is being pushed out. Seems to work fine with mali450 from users that have the C1, but not so great with mali400 on my u3.

iBot
Posts: 52
Joined: Sun Dec 21, 2014 11:02 am
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by iBot » Mon Jan 12, 2015 11:04 am

I followed the instructions but I couldn't get the H/W Acc running. I got these errors

Code: Select all

chromium-browser --use-gl=egl
Xlib: extension "RANDR" missing on display ":1".
Xlib: extension "XInputExtension" missing on display ":1".
Xlib: extension "XInputExtension" missing on display ":1".
Xlib: extension "RANDR" missing on display ":1".
[2985:3009:0112/123035:ERROR:video_capture_device_factory_linux.cc(149)] Not implemented reached in virtual void media::VideoCaptureDeviceFactoryLinux::GetDeviceSupportedFormats(const media::VideoCaptureDevice::Name&, media::VideoCaptureFormats*)
Xlib: extension "XInputExtension" missing on display ":1".
Xlib: extension "XInputExtension" missing on display ":1".
[3024:3024:0112/123037:ERROR:gl_surface_egl.cc(128)] eglInitialize failed with error EGL_BAD_ALLOC
[3024:3024:0112/123037:ERROR:gl_surface_x11.cc(68)] GLSurfaceEGL::InitializeOneOff failed.
[3024:3024:0112/123037:ERROR:sandbox_linux.cc(305)] InitializeSandbox() called with multiple threads in process gpu-process
[3024:3024:0112/123037:ERROR:gpu_child_thread.cc(143)] Exiting GPU process due to errors during initialization
[2985

benkong
Posts: 7
Joined: Sat Jan 10, 2015 12:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by benkong » Mon Jan 12, 2015 6:41 pm

Pls check my photo. I only tested it on C1. Please follow the order of steps, because if you add command line arguments first, your renderer will crash. We have to disable the black list first then add egl argument.
Attachments
unnamed.jpg
unnamed.jpg (48.96 KiB) Viewed 50439 times

iBot
Posts: 52
Joined: Sun Dec 21, 2014 11:02 am
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by iBot » Mon Jan 12, 2015 10:35 pm

benkong wrote:Pls check my photo. I only tested it on C1. Please follow the order of steps, because if you add command line arguments first, your renderer will crash. We have to disable the black list first then add egl argument.
I am using vnc for display, not a real monitor. Will it affect?

vayal
Posts: 5
Joined: Mon Jan 12, 2015 11:51 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by vayal » Tue Jan 13, 2015 12:05 am

@benkong, I see from from your screenshot that video decoding is hardware accelerated. How does playing back a HTML5 video look - in terms of the CPU usage and frame rates - in full screen and in window. It would be of great help if you can provide me this details because I am researching in to the exact same thing for a project and planning to buy the Odroid-C1 if it fares well.

HerbsMix
Posts: 63
Joined: Fri Dec 05, 2014 7:51 am
languages_spoken: english
ODROIDs: ODROID-XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by HerbsMix » Tue Jan 13, 2015 12:16 am

It works on my xu3. Good find.
chromeSU1.png
chromeSU1.png (73.68 KiB) Viewed 50373 times

gripped
Posts: 691
Joined: Tue May 21, 2013 11:34 pm
languages_spoken: english
ODROIDs: U2 XU U3 XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by gripped » Tue Jan 13, 2015 1:07 am

I hate to be a party pooper but all the odroids I have, U2, U3, XU & XU3 if I follow the instructions in the first post about:gpu will state "hardware accelerated " but if you scroll down past "version information" it shows me that Mesa is the driver. So its's still software rendering.

A benefit is that webgl pages will run but slowly.

I can't speak for the C1 as I don't have one.

Also my tests (I tried this long ago and retry with most new versions of chromium) have been on Arch Linux so its possible that on another distro it actually gets passed to the mali driver.

I don't even have the mesa egl drivers on my systems but chromium builds it's own version at compile time.

can someone whose done this on the C1 (or indeed got it working on any other odroid) please copy and paste the whole output of about:gpu and also about:version :)

HerbsMix
Posts: 63
Joined: Fri Dec 05, 2014 7:51 am
languages_spoken: english
ODROIDs: ODROID-XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by HerbsMix » Tue Jan 13, 2015 2:50 am

Sincs last post i turned off "Enable experimental canvas features Mac, Windows, Linux, Chrome OS, Android" and performance has increased.

This is from xu3

Code: Select all

Graphics Feature Status
Canvas: Software only. Hardware acceleration disabled
Flash: Hardware accelerated
Flash Stage3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Compositing: Hardware accelerated
Multiple Raster Threads: Disabled
Rasterization: Hardware accelerated
Threaded Rasterization: Enabled
Video Decode: Hardware accelerated
Video Encode: Hardware accelerated
WebGL: Hardware accelerated
Driver Bug Workarounds
clear_uniforms_before_first_program_use
count_all_in_varyings_packing
disable_post_sub_buffers_for_onscreen_surfaces
scalarize_vec_and_mat_constructor_args
use_virtualized_gl_contexts
Problems Detected
The Mali-Txxx driver does not guarantee flush ordering: 154715, 10068, 269829, 294779, 285292
Applied Workarounds: use_virtualized_gl_contexts
Clear uniforms before first program use on all platforms: 124764, 349137
Applied Workarounds: clear_uniforms_before_first_program_use
Mesa drivers in Linux handle varyings without static use incorrectly: 333885
Applied Workarounds: count_all_in_varyings_packing
Disable partial swaps on linux drivers: 339493
Applied Workarounds: disable_post_sub_buffers_for_onscreen_surfaces
Always rewrite vec/mat constructors to be consistent: 398694
Applied Workarounds: scalarize_vec_and_mat_constructor_args
Accelerated 2D canvas is unavailable: either disabled at the command line or not supported by the current system.
Disabled Features: 2d_canvas
Raster is using a single thread.
Disabled Features: multiple_raster_threads
Version Information
Data exported	1/12/2015, 11:35:16 AM
Chrome version	Chrome/39.0.2171.65
Operating system	Linux 3.10.63
Software rendering list version	0
Driver bug list version	7.7
ANGLE commit id	unknown hash
2D graphics backend	Skia
Command Line Args	--enable-pinch --use-gl=egl --flag-switches-begin --enable-experimental-canvas-features --ignore-gpu-blacklist --flag-switches-end
Driver Information
Initialization time	336
Sandboxed	false
GPU0	VENDOR = 0x0000, DEVICE= 0x0000
Optimus	false
AMD switchable	false
Driver vendor	Mesa
Driver version	10.1.3
Driver date	
Pixel shader version	3.00
Vertex shader version	3.00
Machine model name	
Machine model version	
GL_VENDOR	ARM
GL_RENDERER	Mali-T628
GL_VERSION	OpenGL ES 3.0
GL_EXTENSIONS	GL_ARM_rgba8 GL_ARM_mali_shader_binary GL_OES_depth24 GL_OES_depth_texture GL_OES_depth_texture_cube_map GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_EXT_read_format_bgra GL_OES_compressed_paletted_texture GL_OES_compressed_ETC1_RGB8_texture GL_OES_standard_derivatives GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_sync GL_OES_texture_npot GL_OES_vertex_half_float GL_OES_required_internalformat GL_OES_vertex_array_object GL_OES_mapbuffer GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_type_2_10_10_10_REV GL_OES_fbo_render_mipmap GL_OES_element_index_uint GL_EXT_shadow_samplers GL_OES_texture_compression_astc GL_KHR_texture_compression_astc_ldr GL_KHR_texture_compression_astc_hdr GL_KHR_debug GL_EXT_occlusion_query_boolean GL_EXT_blend_minmax GL_EXT_discard_framebuffer GL_OES_get_program_binary GL_OES_texture_3D GL_EXT_texture_storage GL_EXT_multisampled_render_to_texture GL_OES_surfaceless_context GL_EXT_shader_pixel_local_storage GL_ARM_shader_framebuffer_fetch GL_ARM_shader_framebuffer_fetch_depth_stencil GL_ARM_mali_program_binary
Window system binding vendor	ARM
Window system binding version	1.4 Midgard-"r4p0-02rel0"
Window system binding extensions	EGL_KHR_config_attribs EGL_KHR_image EGL_KHR_image_base EGL_KHR_fence_sync EGL_KHR_wait_sync EGL_ARM_pixmap_multisample_discard EGL_KHR_gl_texture_2D_image EGL_KHR_gl_renderbuffer_image EGL_KHR_create_context EGL_KHR_surfaceless_context EGL_KHR_gl_texture_cubemap_image EGL_KHR_image_pixmap
Window manager	Metacity
XDG_CURRENT_DESKTOP	LXDE
GDMSESSION	Lubuntu
Compositing manager	No
Direct rendering	Yes
Reset notification strategy	0x0000
GPU process crash count	0
Log Messages
[3738:3738:0112/113402:ERROR:sandbox_linux.cc(305)] : InitializeSandbox() called with multiple threads in process gpu-process

Code: Select all

Chromium	39.0.2171.65 (Developer Build) Ubuntu 14.04
Revision	b853bfefba0da840f4574eb3b5c7ad6e9b8573b5
OS	Linux 
Blink	537.36 (@185325)
JavaScript	V8 3.29.88.17
Flash	(Disabled)
User Agent	Mozilla/5.0 (X11; Linux armv7l) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/39.0.2171.65 Chrome/39.0.2171.65 Safari/537.36
Command Line	/usr/lib/chromium-browser/chromium-browser --enable-pinch --flag-switches-begin --enable-experimental-canvas-features --ignore-gpu-blacklist --flag-switches-end
Executable Path	/usr/lib/chromium-browser/chromium-browser
Profile Path	/home/odroid/.config/chromium/Default
Variations	24dca50e-710af828
ca65a9fe-91ac3782
5e29d81-f23d1dea
246fb659-4ad60575
f296190c-6e3b1976
4442aae2-d7f6b13c
ed1d377-e1cc0f14
75f0f0a0-4ad60575
e2b18481-bd104136
e7e71889-e1cc0f14

benkong
Posts: 7
Joined: Sat Jan 10, 2015 12:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by benkong » Tue Jan 13, 2015 7:43 am

@vayal It can only smoothly play 480p videos on youtube html5. It's better, but not full accelerated. But the page rendering is much faster I can feel.

I am also sure that the driver is mali, not mesa. This way I only tested on C1's clean installation ubuntu v1.1. I don't know what will happen on others broad or system :)

gripped
Posts: 691
Joined: Tue May 21, 2013 11:34 pm
languages_spoken: english
ODROIDs: U2 XU U3 XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by gripped » Tue Jan 13, 2015 8:43 am

Well I very much hope I'm wrong. :D

I'm going to have another try now.

HerbsMix
Posts: 63
Joined: Fri Dec 05, 2014 7:51 am
languages_spoken: english
ODROIDs: ODROID-XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by HerbsMix » Tue Jan 13, 2015 9:22 am

You inspired me to make this post http://forum.odroid.com/viewtopic.php?f=95&t=8352
use the options from command line above when running Chromium. I used the start>run for testing

gripped
Posts: 691
Joined: Tue May 21, 2013 11:34 pm
languages_spoken: english
ODROIDs: U2 XU U3 XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by gripped » Tue Jan 13, 2015 11:15 am

Excellent. It works . Sorry I had doubts :oops:
It didn't use to. Either chromium has fixed something or I was doing something wrong. Not a lot to get wrong though.

I'm getting 25fps on BBC iplayer on their HD stream. Fullscreen does not work though. The picture freezes but the sound continues.
But I can use the "FullScreen Anything" addon, which fills the browser window, maximized and it working great.

This is on my XU3 by the way so get I'll off your C1 thread now. But thanks benkong.

(Edit - Should have said this is with Flash. HTML5 is laggy :cry: )

rflownn
Posts: 28
Joined: Sun Jan 04, 2015 12:47 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by rflownn » Tue Jan 13, 2015 7:52 pm

Hardware acceleration isn't working on my U3. I'm still able to get HD resolution on youtube at 720p, without the hardware acceleration by using a optimized compile of chromium for arm (from the chromium repot at https://dev.chromium.org).

barmalei
Posts: 9
Joined: Fri Jan 09, 2015 6:35 pm
languages_spoken: russian,english
ODROIDs: odroid c1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by barmalei » Thu Jan 15, 2015 10:04 pm

benkong wrote:Thanks for odriod c1. Very good price and preformance! We can make the chromium browser even faster. By default, hardware acceleration is disable. Because your GPU is only support OpenGL ES. You can enter URL as about:gpu to see this.

Here is the way.
1. Run chromium.
2. Enter about:flags as URL.
3. Disable Override software rendering list (1st one).
4. Close the browser.
5. Run the chromium with "chromium-browser --use-gl=egl"
6. Enter about:gpu as URL

You can see it is full hardware accelerated :) You can feel it now!

Now the issue I am waiting is 1366x768, 1600x1200 support and make 8192cu 40mhz mode stable.
Can you help possible change "Canvas: Software only. Hardware acceleration disabled" to "Canvas:Hardware acceleration" c1 board?

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 57 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by memeka » Sat Jan 17, 2015 12:53 am

on the U3, egl detection fails:
ERROR:gl_surface_egl.cc(123) eglGetDisplay failed with error EGL_SUCCESS
ERROR:gl_surface_x11.cc(68) GLSurfaceEGL::InitializeOneOff failed.
maybe with a but of patching it will work on U3 as well.

User avatar
meveric
Posts: 10720
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2, H2 (J4105)
Has thanked: 27 times
Been thanked: 236 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by meveric » Sat Jan 17, 2015 12:57 am

anyone testet http://ie.microsoft.com/testdrive/Perfo ... ETank/?o=1
with and without the "GPU-Acceleration"? Does it make any difference?
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

User avatar
memeka
Posts: 4420
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Has thanked: 2 times
Been thanked: 57 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by memeka » Sat Jan 17, 2015 1:12 am

i think the best is to try the chrome experiments with WebGL.

Boter
Posts: 17
Joined: Sun Jan 18, 2015 8:15 pm
languages_spoken: english, slovenian
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by Boter » Sun Jan 18, 2015 11:07 pm

Is there any hack for firefox too?

HerbsMix
Posts: 63
Joined: Fri Dec 05, 2014 7:51 am
languages_spoken: english
ODROIDs: ODROID-XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by HerbsMix » Fri Jan 23, 2015 9:52 am

anyone testet http://ie.microsoft.com/testdrive/Perfo ... ETank/?o=1
with and without the "GPU-Acceleration"? Does it make any difference?
XU3 test results from accelerated Chromium, full screen (1440x900):
1 - 250 fish - 60FPS
500 fish - 59FPS
1000 fish - 36FPS

Guenlay
Posts: 6
Joined: Thu Sep 12, 2013 6:27 pm
languages_spoken: english, chinese
ODROIDs: Odroid C1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by Guenlay » Fri Jan 23, 2015 2:24 pm

using C1, got error in Archlinux

Code: Select all

Log Messages
[1691:1691:0123/051348:ERROR:gl_surface_egl.cc(128)] : eglInitialize failed with error EGL_BAD_ALLOC
[1691:1691:0123/051348:ERROR:gl_surface_x11.cc(68)] : GLSurfaceEGL::InitializeOneOff failed.
[1691:1691:0123/051348:ERROR:sandbox_linux.cc(305)] : InitializeSandbox() called with multiple threads in process gpu-process
GpuProcessHostUIShim: The GPU process exited normally. Everything is okay.
could u tell me what gllib ur using, im using odroid-c1-libgl-X11 but found odroid-c1-libgl-fb
also there is a package "xf86-video-armsoc-chromium" looks like an optimused driver, did u install it?

HerbsMix
Posts: 63
Joined: Fri Dec 05, 2014 7:51 am
languages_spoken: english
ODROIDs: ODROID-XU3
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by HerbsMix » Sat Jan 24, 2015 8:12 am

Nothing special.
  • odroid@xu3-1:~$ uname -a
    Linux xu3-1 3.10.63 #1 SMP PREEMPT Sun Jan 18 17:25:17 BRST 2015 armv7l armv7l armv7l GNU/Linux
I have updated with the latest form Odroid-Utility and System Tools>Software Updater

youka
Posts: 163
Joined: Wed Oct 09, 2013 8:38 pm
languages_spoken: english
ODROIDs: Odroid XU+E, U2, U3, XU3, XU4 + Cloudshell
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by youka » Mon Jan 26, 2015 9:52 pm

Anyone had any luck with the U3 yet?

youka
Posts: 163
Joined: Wed Oct 09, 2013 8:38 pm
languages_spoken: english
ODROIDs: Odroid XU+E, U2, U3, XU3, XU4 + Cloudshell
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by youka » Mon Feb 02, 2015 8:58 pm

Anyone?? Managed to get Chromium to show "Hardware accelerated" on almost all features and the GPU details are showing Mali and not Mesa, but it's still running at the same speed as if it were using Mesa and canvas-related thing glitch out quite badly. Runs perfect on the XU3 though...

EntityFX
Posts: 6
Joined: Sat May 18, 2013 3:51 am
languages_spoken: english russian
ODROIDs: ODROID-X2
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by EntityFX » Tue Feb 03, 2015 8:09 pm

Please, help, how to enable hw acceleration on my Odroid X2
OS:

Code: Select all

ubuntu 13.10
Kernel:

Code: Select all

Linux odroid 3.8.13.11 #1 SMP PREEMPT Fri Oct 25 08:49:50 BRST 2013 armv7l armv7l armv7l GNU/Linux
Chromium renderere shows:
GL_VENDOR Mesa Project
Chromium version:

Code: Select all

Chrome/31.0.1650.63
Issues from chrome://gpu page:

Code: Select all

[b]Problems Detected[/b]
GPU process was unable to boot: GPU access is disabled in chrome://settings.
GL driver is software rendered. Accelerated compositing is disabled.: 59302
Accelerated 2d canvas is unstable in Linux at the moment.
Stage3D is not supported on Linux.: 129848
Accelerated video decode is unavailable on Mac and Linux.: 137247, 133828
Accelerated 2D canvas is unavailable: either disabled at the command line or not supported by the current system.
Accelerated CSS animation has been disabled at the command line.
How can I fix it? :?:

benkong
Posts: 7
Joined: Sat Jan 10, 2015 12:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by benkong » Wed Feb 04, 2015 9:20 am

Can anyone enable 2D canvas acceleration? Also video decoding is not accelerated as well. The log message showing

ERROR:gpu_video_decode_accelerator.cc(301)] : Not implemented reached in void

Thanks.

dode
Posts: 7
Joined: Wed Jan 14, 2015 8:19 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by dode » Tue Feb 24, 2015 11:55 pm

benkong wrote:ERROR:gpu_video_decode_accelerator.cc(301)] : Not implemented reached in void
Indeed, even though chrome://gpu says

Code: Select all

Video decode: Hardware accelerated
it says in the console:

Code: Select all

HW video decode acceleration not available.
and the video runs just as jerky as without --use-gl=egl

Not really awesome.

MrRee
Posts: 5
Joined: Sat Feb 21, 2015 8:03 am
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by MrRee » Wed Feb 25, 2015 1:31 am

Thanks for this , its great to be able to use the GPU and let teh CPU kick back and relax a little

Boter wrote:Is there any hack for firefox too?
I was searching for one prior to seeing this thread. there is some mention of "firefox -gl-provider=EGL " on some of the mailing lists, however I could not confirm any improvement with firefox over all.

Jase

User avatar
rooted
Posts: 7259
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 451 times
Been thanked: 127 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by rooted » Wed Feb 25, 2015 3:24 am

Definitely see improvement in chromium responsiveness.

patoberli
Posts: 401
Joined: Mon Feb 23, 2015 6:32 pm
languages_spoken: english, german
ODROIDs: C1 with RTC, Bluetooth 4.0, Wireless stick 4.0
Location: Switzerland
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by patoberli » Wed Mar 04, 2015 7:52 pm

Just tested this also. HTML5 Youtube video in 720p sadly doesn't show any difference, both modes have dropped frames and judders.
-
pato

User avatar
odroid
Site Admin
Posts: 33277
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 366 times
Been thanked: 446 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by odroid » Wed Mar 04, 2015 7:57 pm

The GPU accleration of Chromium browser doesn't work on the C1 while U3 and XU3 have no issue.

We are working on the new GPU drivers for C1 now and we have a plan to make a new release by end of this month.

patoberli
Posts: 401
Joined: Mon Feb 23, 2015 6:32 pm
languages_spoken: english, german
ODROIDs: C1 with RTC, Bluetooth 4.0, Wireless stick 4.0
Location: Switzerland
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by patoberli » Wed Mar 04, 2015 9:14 pm

Wow that's great to hear! :)
-
pato

ken107
Posts: 2
Joined: Fri Mar 20, 2015 9:37 am
languages_spoken: english
ODROIDs: c1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by ken107 » Fri Mar 20, 2015 9:47 am

Just wanna say "me too!" Hope this feature ready soon, my proj depends on this. And thanks for the great work!

mdrjr
Site Admin
Posts: 11736
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Has thanked: 1 time
Been thanked: 19 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by mdrjr » Fri Mar 20, 2015 10:24 pm

Released today a new image and the updates.
Please refer to our wiki.

User avatar
runnerway
Posts: 130
Joined: Mon Dec 15, 2014 6:47 am
languages_spoken: italian, english
ODROIDs: C1, C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by runnerway » Sat Mar 21, 2015 2:34 am

mdrjr wrote:Released today a new image and the updates.
Please refer to our wiki.
Thank you for the update. Tested and works :D

There is only one problem. When using hardware acceleration the mouse cursor flickers a lot.
Common problem? Any workaround?

ken107
Posts: 2
Joined: Fri Mar 20, 2015 9:37 am
languages_spoken: english
ODROIDs: c1
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by ken107 » Mon Mar 23, 2015 7:14 am

Fantastic. Even though accelerated_video_decode is not enabled, 720p videos plays better now and is acceptable for my purpose. But it would be nice if it was enabled.

Chrome://gpu says:
"Accelerated video decode is unavailable on Mac and Linux: crbug.com/137247"

On that page somebody suggests a workaround by compiling Chromium with -Dchromeos=1. Do you have any experience with this? Thanks again.

crashoverride
Posts: 4713
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 188 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by crashoverride » Mon Mar 23, 2015 10:48 am

runnerway wrote:When using hardware acceleration the mouse cursor flickers a lot.
Common problem? Any workaround?
This is an issue in the X11 driver. Currently a software mouse cursor is used and X11 has to repaint it. Modifying the X11 driver to enabling a hardware cursor using the extra OSD layer would correct that. It requires support from the kernel video driver so its something that will have to be tested and may be non-trivial.
ken107 wrote:Chrome://gpu says:
"Accelerated video decode is unavailable on Mac and Linux: crbug.com/137247"

On that page somebody suggests a workaround by compiling Chromium with -Dchromeos=1.
"Enable VAVDA by default on Linux for VA-API-assisted HW video decode"
The Odroid-C1, and possibly every ARM SoC made, does not provide VA-API support for the hardware codec.

User avatar
streetboy
Posts: 196
Joined: Tue Feb 26, 2013 6:43 pm
languages_spoken: english
ODROIDs: ODROID-X,U2,XU3-Lite
C1, XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by streetboy » Mon Mar 23, 2015 2:53 pm

This GPU accelerated Chromium is really fantastic. Much much faster web browsing as well as webgl support. Deeply impressive. :o

User avatar
TeHashX
Posts: 171
Joined: Wed Aug 13, 2014 4:14 am
languages_spoken: english
ODROIDs: C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by TeHashX » Mon Mar 23, 2015 9:46 pm

I can't get it to work: GPU process was unable to boot: GPU process launch failed.
Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Flash: Software only, hardware acceleration unavailable
Flash Stage3D: Software only, hardware acceleration unavailable
Flash Stage3D Baseline profile: Software only, hardware acceleration unavailable
Compositing: Software only, hardware acceleration unavailable
Multiple Raster Threads: Unavailable
Rasterization: Software only, hardware acceleration unavailable
Threaded Rasterization: Unavailable
Video Decode: Software only, hardware acceleration unavailable
Video Encode: Software only, hardware acceleration unavailable
WebGL: Unavailable
Driver Bug Workarounds
clear_uniforms_before_first_program_use
scalarize_vec_and_mat_constructor_args
Problems Detected
GPU process was unable to boot: GPU process launch failed.
Disabled Features: all
Clear uniforms before first program use on all platforms: 124764, 349137
Applied Workarounds: clear_uniforms_before_first_program_use
Always rewrite vec/mat constructors to be consistent: 398694
Applied Workarounds: scalarize_vec_and_mat_constructor_args
Version Information
Data exported 3/23/2015, 2:42:57 PM
Chrome version Chrome/41.0.2272.76
Operating system Linux 3.10.72-76
Software rendering list version 0
Driver bug list version 7.16
ANGLE commit id unknown hash
2D graphics backend Skia
Command Line Args --enable-pinch --use-gl=egl --flag-switches-begin --enable-experimental-extension-apis --ignore-gpu-blacklist --flag-switches-end
Driver Information
Initialization time 0
Sandboxed false
GPU0 VENDOR = 0x0000, DEVICE= 0x0000
Optimus false
AMD switchable false
Driver vendor
Driver version
Driver date
Pixel shader version
Vertex shader version
Machine model name
Machine model version
GL_VENDOR
GL_RENDERER
GL_VERSION
GL_EXTENSIONS
Window system binding vendor
Window system binding version
Window system binding extensions
Window manager Openbox
XDG_CURRENT_DESKTOP LXDE
Compositing manager No
Direct rendering Yes
Reset notification strategy 0x0000
GPU process crash count 0
Log Messages
[4428:4428:0323/144239:ERROR:gl_surface_egl.cc(161)] : eglInitialize failed with error EGL_BAD_ALLOC
[4428:4428:0323/144239:ERROR:gl_surface_x11.cc(68)] : GLSurfaceEGL::InitializeOneOff failed.
[4428:4428:0323/144239:ERROR:sandbox_linux.cc(325)] : InitializeSandbox() called with multiple threads in process gpu-process
GpuProcessHostUIShim: The GPU process exited normally. Everything is okay.

User avatar
odroid
Site Admin
Posts: 33277
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 366 times
Been thanked: 446 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by odroid » Tue Mar 24, 2015 9:51 am

Run "es2gears" to check the GPU driver status.
It doesn't show "r5p0-01rel0", you might need to reflash the latest V1.4 OS image.

User avatar
TeHashX
Posts: 171
Joined: Wed Aug 13, 2014 4:14 am
languages_spoken: english
ODROIDs: C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by TeHashX » Tue Mar 24, 2015 10:33 pm

odroid wrote:Run "es2gears" to check the GPU driver status.
It doesn't show "r5p0-01rel0", you might need to reflash the latest V1.4 OS image.
EGLUT: failed to initialize native display

User avatar
TeHashX
Posts: 171
Joined: Wed Aug 13, 2014 4:14 am
languages_spoken: english
ODROIDs: C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by TeHashX » Wed Mar 25, 2015 6:39 am

odroid wrote:Run "es2gears" to check the GPU driver status.
It doesn't show "r5p0-01rel0", you might need to reflash the latest V1.4 OS image.
Fresh install v1.4 and the same error
EGLUT: failed to initialize native display
Should I enable it somehow? I just resized root partition using odroid-utility.sh and run apt-get update && apt-get dist-upgrade

User avatar
odroid
Site Admin
Posts: 33277
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 366 times
Been thanked: 446 times
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by odroid » Wed Mar 25, 2015 10:13 am

Did you flash this image?
http://odroid.com/dokuwiki/doku.php?id= ... _note_v1.4
The "es2gears" must work.

patoberli
Posts: 401
Joined: Mon Feb 23, 2015 6:32 pm
languages_spoken: english, german
ODROIDs: C1 with RTC, Bluetooth 4.0, Wireless stick 4.0
Location: Switzerland
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by patoberli » Wed Mar 25, 2015 3:54 pm

You have to run es2gears with a graphical output, not via SSH.
-
pato

User avatar
TeHashX
Posts: 171
Joined: Wed Aug 13, 2014 4:14 am
languages_spoken: english
ODROIDs: C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How to enable Chromium browser GPU hardware accelerate.

Unread post by TeHashX » Wed Mar 25, 2015 4:15 pm

odroid wrote:Did you flash this image?
http://odroid.com/dokuwiki/doku.php?id= ... _note_v1.4
The "es2gears" must work.
I was connected through xrdp :(
patoberli wrote:You have to run es2gears with a graphical output, not via SSH.

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 1 guest