[SOLVED] Odroid HC4 don't automatically boot up after installing openmediavault 5.0

Post Reply
pjrough
Posts: 7
Joined: Wed Aug 03, 2022 2:50 am
languages_spoken: english
ODROIDs: Odroid HC4
Has thanked: 2 times
Been thanked: 0
Contact:

[SOLVED] Odroid HC4 don't automatically boot up after installing openmediavault 5.0

Post by pjrough »

Hi all.

I got an issue:
Odroid HC4 is not able automatically boot into the open mediavailt 5.0.

Description:

It is new Odroid HC4, right out of the box. HDD\s are not plugged for the moment.
Petitboot option is 20201005.

I used netboot_default to install Debian 10 (buster) onto Class 10 64gb microSD card from transcend.

All went OK and the system booted into debian 10 without touching the boot menu at all. So at this point HC4 is booting up Debian 10 - no problem.

But after installing the openmediavailt 5 using Odroid Wiki guide, the HC4 don't boots up automatically.
It powers up, passes the HK screen, shows booting options, but after the countdown, nothing happens. It is just a black screen. The blue LED doesn't lit. The red one remains lit.

interesting thing, though, if not waiting for automatic boot, but selecting first boot option from the picture below, it boots into the OMV with no issues what so ever. The blue led is blinking as normal.

My plan is to set a stand alone NAS, which is not connected to the monitor neither to the keyboard. So manual booting is not an option for me.
Manually selecting a boot option from mmcblk0p1 don\t solve the problem - blue LED don\t lit up.



please help me to solve this issue.

Image
Last edited by pjrough on Sat Aug 06, 2022 2:08 am, edited 1 time in total.

User avatar
tobetter
Posts: 10289
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 663 times
Been thanked: 1756 times
Contact:

Re: Odroid HC4 don't automatically boot up after installing openmediavault 5.0

Post by tobetter »

Can you please try the 3rd one if it boots?

pjrough
Posts: 7
Joined: Wed Aug 03, 2022 2:50 am
languages_spoken: english
ODROIDs: Odroid HC4
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Odroid HC4 don't automatically boot up after installing openmediavault 5.0

Post by pjrough »

Hi Tobetter thanks for replying. 3rd option don't work. the rest of the options don't work never (except the first one).
I mean that if manually selecting any option except 1st one, the HC4 don't boot, blue LED is off.

User avatar
tobetter
Posts: 10289
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 663 times
Been thanked: 1756 times
Contact:

Re: Odroid HC4 don't automatically boot up after installing openmediavault 5.0

Post by tobetter »

pjrough wrote:
Thu Aug 04, 2022 12:29 am
Hi Tobetter thanks for replying. 3rd option don't work. the rest of the options don't work never (except the first one).
I mean that if manually selecting any option except 1st one, the HC4 don't boot, blue LED is off.
That's strange...well...actually I never tried Grub menu entris after OMV is installed.
Once you booted with the first boot entry, run sudo apt purge odroid-grub2 and remove /boot/grub so that only the 1st boot entry is selectable. This way will let you boot successfully. Please try and let me know how it works.
These users thanked the author tobetter for the post:
pjrough (Fri Aug 05, 2022 9:45 pm)

pjrough
Posts: 7
Joined: Wed Aug 03, 2022 2:50 am
languages_spoken: english
ODROIDs: Odroid HC4
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Odroid HC4 don't automatically boot up after installing openmediavault 5.0

Post by pjrough »

Hey, thanks, that actually worked out. The boot issue is solved now. The unit can be rebooted automatically now.

I got two odroid ch4, the second one was bought just for tweaking the issue. Both units are back in working order now.

Tobetter, can you tell me in a couple of words what the issue was and what I just did to solve it?

tomerr
Posts: 91
Joined: Thu Feb 11, 2021 11:06 pm
languages_spoken: english
ODROIDs: HC4
Has thanked: 26 times
Been thanked: 17 times
Contact:

Re: Odroid HC4 don't automatically boot up after installing openmediavault 5.0

Post by tomerr »

are you aware that OMV5 recently reached End Of Life, meaning it would not receive any updates (including security updates) ?
https://www.openmediavault.org/?p=3259
These users thanked the author tomerr for the post:
odroid (Fri Aug 05, 2022 4:38 pm)

pjrough
Posts: 7
Joined: Wed Aug 03, 2022 2:50 am
languages_spoken: english
ODROIDs: Odroid HC4
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Odroid HC4 don't automatically boot up after installing openmediavault 5.0

Post by pjrough »

Yes, I know that. I was not able to start oled screen on Debian 11, so I am not in a hurry to switch to move 6.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests