N2 ssd boot issue and slow usb speed

Post Reply
gatz
Posts: 7
Joined: Sun Feb 16, 2020 6:27 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 1 time
Contact:

N2 ssd boot issue and slow usb speed

Post by gatz »

Hello,

I installed netboot debian bullseye on a kingston ssd. The ssd is in an enclosure Rebel comp that has a JMicron jms580 controller.
During installation to detect the ssd I had to unplug and plug the usb cable of ssd.
On petitboot (dev.20220317) the ssd is recognized, but when is booting can't find it.
It stays around 10 seconds on "Asking for cache data failed" and then gives up
IMG_20220609_185131.jpg
IMG_20220609_185131.jpg (59.32 KiB) Viewed 117 times
The only way to get over this issue is to unplug and plug the usb cable.

On top of this the SSD speed over usb is very slow around 35MB/s

sync; dd if=/dev/zero of=tempfile bs=1M count=1024; sync

Code: Select all

1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB, 1.0 GiB) copied, 30.1511 s, 35.6 MB/s 
lsusb -tv
Screenshot 2022-06-09 183147.png
Screenshot 2022-06-09 183147.png (17.63 KiB) Viewed 117 times


1. There is any way to get over the boot issue to don't have to manually unplug and plug the ssd?
2. There is any way to increase the ssd speed over usb?

Thanks
Last edited by gatz on Fri Jun 10, 2022 4:26 am, edited 1 time in total.

User avatar
tobetter
Posts: 10043
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 640 times
Been thanked: 1714 times
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by tobetter »

Can you please grab the output of lsusb when your USB is attached?

gatz
Posts: 7
Joined: Sun Feb 16, 2020 6:27 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by gatz »

lsusb while running the os from ssd

Code: Select all

Bus 002 Device 002: ID 05e3:0620 Genesys Logic, Inc. USB3.1 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0578:0578 Intrinsix Corp. JMS580
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
I'm not sure if is helping I also put an image of ubuntu on sdcard and ran udevadm monitor while attaching the ssd
1.png
1.png (71.57 KiB) Viewed 108 times

User avatar
tobetter
Posts: 10043
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 640 times
Been thanked: 1714 times
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by tobetter »

gatz wrote:
Fri Jun 10, 2022 3:46 am
lsusb while running the os from ssd

Code: Select all

Bus 002 Device 002: ID 05e3:0620 Genesys Logic, Inc. USB3.1 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0578:0578 Intrinsix Corp. JMS580
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Maybe your SSD is not compatible to the Linux kernel, so let's try this.
Firstly, update your Petitboot with the latest version (20220317) via the command pb-update in Petitboot command line.
Secondly, after rebooting with the latest Petitboot, get into the command line again in Petitboot and run pb-usbquirks.
Lastly, restart your ODROID-N2Plus again and check if your SSD works/boots.

gatz
Posts: 7
Joined: Sun Feb 16, 2020 6:27 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by gatz »

Petitboot is already on the latest version (20220317)
I ran pb-usbquirks but the same: waits a while on "Asking for cache data failed" then crashes. Only boots if I physically remove and plug in the ssd from which I'm booting.

This ssd I got it out of my previous laptop and I was running on it a dual boot with manjaro and windows.

User avatar
tobetter
Posts: 10043
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 640 times
Been thanked: 1714 times
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by tobetter »

gatz wrote:
Fri Jun 10, 2022 4:31 am
Petitboot is already on the latest version (20220317)
I ran pb-usbquirks but the same: waits a while on "Asking for cache data failed" then crashes. Only boots if I physically remove and plug in the ssd from which I'm booting.

This ssd I got it out of my previous laptop and I was running on it a dual boot with manjaro and windows.
When stuck at booting with the SSD, what are the output of cat /proc/cmdline and lsmod?

gatz
Posts: 7
Joined: Sun Feb 16, 2020 6:27 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by gatz »

IMG_20220609_234134.jpg
IMG_20220609_234134.jpg (299.87 KiB) Viewed 102 times

User avatar
tobetter
Posts: 10043
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 640 times
Been thanked: 1714 times
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by tobetter »

@gatz, that's odd. I intended no to load the driver uas by adding the kernel parameter usb-storage.quirks=0578:0578:u but it loads uas.

Do you have this line when the error happens?

Code: Select all

Bus 001 Device 004: ID 0578:0578 Intrinsix Corp. JMS580
What's the output of lsblk and dmesg | grep usb when the error happens?

gatz
Posts: 7
Joined: Sun Feb 16, 2020 6:27 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by gatz »

No ssd partitions detected. But if I remove and plug in the ssd again I can see the ssd partitions on cat /proc/partitions
IMG_20220610_110936.jpg
IMG_20220610_110936.jpg (260.03 KiB) Viewed 80 times
IMG_20220610_111114.jpg
IMG_20220610_111114.jpg (472.15 KiB) Viewed 80 times
IMG_20220610_111226.jpg
IMG_20220610_111226.jpg (492.81 KiB) Viewed 80 times

gatz
Posts: 7
Joined: Sun Feb 16, 2020 6:27 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by gatz »

I found an old usb2 enclosure and put my ssd in it. Seems like using that one is booting fine.
I guess, in fact, the problem is the enclosure itself.
I ordered a new enclosing with JMS578 controller same as hardkernel is selling, hopefully that one will work fine.

gatz
Posts: 7
Joined: Sun Feb 16, 2020 6:27 pm
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: N2 ssd boot issue and slow usb speed

Post by gatz »

As an update, maybe it will help someone in the future.
In the end I got an enclosure Ugreen CM300 70498 with chipset: ASMedia - ASM1352R.
This solved my boot problem and now I have usb3 speeds up to 350MB.
These users thanked the author gatz for the post:
odroid (Fri Jun 24, 2022 8:43 am)

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 2 guests