After Power Outage N2+ USB ports no longer work!

Post Reply
Suuvs
Posts: 10
Joined: Tue Jan 26, 2021 10:34 pm
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 1 time
Been thanked: 1 time
Contact:

After Power Outage N2+ USB ports no longer work!

Post by Suuvs »

Hi,

So i woke up today after having the power go out of my house during the night, and for some reason the N2+ does not recognize any usb ports anymore. it doesnt seem to transmit any power to anything, as for example my external HDD light does not even turn on for a second. (this hdd has been connected to the N2+ during its entire life). When i plug it in to my main pc it works just fine :S.

Has anyone encountered this before? or did the power outtage somehow fry my USB rails or something.

i also had automatic updates on, and it could be that the reset loaded some new updated code that is fucking things up. I tried running apt get update and upgrade but im currently fully updated.

User avatar
rooted
Posts: 8729
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 743 times
Been thanked: 376 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by rooted »

Yes it likely damaged it, I had something similar happen to an XU4 but it only damaged the Ethernet.

What is the output of 'lsusb -a'

Suuvs
Posts: 10
Joined: Tue Jan 26, 2021 10:34 pm
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by Suuvs »

rooted wrote:
Sat Aug 07, 2021 10:51 pm
Yes it likely damaged it, I had something similar happen to an XU4 but it only damaged the Ethernet.

What is the output of 'lsusb -a'
lsusb -a shows as invalid option a for me for some reason.

the output of just lsusb is :

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and lsusb -t :
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/2p, 480M

User avatar
rooted
Posts: 8729
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 743 times
Been thanked: 376 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by rooted »

That was supposed to say 'lsusb -v'

User avatar
mctom
Posts: 442
Joined: Wed Nov 11, 2020 4:44 am
languages_spoken: english, polish
ODROIDs: N2+, Game Advance, a few XU4
Location: Gdansk, Poland
Has thanked: 49 times
Been thanked: 42 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by mctom »

On the hardware side, this would be helpful to know what kind of power source did you use and what was plugged into the USB ports when this happened.

It seems that Linux is aware of two USB hubs in your system.
If you have a USB hub that has independent power supply, try if your devices work with it.
Punk ain't no religious cult, punk means thinking for yourself!

Maintainer of PiStackMon

Suuvs
Posts: 10
Joined: Tue Jan 26, 2021 10:34 pm
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by Suuvs »

mctom wrote:
Sun Aug 08, 2021 4:37 am
On the hardware side, this would be helpful to know what kind of power source did you use and what was plugged into the USB ports when this happened.

It seems that Linux is aware of two USB hubs in your system.
If you have a USB hub that has independent power supply, try if your devices work with it.
Im using the power supply that Hardkernel themselves supplied the device with.

The only thing that was plugged into the usb ports was a Western Digital My Passport Ultra 2TB, that has been connected to the N2+ for its entire lifespan basically.

Sadly i dont have a powered usb hub, but i tried using a regular usb stick to see if something low power would work, but no dice :(

User avatar
tobetter
Posts: 8398
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1325 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by tobetter »

Suuvs wrote:
Sun Aug 08, 2021 5:56 am
mctom wrote:
Sun Aug 08, 2021 4:37 am
On the hardware side, this would be helpful to know what kind of power source did you use and what was plugged into the USB ports when this happened.

It seems that Linux is aware of two USB hubs in your system.
If you have a USB hub that has independent power supply, try if your devices work with it.
Im using the power supply that Hardkernel themselves supplied the device with.

The only thing that was plugged into the usb ports was a Western Digital My Passport Ultra 2TB, that has been connected to the N2+ for its entire lifespan basically.

Sadly i dont have a powered usb hub, but i tried using a regular usb stick to see if something low power would work, but no dice :(
Can you please check the voltage at pin #1 and #2 on GPIO pin header?
https://wiki.odroid.com/_media/odroid-n ... tok=31e93c

Also would you be able to take a photo that shows HDMI and one big IC around HDMI ports on your N2Plus? Clear / high resolution one would be nice.

Suuvs
Posts: 10
Joined: Tue Jan 26, 2021 10:34 pm
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by Suuvs »

Can you please check the voltage at pin #1 and #2 on GPIO pin header?
https://wiki.odroid.com/_media/odroid-n ... tok=31e93c

Also would you be able to take a photo that shows HDMI and one big IC around HDMI ports on your N2Plus? Clear / high resolution one would be nice.
3.3v and 5volt from pin 1 and 2.

I assume you wanted a picture of this part, sorry if i misunderstood :)
Attachments
ODROIDN2.JPEG
ODROIDN2.JPEG (864.88 KiB) Viewed 343 times

User avatar
tobetter
Posts: 8398
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1325 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by tobetter »

Suuvs wrote:
Sun Aug 08, 2021 7:45 am
Can you please check the voltage at pin #1 and #2 on GPIO pin header?
https://wiki.odroid.com/_media/odroid-n ... tok=31e93c

Also would you be able to take a photo that shows HDMI and one big IC around HDMI ports on your N2Plus? Clear / high resolution one would be nice.
3.3v and 5volt from pin 1 and 2.

I assume you wanted a picture of this part, sorry if i misunderstood :)
Thanks, this is the photo what I exactly wanted and it clear enough.
Unfortunately, I am not able to find a spot explicitly damaged on the board.
Since the voltages at pin #1 and #2 are correct respectively and the output of lsusb does not shows the on-board USB controller, the USB hub seems to be damaged.

User avatar
mctom
Posts: 442
Joined: Wed Nov 11, 2020 4:44 am
languages_spoken: english, polish
ODROIDs: N2+, Game Advance, a few XU4
Location: Gdansk, Poland
Has thanked: 49 times
Been thanked: 42 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by mctom »

Okay, now I see what's missing. Here's my output:

Code: Select all

mctom@Tomusiomat-ARM:~$ lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 5000M
        |__ Port 4: Dev 3, If 0, Class=Mass Storage, Driver=uas, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
(...)
tobetter wrote:
Sun Aug 08, 2021 9:54 am
Since the voltages at pin #1 and #2 are correct respectively and the output of lsusb does not shows the on-board USB controller, the USB hub seems to be damaged.
I'm confident this is probably the right diagnosis. GL3523 is the USB hub chip, you can even see traces coming from it to USB ports. If it's hot during operation it's surely busted, but otherwise the damage may be more subtle and not directly in it.
I'd suggest replacing both N2+ and its power supply.

I am really curious how all this happened, though. After all it's not usual to break stuff by cutting off the supply voltage. I suspect there might be something wrong with power adapter, maybe? :roll:
Punk ain't no religious cult, punk means thinking for yourself!

Maintainer of PiStackMon

Suuvs
Posts: 10
Joined: Tue Jan 26, 2021 10:34 pm
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by Suuvs »

Since the voltages at pin #1 and #2 are correct respectively and the output of lsusb does not shows the on-board USB controller, the USB hub seems to be damaged.

I'm confident this is probably the right diagnosis. GL3523 is the USB hub chip, you can even see traces coming from it to USB ports. If it's hot during operation it's surely busted, but otherwise the damage may be more subtle and not directly in it.
I'd suggest replacing both N2+ and its power supply.

I am really curious how all this happened, though. After all it's not usual to break stuff by cutting off the supply voltage. I suspect there might be something wrong with power adapter, maybe? :roll:

I cant really tell that much about how it happened haha, it wasnt that unusual. I woke up after sleeping and found out that we had a power outtage (probably a tree hitting a powerline since it was very windy). The N2+ was connected to a power strip with the official Hardkernel supplied power supply (the barrel jack one).

Thanks so much for all of your help everyone! eventhough the result was what i feared :S

Next time i should buy a surge protector!

User avatar
rooted
Posts: 8729
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 743 times
Been thanked: 376 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by rooted »

You can use a separate powered USB hub, if you don't power devices through the USB this would be less likely to occur even though it's already unlikely.

User avatar
mad_ady
Posts: 9696
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 609 times
Been thanked: 721 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by mad_ady »

One more thing you can try is to use a usb-otg adapter and try out the otg port. If it works you'll be downgraded to usb2 speeds, though.
If it doesn't work, you can still use the N2 as a server or as a network media player, so I wouldn't throw it away.

L67GS
Posts: 578
Joined: Wed Apr 22, 2020 3:02 pm
languages_spoken: English, Jibberish, Pig Latin
ODROIDs: XU4, C1+,(3) C0's, and a whole big pile of accessories, VU7A Plus,, ect....
Location: Great Lakes Region, U.S.A
Has thanked: 159 times
Been thanked: 83 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by L67GS »

Tobetter, does the seventh pin from the right (pin 13) along the bottom on the hub controller have something bad going on?

User avatar
mctom
Posts: 442
Joined: Wed Nov 11, 2020 4:44 am
languages_spoken: english, polish
ODROIDs: N2+, Game Advance, a few XU4
Location: Gdansk, Poland
Has thanked: 49 times
Been thanked: 42 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by mctom »

L67GS wrote:
Mon Aug 09, 2021 2:53 pm
Tobetter, does the seventh pin from the right (pin 13) along the bottom on the hub controller have something bad going on?
You mean pin 10?
scrn-2021-08-09-10-26-11.png
scrn-2021-08-09-10-26-11.png (88.27 KiB) Viewed 304 times
Punk ain't no religious cult, punk means thinking for yourself!

Maintainer of PiStackMon

L67GS
Posts: 578
Joined: Wed Apr 22, 2020 3:02 pm
languages_spoken: English, Jibberish, Pig Latin
ODROIDs: XU4, C1+,(3) C0's, and a whole big pile of accessories, VU7A Plus,, ect....
Location: Great Lakes Region, U.S.A
Has thanked: 159 times
Been thanked: 83 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by L67GS »

mctom wrote:
Mon Aug 09, 2021 5:27 pm

You mean pin 10?
No
Screenshot_20210809-094309.png
Screenshot_20210809-094309.png (67.41 KiB) Viewed 291 times
These users thanked the author L67GS for the post:
mctom (Mon Aug 09, 2021 11:03 pm)

User avatar
mctom
Posts: 442
Joined: Wed Nov 11, 2020 4:44 am
languages_spoken: english, polish
ODROIDs: N2+, Game Advance, a few XU4
Location: Gdansk, Poland
Has thanked: 49 times
Been thanked: 42 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by mctom »

Hah, that must be the first time to see the same chip in two different sizes of the same type of package :D
Well maybe aside from ol 741.

Anyway, I still don't think it's much of a concern. The QFN chip on the far left (LAN controller?) have all sorts of joint finishes. Or maybe not?
Punk ain't no religious cult, punk means thinking for yourself!

Maintainer of PiStackMon

L67GS
Posts: 578
Joined: Wed Apr 22, 2020 3:02 pm
languages_spoken: English, Jibberish, Pig Latin
ODROIDs: XU4, C1+,(3) C0's, and a whole big pile of accessories, VU7A Plus,, ect....
Location: Great Lakes Region, U.S.A
Has thanked: 159 times
Been thanked: 83 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by L67GS »

That could be camera trickery but it looks like a cold solder joint

Suuvs
Posts: 10
Joined: Tue Jan 26, 2021 10:34 pm
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by Suuvs »

Oh sorry i didnt realize people were still discussing this haha :) Yeah one of the joints looked kinda sus in the picture, but i dont have any way of getting a closer picture :(

OH, and do you guys think its 100% safe to use the N2 still, like theres no shorts or anything like that that could cause damages or heat or something like that? I could just stick a 256 gig sd card in there and get a lot of mileage from it even still.

User avatar
tobetter
Posts: 8398
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1325 times
Contact:

Re: After Power Outage N2+ USB ports no longer work!

Post by tobetter »

L67GS wrote:
Mon Aug 09, 2021 2:53 pm
Tobetter, does the seventh pin from the right (pin 13) along the bottom on the hub controller have something bad going on?
It does really look like a cold solder joint but not sure...if it's the problem, I think only one port out of 4 would not work. I suspect GL3523 is damaged after power outage.
Suuvs wrote:
Thu Aug 12, 2021 8:31 am
OH, and do you guys think its 100% safe to use the N2 still, like theres no shorts or anything like that that could cause damages or heat or something like that? I could just stick a 256 gig sd card in there and get a lot of mileage from it even still.
I guess the on-board USB hub GL3523 is the damaged if still it boots from SD and USB OTG port works. You could check overall current and inspect unusual heat on the board, specifically GL3523. I would use it as-is after having very stressed test for several days to check other peripherals and CPU still can work.

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 0 guests