[SOLVED] ODROID C4 won't boot using official Android image

Post Reply
starkoala
Posts: 1
Joined: Sun Jul 11, 2021 6:13 pm
languages_spoken: english
ODROIDs: C4
Has thanked: 0
Been thanked: 1 time
Contact:

[SOLVED] ODROID C4 won't boot using official Android image

Post by starkoala »

Hi,

I recently received two ODROID C4 boards, and tried to boot using the official Android image.
I tried using the latest image, as well as the one before it:

- https://wiki.odroid.com/odroid-c4/os_im ... 4_20210628
- https://wiki.odroid.com/odroid-c4/os_im ... 4_20210531

In both cases I verified MD5 checksum for the downloaded file.
I wrote the image to microSD card using my laptop's builtin SD card reader, using dd, and then also verified that the image written to the microSD card matched the MD5 checksum.
I tried using two different microSD cards, a Kingston (Kingston Micro SDHC Canvas Select Plus UHS-I SDCS2/16GB) and SanDisk (SanDisk Ultra 64GB microSDXC UHS-I Card SDSQUNC-064G-GN6MA).
I tried booting from both of the boards, in both cases the red LED turned on once I connected the power cord (constant, non-blinking red LED), and I saw no blinking LED. I saw no output to HDMI when connected to my TV. I tried waiting 10 minutes and then power cycling again, but nothing changed (only power and HDMI were connected).

What else can I try to debug this? I don't have a UART cable/adapter.

Thanks.

EDIT:
I feel very silly for missing this, but I'll document it here for future readers, in case anyone makes the same mistake.
I accidentally wrote the image to an existing partition on my SD card, instead of writing to the device itself. It's definitely not my first time writing an image to SD card using dd, which makes this even more embarrassing.

I used: of=/dev/mmcblk0p1
When I should have used: of=/dev/mmcblk0

Maybe this helps someone in the future. :)
These users thanked the author starkoala for the post:
odroid (Mon Jul 12, 2021 10:11 am)

User avatar
rooted
Posts: 8630
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 743 times
Been thanked: 359 times
Contact:

Re: [SOLVED] ODROID C4 won't boot using official Android image

Post by rooted »

Glad you got it sorted.

User avatar
mad_ady
Posts: 9541
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 604 times
Been thanked: 693 times
Contact:

Re: [SOLVED] ODROID C4 won't boot using official Android image

Post by mad_ady »

Could have been worse... Could have been written to a partition on your hdd!
I have a colleague who did this trying to run a speed benchmark on a disk. Except he ran it in the wrong terminal on a production server... Guess who stayed up late to try to recover some data?

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 1 guest