Analogue stick not responding on newly built OGA

Post Reply
geezer500
Posts: 20
Joined: Thu Feb 25, 2021 5:57 am
languages_spoken: english
Has thanked: 13 times
Been thanked: 5 times
Contact:

Analogue stick not responding on newly built OGA

Post by geezer500 »

I have just built 3 OGA's for myself and my kids.

The first two work just fine.

I'm having problems with the 3rd one's Analog Joystick.
It's simply not registering....

The ZIF clip is undamaged and closes correctly (it clicks down) and the ribbon cable appears to be undamaged.

I certainly had no issues building it especially after having just built the other 2 (I made a few mistakes with them and had to open them up a couple of times)
In the button test screen nothing registers when it is fully inserted and the clip closed.

If I open the clip and remove and reinsert it or wiggle it a bit in the connector, It sometimes registers a left or right or both (never up or down).
Is it the joystick itself that might be damaged or would it be the connector on the motherboard?
I read the sticky post on this forum (which says to open and reseat the connector) and have reattached the connector at least half a dozen times now.

I don't really want to have to remove one of the other joysticks from a working and closed machine to test this motherboard.
Is there any way for me to test what piece is faulty?

Thanks

User avatar
odroid
Site Admin
Posts: 37573
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1858 times
Been thanked: 1163 times
Contact:

Re: Analogue stick not responding on newly built OGA

Post by odroid »

These users thanked the author odroid for the post:
geezer500 (Mon May 10, 2021 6:54 am)

geezer500
Posts: 20
Joined: Thu Feb 25, 2021 5:57 am
languages_spoken: english
Has thanked: 13 times
Been thanked: 5 times
Contact:

Re: Analogue stick not responding on newly built OGA

Post by geezer500 »

odroid wrote:
Sun May 09, 2021 9:51 pm
Try 'factory test' mode.
https://wiki.odroid.com/odroid-c4/softw ... d-c4ubuntu
Hi ,

Thanks for the reply...

Do you mean (factory test mode), holding down R1+L1 and power during boot to get to the button test.
That's what I have been doing and it's not registering at all (not turning blue).

I'm going to probably open up one of the working ones and test it's (working) joystick on this motherboard tomorrow.
That way I can establish whether it's the board or the joystick..

User avatar
odroid
Site Admin
Posts: 37573
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1858 times
Been thanked: 1163 times
Contact:

Re: Analogue stick not responding on newly built OGA

Post by odroid »

I see.
Once you find a root cause, just let me know. We will help you.

BTW, where/when did you buy three OGA-BE units?

geezer500
Posts: 20
Joined: Thu Feb 25, 2021 5:57 am
languages_spoken: english
Has thanked: 13 times
Been thanked: 5 times
Contact:

Re: Analogue stick not responding on newly built OGA

Post by geezer500 »

odroid wrote:
Mon May 10, 2021 10:27 am
I see.
Once you find a root cause, just let me know. We will help you.

BTW, where/when did you buy three OGA-BE units?
Sorry for the late reply... I had to wait until one the kids would give up their OGA for me to test it. :-)
I did swap the joystick from a working unit and it was in fact the joystick that isn't working.
My one is completely dead... I tested it in the working OGA as well as my own.. It simply doesn't register anything in the button test
Whereas the other joystick works fine in both machines.
It looks fine - completely new.

I've ordered a VITA replacement, which I was probably going to do anyway, so no big deal, just a delay in time really.

I did in fact order 4 OGAs from Ameridroid for last Christmas (1 for me, 2 for my kids & 1 for my nephew), but they got lost in shipping.
After a bit of time sorting out with the freight insurance co. I finally received all 4 about 6 weeks ago.
I didn't give them or build mine then because I waited for their birthdays to come around.. which was about 2 weeks ago, hence the delay in receiving and building.

User avatar
odroid
Site Admin
Posts: 37573
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1858 times
Been thanked: 1163 times
Contact:

Re: Analogue stick not responding on newly built OGA

Post by odroid »

Thank you for the detail story about how Christmas gift could be changed to their birthdays one. :oops:

I believe Ameridroid send you this spare parts kit once you contact them.
https://www.hardkernel.com/shop/joystic ... o-advance/

If you still have any problem with the Vita replacement analog stick, please contact Ameridroid.
These users thanked the author odroid for the post:
geezer500 (Tue May 18, 2021 8:13 pm)

geezer500
Posts: 20
Joined: Thu Feb 25, 2021 5:57 am
languages_spoken: english
Has thanked: 13 times
Been thanked: 5 times
Contact:

Re: Analogue stick not responding on newly built OGA

Post by geezer500 »

odroid wrote:
Tue May 18, 2021 9:31 am
Thank you for the detail story about how Christmas gift could be changed to their birthdays one. :oops:

I believe Ameridroid send you this spare parts kit once you contact them.
https://www.hardkernel.com/shop/joystic ... o-advance/

If you still have any problem with the Vita replacement analog stick, please contact Ameridroid.
Thanks for the heads-up...
Hopefully there shouldn't be a problem with the VITA joystick as everything worked when I tested the other joystick from the working OGA.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests