[SOLVED] Issues flashing Images to eMMC

Post Reply
Jevvybee
Posts: 3
Joined: Sat Mar 06, 2021 12:00 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 1 time
Been thanked: 1 time
Contact:

[SOLVED] Issues flashing Images to eMMC

Post by Jevvybee »

Hello everyone,

I am having some real problems getting images to boot on my XU4 from eMMC and I wonder if any of you can assist.

I have an XU4 with the OGST Gaming Case, and I am able to flash and run images (in my case OGST and Batocera) from micro SD. It runs well, but I want to use the eMMC as it is faster and less likely to suffer the consequences of many writes/rewrites over time. My particular interest is in N64 emulation, and running those ROMs on the micro SD (Sandisk Ultra and I’ve also tried Samsung EVO) are jittery - so I’m hoping that the faster eMMC will allow better performance here. I have gone round in circles now many times trying to get the eMMC to work, and have not managed it yet…

The Orange 16GB eMMC came from Odroid with Linux installed. I didn’t need that, so simply tried flashing Batocera to the card and tried to run it. The blue light on the XU4 stays on forever, no output and no power to the usb’s - so it didn’t boot. Ok no problem I thought - so I completed the eMMC recovery procedure: https://wiki.odroid.com/accessory/emmc/recovery_xu4. The eMMC boots into Android so it must be working. Next I tried re-flashing Batocera to the eMMC. Same result, blue light stays on without booting. I went back over my steps, flashed the micro SD’s to check the images are working, all fine. I have tried flashing the eMMC from Windows 10 and from Linux - still the same blue light and no boot. Have tried Etcher and Win32 Disk Imager. Have tried unpacking the images using WinRar and 7-Zip. Still nothing. I have found that, in Etcher, Windows fails the verification at 99% while flashing the Batocera image. Linux completes it successfully. Now to be honest I am out of ideas and a bit fatigued of this process….

So what I think I understand (please do help me here if I’m wrong); the eMMC needs to have a boot file (blob?) written into it, which is on a hidden partition and is created whilst completing the eMMC recovery procedure. When you then flash the Batocera Image to the eMMC, that boot file should remain somewhere(?) and allow the eMMC to boot when it’s in the XU4. I don’t know if that’s exactly how it works as I’m new to this, but this is where I think the problem lies.

If anyone can assist then I’d be most grateful
Jev

User avatar
odroid
Site Admin
Posts: 37286
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1749 times
Been thanked: 1127 times
Contact:

Re: Issues flashing Images to eMMC

Post by odroid »

I believe you did as much as you can. There is nothing wrong so far.

I think the Batocera image might not support the eMMC just in case.
Try flashing the OGST image to your eMMC to narrow down root causes.
Remove your microSD card and set the boot mode switch at 'eMMC' for the test.
These users thanked the author odroid for the post:
Jevvybee (Fri Mar 12, 2021 4:01 am)

Jevvybee
Posts: 3
Joined: Sat Mar 06, 2021 12:00 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: Issues flashing Images to eMMC

Post by Jevvybee »

odroid wrote:
Thu Mar 11, 2021 12:26 pm
I believe you did as much as you can. There is nothing wrong so far.

I think the Batocera image might not support the eMMC just in case.
Try flashing the OGST image to your eMMC to narrow down root causes.
Remove your microSD card and set the boot mode switch at 'eMMC' for the test.
Thank you Odroid for your response.

You are indeed correct. The 5.30 image of Batocera is not compatible with eMMC.

I have flashed the eMMC with Ubuntu & Retropie and the it works fine with those, also with Android as per the recovery procedure. I shall take this back to Batocera so that they know of the issue.

Much Appreciated,
Jev
These users thanked the author Jevvybee for the post:
odroid (Fri Mar 12, 2021 11:20 am)

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 2 guests