[SOLVED] Odroid-GO Super: no sound from speaker

Locked
crazyquark
Posts: 346
Joined: Thu Jan 15, 2015 4:22 pm
languages_spoken: english, french, romanian
ODROIDs: C1,C1+,C2,HC1,XU4
Has thanked: 8 times
Been thanked: 19 times
Contact:

[SOLVED] Odroid-GO Super: no sound from speaker

Post by crazyquark »

Hello,

I finally got an Odroid-Go super and I installed the default Ubuntu image.
However, I have no sound; if I plug in headphones on the audio jack I can hear sound but not from the built-in speaker.
I tried messing around with the settings in the audio menu but I couldn't get it to work...

mad_ady
Posts: 9373
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 599 times
Been thanked: 659 times
Contact:

Re: Odroid-GO Super: no sound from speaker

Post by mad_ady »

Most likely the speaker came loose. You may need to take off the cover and reseat the connector
These users thanked the author mad_ady for the post:
crazyquark (Thu Mar 04, 2021 3:53 pm)

User avatar
odroid
Site Admin
Posts: 37281
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1747 times
Been thanked: 1127 times
Contact:

Re: Odroid-GO Super: no sound from speaker

Post by odroid »

If the plug detection switch in the headphone jack didn't work, you could meet the issue.
Plug and unplug your earphone several times to see any difference.
Also try the audio test function in the factory mode.
https://wiki.odroid.com/odroid_go_advan ... odroidtest
These users thanked the author odroid for the post:
crazyquark (Thu Mar 04, 2021 3:53 pm)

crazyquark
Posts: 346
Joined: Thu Jan 15, 2015 4:22 pm
languages_spoken: english, french, romanian
ODROIDs: C1,C1+,C2,HC1,XU4
Has thanked: 8 times
Been thanked: 19 times
Contact:

Re: Odroid-GO Super: no sound from speaker

Post by crazyquark »

odroid wrote:
Thu Mar 04, 2021 9:44 am
If the plug detection switch in the headphone jack didn't work, you could meet the issue.
Plug and unplug your earphone several times to see any difference.
Also try the audio test function in the factory mode.
https://wiki.odroid.com/odroid_go_advan ... odroidtest
The audio test detects the audio jack and I can hear a faint noise on headphones but nothing on speakers.
I will try taking it apart and checking the speaker connection next.

crazyquark
Posts: 346
Joined: Thu Jan 15, 2015 4:22 pm
languages_spoken: english, french, romanian
ODROIDs: C1,C1+,C2,HC1,XU4
Has thanked: 8 times
Been thanked: 19 times
Contact:

Re: Odroid-GO Super: no sound from speaker

Post by crazyquark »

mad_ady wrote:
Thu Mar 04, 2021 4:43 am
Most likely the speaker came loose. You may need to take off the cover and reseat the connector
Yup! This was it, the speaker was not properly connected to the board.
Thank you

Topic closed
These users thanked the author crazyquark for the post:
odroid (Fri Mar 05, 2021 9:28 am)

Locked

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests