[SOLVED] Odroid C4 no longer working with CoreElec

Post Reply
lordcy
Posts: 31
Joined: Sun Dec 21, 2014 12:19 pm
languages_spoken: English
ODROIDs: C1, C2, XU4, N2, C4
Location: New Orleans, LA, USA
Has thanked: 2 times
Been thanked: 0
Contact:

[SOLVED] Odroid C4 no longer working with CoreElec

Post by lordcy »

I've been using the C4 as a CoreElec box since my purchase in Oct 2020 from Ameridroid (Order AD33159). A couple of days ago, Kodi started acting up (what I thought) and my HDHomerun app would not play any channels (it just kept trying to load them). HDHomerun is working on my N2 in another room and on a RPI3 in that same room where the C4 was. I've tried reimaging the SD card and have even used the same re-imaged SD card in the RPI3 and N2 and HDHomerun works. Tried wired and wireless, both have the same issue on the C4. Has my C4 broke after only 3 months of use??? Please advise if there is other tests I should run to test C4. Pretty worthless to me if I can't use it as a CoreElec box to watch my local TV channels...

LordCy

mad_ady
Posts: 9067
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 596 times
Been thanked: 578 times
Contact:

Re: Odroid C4 no longer working with CoreElec

Post by mad_ady »

Most likely it's a software issue somewhere... Check ip connectivity between c4 and your hdhomerun, check logs on both systems, google for error messages, try restoring a working backup, etc...
These users thanked the author mad_ady for the post:
lordcy (Tue Jan 12, 2021 6:12 am)

lordcy
Posts: 31
Joined: Sun Dec 21, 2014 12:19 pm
languages_spoken: English
ODROIDs: C1, C2, XU4, N2, C4
Location: New Orleans, LA, USA
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Odroid C4 no longer working with CoreElec

Post by lordcy »

Thanks. It doesn't appear to be a network connectivity issue. The HDHomerun addon opens but it won't play the channels. The guide actually works and it attempts to play channels. I have other Kodi boxes around my house that are still working both wired and wireless in the same vlan. Here are some logs from Kodi.

2021-01-11 14:03:33.295 T:3599537024 NOTICE: script.hdhomerun.view: Version: 2019.9.15
2021-01-11 14:03:33.296 T:3599537024 NOTICE: script.hdhomerun.view: Current Kodi skin: skin.estuary
2021-01-11 14:03:33.644 T:3599537024 NOTICE: script.hdhomerun.view: Cron started
2021-01-11 14:03:33.717 T:3599537024 NOTICE: script.hdhomerun.view: Touch mode: DISABLED
2021-01-11 14:03:33.721 T:3599537024 NOTICE: script.hdhomerun.view: o-> Broadcast Packet(0002000c0104ffffffff0204ffffffff73cc7d8f)
2021-01-11 14:03:33.721 T:3599537024 NOTICE: script.hdhomerun.view: o-> Broadcasting to lo: 127.255.255.255
2021-01-11 14:03:33.722 T:3599537024 NOTICE: script.hdhomerun.view: o-> Broadcasting to eth0: 192.168.1.255
2021-01-11 14:03:33.801 T:3599537024 NOTICE: script.hdhomerun.view: <-o Response Packet[eth0](0003006501040000000102041070623b2b186e764f646545497439316378687745627864546c527948362a16687474703a2f2f3139322e3136382e312e33333a38301001042722687474703a2f2f3139322e3136382e312e33333a38302f6c696e6575702e6a736f6ef7d03ccc)
2021-01-11 14:03:33.983 T:3599537024 NOTICE: script.hdhomerun.view: o-> Broadcasting to lo: 127.255.255.255
2021-01-11 14:03:33.984 T:3599537024 NOTICE: script.hdhomerun.view: o-> Broadcasting to eth0: 192.168.1.255
2021-01-11 14:03:34.005 T:3599537024 NOTICE: script.hdhomerun.view: <-o Response Packet[eth0](Duplicate)
2021-01-11 14:03:34.308 T:3599537024 NOTICE: script.hdhomerun.view:
Device at 192.168.1.33:
ID: 1070623b
Type: TunerDevice
DeviceAuth: nvOdeEIt91cxhwEbxdTlRyH6
URL: http://192.168.1.33:80/lineup.json?show=demo
Channels: 59
2021-01-11 14:03:34.309 T:3599537024 NOTICE: script.hdhomerun.view: Fetching guide from: http://api.hdhomerun.com/api/guide.php? ... EbxdTlRyH6
2021-01-11 14:03:34.651 T:3599537024 NOTICE: script.hdhomerun.view: Guide data received.
2021-01-11 14:03:34.674 T:3599537024 NOTICE: script.hdhomerun.view: Next guide update: 54 minutes
2021-01-11 14:03:35.692 T:3599537024 NOTICE: script.hdhomerun.view: Found 59 total channels
2021-01-11 14:03:35.692 T:3599537024 NOTICE: script.hdhomerun.view: HDHR video not currently playing. Starting channel...
2021-01-11 14:03:35.741 T:3599537024 NOTICE: script.hdhomerun.view: Playing from source: 1070623b
2021-01-11 14:03:35.792 T:4061249552 NOTICE: VideoPlayer::OpenFile: http://192.168.1.33:5004/auto/v4.1
2021-01-11 14:03:35.799 T:3574358912 NOTICE: Creating InputStream
2021-01-11 14:03:35.909 T:3599537024 NOTICE: script.hdhomerun.view: ON PLAYBACK STARTED
2021-01-11 14:03:36.908 T:3574358912 NOTICE: Creating Demuxer
2021-01-11 14:03:49.784 T:3574358912 NOTICE: Opening stream: 0 source: 256
2021-01-11 14:03:49.784 T:3574358912 WARNING: OpenStream - Unsupported stream 0. Stream disabled.
2021-01-11 14:03:49.784 T:3574358912 NOTICE: Opening stream: 1 source: 256
2021-01-11 14:03:49.784 T:3574358912 NOTICE: Finding audio codec for: 86019
2021-01-11 14:03:49.785 T:3574358912 NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder ac3
2021-01-11 14:03:49.785 T:3574358912 NOTICE: Creating audio thread
2021-01-11 14:03:49.785 T:3531563904 NOTICE: running thread: CVideoPlayerAudio::Process()
2021-01-11 14:03:49.786 T:3574358912 NOTICE: CDVDDemuxFFmpeg::Read() stream change
2021-01-11 14:03:49.787 T:3574358912 NOTICE: Opening stream: 0 source: 256
2021-01-11 14:03:49.787 T:3574358912 NOTICE: CVideoPlayerVideo::OpenStream - Creating codec: 2
2021-01-11 14:03:49.789 T:3574358912 NOTICE: Creating video thread
2021-01-11 14:03:49.789 T:3574358912 NOTICE: Opening stream: 1 source: 256
2021-01-11 14:03:49.790 T:3523171200 NOTICE: running thread: video_thread
2021-01-11 14:03:49.796 T:3531563904 NOTICE: Creating audio stream (codec id: 86019, channels: 6, sample rate: 48000, no pass-through)
2021-01-11 14:03:49.861 T:4061249552 NOTICE: Whitelist search for: width: 1920, height: 1080, fps: 59.940, 3D: false
2021-01-11 14:03:49.862 T:4061249552 NOTICE: Display resolution ADJUST : 1920x1080 @ 59.94 - Full Screen (25) (weight: 0.000)
2021-01-11 14:03:49.874 T:4061249552 NOTICE: VideoPlayer: OnLostDisplay received
2021-01-11 14:03:49.875 T:4061249552 ERROR: GetString: error reading /sys/class/amhdmitx/amhdmitx0/custom_mode
2021-01-11 14:03:50.040 T:4061249552 NOTICE: VideoPlayer: OnResetDisplay received
2021-01-11 14:03:52.369 T:4039525248 WARNING: ActiveAE - large audio sync error: -1857.309740
2021-01-11 14:03:52.370 T:4039525248 WARNING: ActiveAE - large audio sync error: -1857.310449
2021-01-11 14:03:52.371 T:4039525248 WARNING: ActiveAE - large audio sync error: -1857.309865
2021-01-11 14:03:52.845 T:3531563904 NOTICE: CVideoPlayerAudio::Process - stream stalled
2021-01-11 14:04:48.916 T:3523171200 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
2021-01-11 14:04:49.281 T:4039525248 WARNING: ActiveAE - large audio sync error: -10018.819037
2021-01-11 14:04:49.285 T:4039525248 WARNING: ActiveAE - large audio sync error: -9924.081038
2021-01-11 14:04:49.286 T:4039525248 WARNING: ActiveAE - large audio sync error: -9924.929871
2021-01-11 14:04:49.287 T:4039525248 WARNING: ActiveAE - large audio sync error: -9925.785330
2021-01-11 14:04:49.290 T:4039525248 WARNING: ActiveAE - large audio sync error: -9977.215038
2021-01-11 14:04:49.291 T:4039525248 WARNING: Previous line repeats 1 times.

LordCy

lordcy
Posts: 31
Joined: Sun Dec 21, 2014 12:19 pm
languages_spoken: English
ODROIDs: C1, C2, XU4, N2, C4
Location: New Orleans, LA, USA
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Odroid C4 no longer working with CoreElec

Post by lordcy »

While the logs do not show a network issue, it is most likely the case. Thanks for helping me pinpoint it. I upgraded DD-WRT on my main router and rebooted. After the reboot, it's working again. I'm not sure what the issue was but I will try to track it down in the DD-WRT logs. Thanks.

LordCy

mad_ady
Posts: 9067
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 596 times
Been thanked: 578 times
Contact:

Re: [SOLVED] Odroid C4 no longer working with CoreElec

Post by mad_ady »

Most likely the router reboot helped...

Post Reply

Return to “Other OS”

Who is online

Users browsing this forum: No registered users and 0 guests