RRVL (Retro Roller) OGA 1.0/1.1; OGS

Third party OS images and hardware mods
Post Reply
crashoverride
Posts: 5213
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1
Has thanked: 0
Been thanked: 399 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by crashoverride »

shanti wrote:
Mon Jan 04, 2021 2:35 pm
Duckstation at the moment runs better in "software" renderer than in GPU renderer, maybe try it in software mode?
I tried the software renderer, and it does perform better. However, it is currently unable to maintain 60 FPS in many places. I will wait for further improvements before using it in the Reference Image.

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by valadaa48 »

crashoverride wrote:
Mon Jan 04, 2021 5:34 pm
shanti wrote:
Mon Jan 04, 2021 2:35 pm
Duckstation at the moment runs better in "software" renderer than in GPU renderer, maybe try it in software mode?
I tried the software renderer, and it does perform better. However, it is currently unable to maintain 60 FPS in many places. I will wait for further improvements before using it in the Reference Image.
You may consider implementing software framebuffer support in retrorun to mitigate the extra frame buffer copy. https://github.com/libretro/RetroArch/c ... baf2e4e9b1 is my commit for the oga gfx driver in retroarch.

Duckstation is one of the only cores that implement this feature.

stellarvelocity
Posts: 2
Joined: Fri Jan 08, 2021 5:10 am
languages_spoken: english
ODROIDs: OGA 1.1
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: RRVL Final / Retro Roller 3.0 RC

Post by stellarvelocity »

valadaa48 wrote:
Thu Dec 31, 2020 10:57 pm
Latest update has global hotkeys upgraded to grab input so now when hitting F5+ vol/brightness, input events don't reflect in whatever you're running anymore.
Ever since this update rolled out whenever I press F5 for any reason in game, upon opening the Retroarch Menu I lose all input control and I have to hard power off the console to regain controller use. The system isn't locked up, I can see the UI elements flashing as normal. I've tried plugging in USB controllers to troubleshoot but RA doesn't recognize them in this state.

I also noticed if I press F5 when the system boots the RA menu starts scrolling at a nearly uncontrollable faster speed and then after I launch a game and open the menu, it freezes the controls again.

I've ran the updater a few times and tried remapping around F5 for now. Any ideas to avoid having to reflash the entire 265gb card?

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL Final / Retro Roller 3.0 RC

Post by valadaa48 »

stellarvelocity wrote:
Fri Jan 08, 2021 5:17 am
valadaa48 wrote:
Thu Dec 31, 2020 10:57 pm
Latest update has global hotkeys upgraded to grab input so now when hitting F5+ vol/brightness, input events don't reflect in whatever you're running anymore.
Ever since this update rolled out whenever I press F5 for any reason in game, upon opening the Retroarch Menu I lose all input control and I have to hard power off the console to regain controller use. The system isn't locked up, I can see the UI elements flashing as normal. I've tried plugging in USB controllers to troubleshoot but RA doesn't recognize them in this state.

I also noticed if I press F5 when the system boots the RA menu starts scrolling at a nearly uncontrollable faster speed and then after I launch a game and open the menu, it freezes the controls again.

I've ran the updater a few times and tried remapping around F5 for now. Any ideas to avoid having to reflash the entire 265gb card?
Are you on the oga 1.1? What happens if you go to Configure File / Reset to Defaults (you'll lose input) then F5+Power to shutoff then power back on? Does it fix it?

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL Final / Retro Roller 3.0 RC

Post by valadaa48 »

valadaa48 wrote:
Fri Jan 08, 2021 7:56 am
stellarvelocity wrote:
Fri Jan 08, 2021 5:17 am
valadaa48 wrote:
Thu Dec 31, 2020 10:57 pm
Latest update has global hotkeys upgraded to grab input so now when hitting F5+ vol/brightness, input events don't reflect in whatever you're running anymore.
Ever since this update rolled out whenever I press F5 for any reason in game, upon opening the Retroarch Menu I lose all input control and I have to hard power off the console to regain controller use. The system isn't locked up, I can see the UI elements flashing as normal. I've tried plugging in USB controllers to troubleshoot but RA doesn't recognize them in this state.

I also noticed if I press F5 when the system boots the RA menu starts scrolling at a nearly uncontrollable faster speed and then after I launch a game and open the menu, it freezes the controls again.

I've ran the updater a few times and tried remapping around F5 for now. Any ideas to avoid having to reflash the entire 265gb card?
Are you on the oga 1.1? What happens if you go to Configure File / Reset to Defaults (you'll lose input) then F5+Power to shutoff then power back on? Does it fix it?
OK we added a reset_rrvl script in /roms/_rrvl/. Can you run that from retroarch and the system will reboot with reset configs to stock. It should fix your issue (someone on discord just tested this).

There have been a lot of changes since the OGS release to normalize the image. Namely all of the joystick devices changed and we had to create new SDL2 and retroarch mappings.

Let us know how it goes.

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL Final / Retro Roller 3.0 RC

Post by valadaa48 »

valadaa48 wrote:
Fri Jan 08, 2021 8:28 am
valadaa48 wrote:
Fri Jan 08, 2021 7:56 am
stellarvelocity wrote:
Fri Jan 08, 2021 5:17 am
valadaa48 wrote:
Thu Dec 31, 2020 10:57 pm
Latest update has global hotkeys upgraded to grab input so now when hitting F5+ vol/brightness, input events don't reflect in whatever you're running anymore.
Ever since this update rolled out whenever I press F5 for any reason in game, upon opening the Retroarch Menu I lose all input control and I have to hard power off the console to regain controller use. The system isn't locked up, I can see the UI elements flashing as normal. I've tried plugging in USB controllers to troubleshoot but RA doesn't recognize them in this state.

I also noticed if I press F5 when the system boots the RA menu starts scrolling at a nearly uncontrollable faster speed and then after I launch a game and open the menu, it freezes the controls again.

I've ran the updater a few times and tried remapping around F5 for now. Any ideas to avoid having to reflash the entire 265gb card?
Are you on the oga 1.1? What happens if you go to Configure File / Reset to Defaults (you'll lose input) then F5+Power to shutoff then power back on? Does it fix it?
OK we added a reset_rrvl script in /roms/_rrvl/. Can you run that from retroarch and the system will reboot with reset configs to stock. It should fix your issue (someone on discord just tested this).

There have been a lot of changes since the OGS release to normalize the image. Namely all of the joystick devices changed and we had to create new SDL2 and retroarch mappings.

Let us know how it goes.
Sorry for all of the noise. Another user reported the same issue and we determined that is was due to the new input grabbing mechanism of ogage. We released ogage 1.3.1 to fix the issue. Please update then reboot and it should be OK now.
These users thanked the author valadaa48 for the post (total 2):
odroid (Fri Jan 08, 2021 10:50 am) • stellarvelocity (Fri Jan 08, 2021 1:31 pm)

stellarvelocity
Posts: 2
Joined: Fri Jan 08, 2021 5:10 am
languages_spoken: english
ODROIDs: OGA 1.1
Has thanked: 1 time
Been thanked: 1 time
Contact:

Re: RRVL Final / Retro Roller 3.0 RC

Post by stellarvelocity »

valadaa48 wrote:
Fri Jan 08, 2021 9:54 am
valadaa48 wrote:
Fri Jan 08, 2021 8:28 am
valadaa48 wrote:
Fri Jan 08, 2021 7:56 am
stellarvelocity wrote:
Fri Jan 08, 2021 5:17 am
valadaa48 wrote:
Thu Dec 31, 2020 10:57 pm
Latest update has global hotkeys upgraded to grab input so now when hitting F5+ vol/brightness, input events don't reflect in whatever you're running anymore.
Ever since this update rolled out whenever I press F5 for any reason in game, upon opening the Retroarch Menu I lose all input control and I have to hard power off the console to regain controller use. The system isn't locked up, I can see the UI elements flashing as normal. I've tried plugging in USB controllers to troubleshoot but RA doesn't recognize them in this state.

I also noticed if I press F5 when the system boots the RA menu starts scrolling at a nearly uncontrollable faster speed and then after I launch a game and open the menu, it freezes the controls again.

I've ran the updater a few times and tried remapping around F5 for now. Any ideas to avoid having to reflash the entire 265gb card?
Are you on the oga 1.1? What happens if you go to Configure File / Reset to Defaults (you'll lose input) then F5+Power to shutoff then power back on? Does it fix it?
OK we added a reset_rrvl script in /roms/_rrvl/. Can you run that from retroarch and the system will reboot with reset configs to stock. It should fix your issue (someone on discord just tested this).

There have been a lot of changes since the OGS release to normalize the image. Namely all of the joystick devices changed and we had to create new SDL2 and retroarch mappings.

Let us know how it goes.
Sorry for all of the noise. Another user reported the same issue and we determined that is was due to the new input grabbing mechanism of ogage. We released ogage 1.3.1 to fix the issue. Please update then reboot and it should be OK now.
Okay, everything is working again after an update and a reboot. It is mixing F5 with the in-game controls again, but I am 100% okay with that as it doesn't often present any kind of issue normally (but I did appreciate you trying!). I absolutely love RVVL and it's my main image for OGA 1.1 and I can't wait to see it on the OGA Super here soon! Keep up the good work! Thanks!
These users thanked the author stellarvelocity for the post:
valadaa48 (Fri Jan 08, 2021 2:09 pm)

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by valadaa48 »

RRVL latest update moves retroarch core info files to /usr/share and the info files are now managed by a package. Same goes for the Retroarch joypad config files since we've seen at least 2 joypad updates and I figure having them managed by a package is the safest so you don't lose control.

P.S. We have a new RRVL theme setting for rgui for pro-users. Be sure to switch your graphics driver to 'oga' and menu to 'rgui' to give it a try!

micronaut
Posts: 10
Joined: Sun Jul 26, 2020 7:30 pm
languages_spoken: english
ODROIDs: Go Advance black edition
Has thanked: 4 times
Been thanked: 3 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by micronaut »

has the F3 + F4 hotkey to return to the menu screen changed with the latest update? I'm unable to exit any of the emulators on the OGA.

Thanks.

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by valadaa48 »

micronaut wrote:
Sat Jan 09, 2021 9:26 pm
has the F3 + F4 hotkey to return to the menu screen changed with the latest update? I'm unable to exit any of the emulators on the OGA.

Thanks.
Yes, unfortunately we had to unmap the hotkey due to the joypad button mapping changes between the OGA 1.0/1.1 and OGS. F1 - our previous hotkey is now select on the OGS. In effect we chose to reset the retroarch.cfg to avoid confusion.

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by valadaa48 »

valadaa48 wrote:
Sun Jan 10, 2021 1:02 am
micronaut wrote:
Sat Jan 09, 2021 9:26 pm
has the F3 + F4 hotkey to return to the menu screen changed with the latest update? I'm unable to exit any of the emulators on the OGA.

Thanks.
Yes, unfortunately we had to unmap the hotkey due to the joypad button mapping changes between the OGA 1.0/1.1 and OGS. F1 - our previous hotkey is now select on the OGS. In effect we chose to reset the retroarch.cfg to avoid confusion.
I pushed a new update that defaults the menu screen combo back to start-select. You'll need to either map it manually or do a rest_rrvl to reset your retroarch.cfg
These users thanked the author valadaa48 for the post:
micronaut (Sun Jan 10, 2021 7:11 pm)

kelbot
Posts: 60
Joined: Thu Aug 29, 2019 12:05 pm
languages_spoken: english
ODROIDs: C2, HC2 x2, Go
Has thanked: 4 times
Been thanked: 2 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by kelbot »

What is the name of the new rgui theme? I'm going to Settings > User Interface > Appearance > Custom Menu Theme Preset > rgui but selecting any of those themes doesn't do anything.

kelbot
Posts: 60
Joined: Thu Aug 29, 2019 12:05 pm
languages_spoken: english
ODROIDs: C2, HC2 x2, Go
Has thanked: 4 times
Been thanked: 2 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by kelbot »

Also, does anyone know if its possible to set retroarch to launch to a specific screen? I would like retroarch to launch straight to the playlist screen but I can't find a setting for that.

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by valadaa48 »

kelbot wrote:
Sun Jan 10, 2021 2:30 pm
What is the name of the new rgui theme? I'm going to Settings > User Interface > Appearance > Custom Menu Theme Preset > rgui but selecting any of those themes doesn't do anything.
It's actually just the default theme we set in retroarch.cfg, it should have a swirling star pattern with gray background.

kelbot
Posts: 60
Joined: Thu Aug 29, 2019 12:05 pm
languages_spoken: english
ODROIDs: C2, HC2 x2, Go
Has thanked: 4 times
Been thanked: 2 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by kelbot »

What is the trick to getting video playback working? I saw that it is supposed to be built in but I have an mp4 file that I transferred and I can't figure out how to play it. I don't see a video player core and it doesn't show up in the file browser.

valadaa48
Posts: 240
Joined: Mon Feb 17, 2020 1:35 pm
languages_spoken: english
ODROIDs: odroid go advance
Has thanked: 16 times
Been thanked: 62 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by valadaa48 »

kelbot wrote:
Mon Jan 11, 2021 3:54 am
What is the trick to getting video playback working? I saw that it is supposed to be built in but I have an mp4 file that I transferred and I can't figure out how to play it. I don't see a video player core and it doesn't show up in the file browser.
You have to enable the setting somewhere in the menus. I admit that it was working at some point but then stopped working. I don't know if it broke in Retroarch itself or due to some other thing. I'll have a look at it sometime in the future. I think slaminger was also trying to make it work but he also had trouble.

kelbot
Posts: 60
Joined: Thu Aug 29, 2019 12:05 pm
languages_spoken: english
ODROIDs: C2, HC2 x2, Go
Has thanked: 4 times
Been thanked: 2 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by kelbot »

The only setting I can find is Settings > File Browser > Use Built-in Media Player which is turned on. If I go to system information it shows "ffmpeg support: No". I tried manually installing ffmpeg and restarting but it still shows no ffmpeg support and when I go to load content and browse to my videos folder it doesn't show any of the video files which are in that folder.

Is there a switch that needs to be used on the retroarch compile to enable the ffmpeg support maybe?

kelbot
Posts: 60
Joined: Thu Aug 29, 2019 12:05 pm
languages_spoken: english
ODROIDs: C2, HC2 x2, Go
Has thanked: 4 times
Been thanked: 2 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by kelbot »

I submitted a bug for this but is anyone else experiencing the screen going to sleep after 10 minutes?

ducadan
Posts: 43
Joined: Sun Feb 02, 2020 7:07 pm
languages_spoken: english
Has thanked: 37 times
Been thanked: 3 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by ducadan »

i've installed OpenBOR from http://eple.us/retroroller/rrvl/ . I have Emulation Station from there as well. I tried creating a </system> in es_systems.cfg with this format but it doesn't work when i try to launch a .pak file (it just launches the OpenBOR program, with no controls or the game; at which point i need to hard reset the device) :

Code: Select all

<system>
		<name>openbor</name>
		<fullname>openbor</fullname>
		<path>/roms/openbor</path>
		<extension>.pak .PAK</extension>
		<command>/usr/bin/OpenBOR -L %ROM%</command>
		<platform>openbor</platform>
		<theme>openbor</theme>
</system>
I was able to create other systems and was successful with my noob powers, but these ports outside of RetroArch like OpenBOR are harder figure how to start:(
Any help would be appreciated; thx for the RRVL again

shanti
Posts: 331
Joined: Fri Feb 15, 2019 3:12 am
languages_spoken: english, spanish
ODROIDs: Odroid N2
Has thanked: 90 times
Been thanked: 125 times
Contact:

Re: RRVL (Retro Roller) OGA 1.0/1.1; OGS

Post by shanti »

ducadan wrote:
Thu Jan 14, 2021 3:09 am
i've installed OpenBOR from http://eple.us/retroroller/rrvl/ . I have Emulation Station from there as well. I tried creating a </system> in es_systems.cfg with this format but it doesn't work when i try to launch a .pak file (it just launches the OpenBOR program, with no controls or the game; at which point i need to hard reset the device) :

Code: Select all

<system>
		<name>openbor</name>
		<fullname>openbor</fullname>
		<path>/roms/openbor</path>
		<extension>.pak .PAK</extension>
		<command>/usr/bin/OpenBOR -L %ROM%</command>
		<platform>openbor</platform>
		<theme>openbor</theme>
</system>
I was able to create other systems and was successful with my noob powers, but these ports outside of RetroArch like OpenBOR are harder figure how to start:(
Any help would be appreciated; thx for the RRVL again
OpenBor is a bit of a special case, first, you need a Keyboard to set the gamepad , navigate the menus and configure them to your liking. As for ROMs they need to be in

Code: Select all

Paks
folder where the OpenBor config resides, I have no idea where is that in RRVL but you could potentially create a symlink to the

Code: Select all

/roms/openbor
folder like

Code: Select all

ln -sf /roms/openbor /path/to/openbor/config/Pak

Post Reply

Return to “Projects”

Who is online

Users browsing this forum: No registered users and 1 guest