[SOLVED] No HDMI output after unplugging / plugging cable

Post Reply
User avatar
sgim74528
Posts: 18
Joined: Wed Dec 16, 2020 10:43 pm
languages_spoken: Korean, English
ODROIDs: H2+, N2+, XU4, C4, C2
Location: Ulsan, South Korea
Has thanked: 11 times
Been thanked: 0
Contact:

[SOLVED] No HDMI output after unplugging / plugging cable

Post by sgim74528 »

Hello.
When reconnecting after disconnecting the HDMI cable, the screen is not displayed.
Has anyone encountered the same problem or knows a solution?

problem video :



system info :

Image

Thanks.
Last edited by sgim74528 on Sun Dec 20, 2020 7:45 pm, edited 1 time in total.

mad_ady
Posts: 9090
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 597 times
Been thanked: 584 times
Contact:

Re: No HDMI output after unplugging / plugging cable

Post by mad_ady »

I think you need to turn on "disablehpd" option in boot.ini (which is in /odm I think).
These users thanked the author mad_ady for the post:
sgim74528 (Sun Dec 20, 2020 7:07 pm)

User avatar
sgim74528
Posts: 18
Joined: Wed Dec 16, 2020 10:43 pm
languages_spoken: Korean, English
ODROIDs: H2+, N2+, XU4, C4, C2
Location: Ulsan, South Korea
Has thanked: 11 times
Been thanked: 0
Contact:

Re: No HDMI output after unplugging / plugging cable

Post by sgim74528 »

mad_ady wrote:
Sun Dec 20, 2020 6:20 pm
I think you need to turn on "disablehpd" option in boot.ini (which is in /odm I think).
Thanks reply.
But, Unfortunately it doesn't solve the problem.

User avatar
tobetter
Posts: 7171
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 384 times
Been thanked: 1052 times
Contact:

Re: No HDMI output after unplugging / plugging cable

Post by tobetter »

sgim74528 wrote:
Sun Dec 20, 2020 7:06 pm
mad_ady wrote:
Sun Dec 20, 2020 6:20 pm
I think you need to turn on "disablehpd" option in boot.ini (which is in /odm I think).
Thanks reply.
But, Unfortunately it doesn't solve the problem.
Can you share the output of cat /proc/cmdline after adb shell to your C4?
These users thanked the author tobetter for the post:
sgim74528 (Sun Dec 20, 2020 7:23 pm)

User avatar
sgim74528
Posts: 18
Joined: Wed Dec 16, 2020 10:43 pm
languages_spoken: Korean, English
ODROIDs: H2+, N2+, XU4, C4, C2
Location: Ulsan, South Korea
Has thanked: 11 times
Been thanked: 0
Contact:

Re: No HDMI output after unplugging / plugging cable

Post by sgim74528 »

tobetter wrote:
Sun Dec 20, 2020 7:11 pm
sgim74528 wrote:
Sun Dec 20, 2020 7:06 pm
mad_ady wrote:
Sun Dec 20, 2020 6:20 pm
I think you need to turn on "disablehpd" option in boot.ini (which is in /odm I think).
Thanks reply.
But, Unfortunately it doesn't solve the problem.
Can you share the output of cat /proc/cmdline after adb shell to your C4?
Thank you for answer.
The output is as below.
odroidc4:/ # cat /proc/cmdline
rootfstype=ramfs init=/init console=ttyS0,115200n8 no_console_suspend earlyprintk=aml-uart,0xff803000 quiet ramoops.pstore_en=1 ramoops.record_size=0x8000 ramoops.console_size=0x4000 max_freq_a55=2016 modeline=1920,1080,148500,67500,60,1920,2008,2052,2200,1080,1084,1089,1125,1,1,1 customwidth=1920 customheight=1080 disable_vu7=false touch_invert_x=false touch_invert_y=false zoom_rate=100 test_mt_vid=0000 test_mt_pid=0000 backlight_pwm=yes suspend_hdmiphy=1 usb-xhci.tablesize=2 prevent_sleep=1 androidboot.selinux=permissive androidboot.firstboot= jtag=disable androidboot.hardware=odroidc4 otg_device=1 buildvariant=eng colorattribute=444,8bit disablehpd=false logo=osd0,loaded,0x3d800000 hdmimode=custombuilt voutmode=hdmi osd_reverse=0 video_reverse=0 gpiopower= enable_wol=0 otg_device=1 buildvariant=eng

User avatar
tobetter
Posts: 7171
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 384 times
Been thanked: 1052 times
Contact:

Re: No HDMI output after unplugging / plugging cable

Post by tobetter »

sgim74528 wrote:
Sun Dec 20, 2020 7:22 pm
tobetter wrote:
Sun Dec 20, 2020 7:11 pm
sgim74528 wrote:
Sun Dec 20, 2020 7:06 pm
mad_ady wrote:
Sun Dec 20, 2020 6:20 pm
I think you need to turn on "disablehpd" option in boot.ini (which is in /odm I think).
Thanks reply.
But, Unfortunately it doesn't solve the problem.
Can you share the output of cat /proc/cmdline after adb shell to your C4?
Thank you for answer.
The output is as below.
odroidc4:/ # cat /proc/cmdline
rootfstype=ramfs init=/init console=ttyS0,115200n8 no_console_suspend earlyprintk=aml-uart,0xff803000 quiet ramoops.pstore_en=1 ramoops.record_size=0x8000 ramoops.console_size=0x4000 max_freq_a55=2016 modeline=1920,1080,148500,67500,60,1920,2008,2052,2200,1080,1084,1089,1125,1,1,1 customwidth=1920 customheight=1080 disable_vu7=false touch_invert_x=false touch_invert_y=false zoom_rate=100 test_mt_vid=0000 test_mt_pid=0000 backlight_pwm=yes suspend_hdmiphy=1 usb-xhci.tablesize=2 prevent_sleep=1 androidboot.selinux=permissive androidboot.firstboot= jtag=disable androidboot.hardware=odroidc4 otg_device=1 buildvariant=eng colorattribute=444,8bit disablehpd=false logo=osd0,loaded,0x3d800000 hdmimode=custombuilt voutmode=hdmi osd_reverse=0 video_reverse=0 gpiopower= enable_wol=0 otg_device=1 buildvariant=eng
In the output of /proc/cmdline, it still has the value like disablehpd=false. It should be true as @mad_ady suggested. Please change the value in env.ini, not boot.ini.
These users thanked the author tobetter for the post:
sgim74528 (Sun Dec 20, 2020 7:44 pm)

User avatar
sgim74528
Posts: 18
Joined: Wed Dec 16, 2020 10:43 pm
languages_spoken: Korean, English
ODROIDs: H2+, N2+, XU4, C4, C2
Location: Ulsan, South Korea
Has thanked: 11 times
Been thanked: 0
Contact:

Re: No HDMI output after unplugging / plugging cable

Post by sgim74528 »

tobetter wrote:
Sun Dec 20, 2020 7:35 pm
sgim74528 wrote:
Sun Dec 20, 2020 7:22 pm
tobetter wrote:
Sun Dec 20, 2020 7:11 pm
sgim74528 wrote:
Sun Dec 20, 2020 7:06 pm
mad_ady wrote:
Sun Dec 20, 2020 6:20 pm
I think you need to turn on "disablehpd" option in boot.ini (which is in /odm I think).
Thanks reply.
But, Unfortunately it doesn't solve the problem.
Can you share the output of cat /proc/cmdline after adb shell to your C4?
Thank you for answer.
The output is as below.
odroidc4:/ # cat /proc/cmdline
rootfstype=ramfs init=/init console=ttyS0,115200n8 no_console_suspend earlyprintk=aml-uart,0xff803000 quiet ramoops.pstore_en=1 ramoops.record_size=0x8000 ramoops.console_size=0x4000 max_freq_a55=2016 modeline=1920,1080,148500,67500,60,1920,2008,2052,2200,1080,1084,1089,1125,1,1,1 customwidth=1920 customheight=1080 disable_vu7=false touch_invert_x=false touch_invert_y=false zoom_rate=100 test_mt_vid=0000 test_mt_pid=0000 backlight_pwm=yes suspend_hdmiphy=1 usb-xhci.tablesize=2 prevent_sleep=1 androidboot.selinux=permissive androidboot.firstboot= jtag=disable androidboot.hardware=odroidc4 otg_device=1 buildvariant=eng colorattribute=444,8bit disablehpd=false logo=osd0,loaded,0x3d800000 hdmimode=custombuilt voutmode=hdmi osd_reverse=0 video_reverse=0 gpiopower= enable_wol=0 otg_device=1 buildvariant=eng
In the output of /proc/cmdline, it still has the value like disablehpd=false. It should be true as @mad_ady suggested. Please change the value in env.ini, not boot.ini.
Thank you very much!!!
The problem is solved.
Thank you also @mad_ady !!!

disable"HPD", Hot Plug Detect Pin

I did a little more searching to find out more.
info url : https://yeonsozzz.tistory.com/15

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 0 guests