HDMI output not always active at bootup

Post Reply
benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

HDMI output not always active at bootup

Post by benwillcox »

Hi all,

I've had an issue on a few occasions where the Odroid is powered up before the display device, and when the display is switched on it detects no HDMI output from the Odroid. This can be fixed by simply unplugging and re-plugging in the HDMI cable to the Odroid.
Maybe it's trying to auto-detect something on startup even though I have the resolution defined in Odroid Settings. Is there a way to force the output to always be on even though the display is not active at startup?

Thanks,
Ben

User avatar
tobetter
Posts: 8400
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1325 times
Contact:

Re: HDMI output not always active at bootup

Post by tobetter »

Can you change the value of disablehpd to true in the boot.ini or config.ini?

Code: Select all

setenv disablehpd "false"

benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

Re: HDMI output not always active at bootup

Post by benwillcox »

Thanks I'll give it a try, but where would I find boot.ini or config.ini please?

User avatar
tobetter
Posts: 8400
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1325 times
Contact:

Re: HDMI output not always active at bootup

Post by tobetter »

benwillcox wrote:
Mon Oct 26, 2020 8:46 pm
Thanks I'll give it a try, but where would I find boot.ini or config.ini please?
They are in the first partition of the memory card when you attach your memory card to PC.

benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

Re: HDMI output not always active at bootup

Post by benwillcox »

Thanks, found it in /odm/ :-)
I've changed it and will test and report back.
Thanks,
Ben

benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

Re: HDMI output not always active at bootup

Post by benwillcox »

Hi, making this change appears to work. However, the bad news is that when a software update is performed it resets the setting back to false, and breaks the system again. Is there a way to permanently alter the setting so it's persistent across updates?

OverSoft
Posts: 56
Joined: Wed Feb 01, 2017 5:34 pm
languages_spoken: english
ODROIDs: C2, XU4, N2, N2+
Has thanked: 4 times
Been thanked: 13 times
Contact:

Re: HDMI output not always active at bootup

Post by OverSoft »

You have to set this up in env.ini, not in boot.ini. (Boot.ini is overwritten during an update, env.ini isn't)

Find the line:
disablehpd="false"

and change it to:
disablehpd="true"
These users thanked the author OverSoft for the post (total 2):
tobetter (Mon Nov 09, 2020 11:51 pm) • benwillcox (Tue Nov 10, 2020 12:23 am)

benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

Re: HDMI output not always active at bootup

Post by benwillcox »

Great, many thanks!

benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

Re: HDMI output not always active at bootup

Post by benwillcox »

By the way, I don't suppose there is an easy way to mount the /odm/ directory directly in the Android gui so that it's easy to edit or copy the env.ini file directly using the File Manager?

User avatar
tobetter
Posts: 8400
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1325 times
Contact:

Re: HDMI output not always active at bootup

Post by tobetter »

benwillcox wrote:
Tue Nov 10, 2020 12:30 am
By the way, I don't suppose there is an easy way to mount the /odm/ directory directly in the Android gui so that it's easy to edit or copy the env.ini file directly using the File Manager?
I think it's in /storage? Can you share the output of 'mount' command?

benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

Re: HDMI output not always active at bootup

Post by benwillcox »

Here is the mount output:

Code: Select all

rootfs on / type rootfs (ro,seclabel)
tmpfs on /dev type tmpfs (rw,seclabel,nosuid,relatime,mode=755)
devpts on /dev/pts type devpts (rw,seclabel,relatime,mode=600,ptmxmode=000)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,seclabel,relatime)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
tmpfs on /mnt type tmpfs (rw,seclabel,nosuid,nodev,noexec,relatime,mode=755,gid=1000)
/dev/block/odm on /odm type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/block/product on /product type ext4 (ro,seclabel,relatime,block_validity,delalloc,barrier,user_xattr,acl,inode_readahead_blks=8)
/dev/block/system on /system type ext4 (ro,seclabel,relatime,block_validity,delalloc,barrier,user_xattr,acl,inode_readahead_blks=8)
/dev/block/vendor on /vendor type ext4 (ro,seclabel,relatime,block_validity,delalloc,barrier,user_xattr,acl,inode_readahead_blks=8)
none on /acct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
/sys/kernel/debug on /sys/kernel/debug type debugfs (rw,seclabel,relatime,mode=755)
configfs on /sys/kernel/config type configfs (rw,relatime)
none on /dev/stune type cgroup (rw,nosuid,nodev,noexec,relatime,schedtune)
none on /config type configfs (rw,nosuid,nodev,noexec,relatime)
none on /dev/cpuctl type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
none on /dev/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset,noprefix,release_agent=/sbin/cpuset_release_agent)
cg2_bpf on /dev/cg2_bpf type cgroup2 (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime)
pstore on /sys/fs/pstore type pstore (rw,seclabel,nosuid,nodev,noexec,relatime)
tracefs on /sys/kernel/debug/tracing type tracefs (rw,seclabel,relatime)
/dev/block/data on /data type ext4 (rw,seclabel,nosuid,nodev,noatime,nodelalloc,resgid=1065,errors=panic,data=ordered)
/dev/block/cache on /cache type ext4 (rw,seclabel,nosuid,nodev,noatime,nodelalloc,errors=panic,data=ordered)
/dev/block/param on /mnt/vendor/param type ext4 (rw,seclabel,nosuid,nodev,noatime,nodelalloc,errors=panic,data=ordered)
tmpfs on /storage type tmpfs (rw,seclabel,nosuid,nodev,noexec,relatime,mode=755,gid=1000)
adb on /dev/usb-ffs/adb type functionfs (rw,relatime)
/data/media on /mnt/runtime/default/emulated type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=1015,multiuser,mask=6,derive_gid,default_normal)
/data/media on /storage/emulated type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=1015,multiuser,mask=6,derive_gid,default_normal)
/data/media on /mnt/runtime/read/emulated type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=9997,multiuser,mask=23,derive_gid,default_normal)
/data/media on /mnt/runtime/write/emulated type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=9997,multiuser,mask=7,derive_gid,default_normal)
/dev/block/vold/public:8,1 on /mnt/media_rw/0DCB-D2E9 type exfat (rw,dirsync,nosuid,nodev,noexec,noatime,uid=1023,gid=1023,fmask=0007,dmask=0007,allow_utime=0020,iocharset=utf8,namecase=0,errors=remount-ro)
/mnt/media_rw/0DCB-D2E9 on /mnt/runtime/default/0DCB-D2E9 type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=1015,mask=6)
/mnt/media_rw/0DCB-D2E9 on /storage/0DCB-D2E9 type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=1015,mask=6)
/mnt/media_rw/0DCB-D2E9 on /mnt/runtime/read/0DCB-D2E9 type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=9997,mask=18)
/mnt/media_rw/0DCB-D2E9 on /mnt/runtime/write/0DCB-D2E9 type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=9997,mask=18)

User avatar
tobetter
Posts: 8400
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1325 times
Contact:

Re: HDMI output not always active at bootup

Post by tobetter »

benwillcox wrote:
Tue Nov 10, 2020 3:28 am
Here is the mount output:

Code: Select all

rootfs on / type rootfs (ro,seclabel)
tmpfs on /dev type tmpfs (rw,seclabel,nosuid,relatime,mode=755)
devpts on /dev/pts type devpts (rw,seclabel,relatime,mode=600,ptmxmode=000)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,seclabel,relatime)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
tmpfs on /mnt type tmpfs (rw,seclabel,nosuid,nodev,noexec,relatime,mode=755,gid=1000)
/dev/block/odm on /odm type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/block/product on /product type ext4 (ro,seclabel,relatime,block_validity,delalloc,barrier,user_xattr,acl,inode_readahead_blks=8)
/dev/block/system on /system type ext4 (ro,seclabel,relatime,block_validity,delalloc,barrier,user_xattr,acl,inode_readahead_blks=8)
/dev/block/vendor on /vendor type ext4 (ro,seclabel,relatime,block_validity,delalloc,barrier,user_xattr,acl,inode_readahead_blks=8)
none on /acct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
/sys/kernel/debug on /sys/kernel/debug type debugfs (rw,seclabel,relatime,mode=755)
configfs on /sys/kernel/config type configfs (rw,relatime)
none on /dev/stune type cgroup (rw,nosuid,nodev,noexec,relatime,schedtune)
none on /config type configfs (rw,nosuid,nodev,noexec,relatime)
none on /dev/cpuctl type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
none on /dev/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset,noprefix,release_agent=/sbin/cpuset_release_agent)
cg2_bpf on /dev/cg2_bpf type cgroup2 (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime)
pstore on /sys/fs/pstore type pstore (rw,seclabel,nosuid,nodev,noexec,relatime)
tracefs on /sys/kernel/debug/tracing type tracefs (rw,seclabel,relatime)
/dev/block/data on /data type ext4 (rw,seclabel,nosuid,nodev,noatime,nodelalloc,resgid=1065,errors=panic,data=ordered)
/dev/block/cache on /cache type ext4 (rw,seclabel,nosuid,nodev,noatime,nodelalloc,errors=panic,data=ordered)
/dev/block/param on /mnt/vendor/param type ext4 (rw,seclabel,nosuid,nodev,noatime,nodelalloc,errors=panic,data=ordered)
tmpfs on /storage type tmpfs (rw,seclabel,nosuid,nodev,noexec,relatime,mode=755,gid=1000)
adb on /dev/usb-ffs/adb type functionfs (rw,relatime)
/data/media on /mnt/runtime/default/emulated type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=1015,multiuser,mask=6,derive_gid,default_normal)
/data/media on /storage/emulated type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=1015,multiuser,mask=6,derive_gid,default_normal)
/data/media on /mnt/runtime/read/emulated type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=9997,multiuser,mask=23,derive_gid,default_normal)
/data/media on /mnt/runtime/write/emulated type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=9997,multiuser,mask=7,derive_gid,default_normal)
/dev/block/vold/public:8,1 on /mnt/media_rw/0DCB-D2E9 type exfat (rw,dirsync,nosuid,nodev,noexec,noatime,uid=1023,gid=1023,fmask=0007,dmask=0007,allow_utime=0020,iocharset=utf8,namecase=0,errors=remount-ro)
/mnt/media_rw/0DCB-D2E9 on /mnt/runtime/default/0DCB-D2E9 type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=1015,mask=6)
/mnt/media_rw/0DCB-D2E9 on /storage/0DCB-D2E9 type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=1015,mask=6)
/mnt/media_rw/0DCB-D2E9 on /mnt/runtime/read/0DCB-D2E9 type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=9997,mask=18)
/mnt/media_rw/0DCB-D2E9 on /mnt/runtime/write/0DCB-D2E9 type sdcardfs (rw,nosuid,nodev,noexec,noatime,fsuid=1023,fsgid=1023,gid=9997,mask=18)
Can't you reach "/odm"?

Code: Select all

/dev/block/odm on /odm type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)

benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

Re: HDMI output not always active at bootup

Post by benwillcox »

Yes sorry, I can do it from the command line but I meant can it be accessed from within the Android GUI, so that it can be done in the File Manager app. Because you can only see 'Internal shared storage' which is at /storage/emulated/0.
Is it possible to navigate the full file structure somehow in the File Manager without using a terminal?

User avatar
mad_ady
Posts: 9703
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 609 times
Been thanked: 721 times
Contact:

Re: HDMI output not always active at bootup

Post by mad_ady »

You may need a Root enabled file manager. I recommend Mixplorer on xda.
These users thanked the author mad_ady for the post:
benwillcox (Tue Nov 10, 2020 5:25 am)

benwillcox
Posts: 300
Joined: Wed Oct 05, 2016 6:34 pm
languages_spoken: english
ODROIDs: C1+,C2, N2, N2+
Location: United Kingdom
Has thanked: 35 times
Been thanked: 23 times
Contact:

Re: HDMI output not always active at bootup

Post by benwillcox »

Ok so originally I changed the disablehpd in boot.ini to true, which I thought had fixed the issue (well, I didn't see a problem since).
However now I've learned there is an env.ini that exists so I made the change in that file as well.

But, in this case as both files contained the same disablehpd variable (and many others), which one takes priority? Perhaps when I changed it in boot.ini it was actually having no effect as the opposite was set in env.ini, although it did seem to work?
Is there any way to check the current actual value of the these variables that is in use at the time, so make sure a setting is in effect?

User avatar
tobetter
Posts: 8400
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: Many
Location: Paju, South Korea
Has thanked: 490 times
Been thanked: 1325 times
Contact:

Re: HDMI output not always active at bootup

Post by tobetter »

benwillcox wrote:
Wed Nov 11, 2020 7:28 pm
Ok so originally I changed the disablehpd in boot.ini to true, which I thought had fixed the issue (well, I didn't see a problem since).
However now I've learned there is an env.ini that exists so I made the change in that file as well.

But, in this case as both files contained the same disablehpd variable (and many others), which one takes priority? Perhaps when I changed it in boot.ini it was actually having no effect as the opposite was set in env.ini, although it did seem to work?
Is there any way to check the current actual value of the these variables that is in use at the time, so make sure a setting is in effect?
the values in env.ini will affect to boot and the values in boot.ini can be assumed as a default in case env.ini is missing. So the actual value applied in the running system can be found with the command cat /proc/cmdline.
These users thanked the author tobetter for the post:
benwillcox (Wed Nov 11, 2020 7:39 pm)

tdfsu
Posts: 13
Joined: Fri Feb 07, 2020 7:46 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDMI output not always active at bootup

Post by tdfsu »

This happens to me all the time also. I don't have the odm directory however. I do see the boot and env files in /dev/block. I'm trying to accomplish this inside the android gui also using root explorer. Is the above vfat command still what I want to use to fix this?

User avatar
odroid
Site Admin
Posts: 38079
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2013 times
Been thanked: 1209 times
Contact:

Re: HDMI output not always active at bootup

Post by odroid »

tdfsu wrote:
Sun Apr 18, 2021 9:13 pm
This happens to me all the time also. I don't have the odm directory however. I do see the boot and env files in /dev/block. I'm trying to accomplish this inside the android gui also using root explorer. Is the above vfat command still what I want to use to fix this?
Which Android OS image did your flash?

tdfsu
Posts: 13
Joined: Fri Feb 07, 2020 7:46 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDMI output not always active at bootup

Post by tdfsu »

It's the latest os that came pre-flashed onto the emmc.

User avatar
odroid
Site Admin
Posts: 38079
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2013 times
Been thanked: 1209 times
Contact:

Re: HDMI output not always active at bootup

Post by odroid »

This is the latest one and you probably need to update it via utility app.
https://wiki.odroid.com/odroid-n2/os_im ... 4_20210414

tdfsu
Posts: 13
Joined: Fri Feb 07, 2020 7:46 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDMI output not always active at bootup

Post by tdfsu »

I flashed the latest image, but the odm directory still doesnt exist. I am using Root Explorer inside the android gui. I see an env file and a boot file and an odm file inside dev/block however. Any ideas?

User avatar
odroid
Site Admin
Posts: 38079
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2013 times
Been thanked: 1209 times
Contact:

Re: HDMI output not always active at bootup

Post by odroid »

Very weird.
Did you flash selfinstall-odroidn2-130-64bit-20210414.img.xz with Etcher?

After shutdown the Android system, connect your eMMC module to your PC.
There must be boot.ini and config.ini file in the FAT32 partition.

tdfsu
Posts: 13
Joined: Fri Feb 07, 2020 7:46 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDMI output not always active at bootup

Post by tdfsu »

Yes...i flashed the 4/14/21 image. Is there any way you could make a script or something to do this? Its so annoying. Ill pay you for your efforts...

User avatar
odroid
Site Admin
Posts: 38079
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2013 times
Been thanked: 1209 times
Contact:

Re: HDMI output not always active at bootup

Post by odroid »

You don't need to pay.

Did you find boot.ini and config.ini files on your PC?

tdfsu
Posts: 13
Joined: Fri Feb 07, 2020 7:46 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDMI output not always active at bootup

Post by tdfsu »

How do i browse the emmc when i have it attached to the pc? The pc says i need to format it and wont let me browse the files.

User avatar
mad_ady
Posts: 9703
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 609 times
Been thanked: 721 times
Contact:

Re: HDMI output not always active at bootup

Post by mad_ady »

You'll need to run either a live linux distro, or install some ext drivers on windows

User avatar
odroid
Site Admin
Posts: 38079
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2013 times
Been thanked: 1209 times
Contact:

Re: HDMI output not always active at bootup

Post by odroid »

Those env.ini & boot.ini files in the FAT partition should be accessible on Windows 10.

tdfsu
Posts: 13
Joined: Fri Feb 07, 2020 7:46 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDMI output not always active at bootup

Post by tdfsu »

I finally got around to editing the env.ini and boot.ini files on the PC and changed disablehpd="true". This still did not fix the issue and when i cut the tv off, the hdmi signal does not activate upon turning the tv back on. Anything else I can try?

User avatar
odroid
Site Admin
Posts: 38079
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2013 times
Been thanked: 1209 times
Contact:

Re: HDMI output not always active at bootup

Post by odroid »

Can you show us "dmesg" output from Terminal app to check if the kernel parameters are correct or not?

tdfsu
Posts: 13
Joined: Fri Feb 07, 2020 7:46 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDMI output not always active at bootup

Post by tdfsu »

See attached.
Attachments
dmesg.log
(494.39 KiB) Downloaded 15 times

User avatar
odroid
Site Admin
Posts: 38079
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 2013 times
Been thanked: 1209 times
Contact:

Re: HDMI output not always active at bootup

Post by odroid »

The log file is not an output from "dmesg".
Did you type "dmesg" and enter key on the terminal app screen?

tdfsu
Posts: 13
Joined: Fri Feb 07, 2020 7:46 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDMI output not always active at bootup

Post by tdfsu »

How do I save the dmesg file so I can post it?

Thanks for all of the help btw...

User avatar
mad_ady
Posts: 9703
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 609 times
Been thanked: 721 times
Contact:

Re: HDMI output not always active at bootup

Post by mad_ady »

Try running dmesg >/sdcard/dmesg.txt and you can upload dmesg.txt

User avatar
rooted
Posts: 8729
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 743 times
Been thanked: 376 times
Contact:

Re: HDMI output not always active at bootup

Post by rooted »

mad_ady wrote:Try running dmesg >/sdcard/dmesg.txt and you can upload dmesg.txt
You have to be root to run dmesg on Android

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 0 guests