H2+ with External GPU issue

Post Reply
anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

H2+ with External GPU issue

Post by anasazi29 »

I’m disappointed in my Odroid H2+. I had an H2 last year and loved it, especially because I was able to connect and use an Nvidia 1080 GTX on it and play high end game.
Bought an NVMe to PCIe 4x card for the bottom of the H2
Bought a PCIe 1x to 16x riser card.
Used a 750 watt power supply for the video card to have the appropriately needed power.
Used a eMMC 64GB and installed Windows 10 Pro.
Changed the appropriate settings on the H2 bios.
Bios / Chipset / south cluster configuration / PCI express configuration / PCI express clock gating (disabled)
Misc config / State After G3 [SO state]
Everything worked great.
______________________________________
The H2+ unfortunately won’t work the same.
I have ordered and tried multiple versions of 1x pcie to 16x pcie with extra power, 4x pcie to 4x pcie and the original working version of 1x pcie to 16x pcie riser card, which uses additional power.
I tried 3 different Nvidia cards from least power needed to average power needed. NVIDIA 730, NVIDIA 1060 and an NVIDIA 2060 GTX. I also tried 3 different power supplies.
I tested each component on other computer and all of them work appropriately.
I updated the H2+ to the most recent bios 07/30/2020 and tried everything again. I have been working on it for about 2 weeks.
This is all running Windows 10 Pro.
If I goto device manager and tell it to scan for hardware it will find the device, download an appropriate default NVIDIA driver and the says:
This device cannot find enough free resources that it can use. (code 12)
If you want to use this device, you will need to disable one of the other devices on the system
.
If I disable devices, it asks me to reboot and then it does NOT find the video card by default again, I have to goto device manager, click scan for new hardware, it finds it and starts the same process over.
I have disable almost ever device that I can on the H2+ and the external video card will still not function. I worked so well and easy on the H2, what am I missing on this new H2+ ?
If anyone has bios setting to try, I’ll try anything.
I also purchased a new power supply with the same/correct voltage, but with more amps, thinking the board just need more amps to support the devices plugged in or something.
I have re-installed the operating system twice.
I have ordered and tried 2 different NVMe to 4x PCIe adapters.
https://www.ureach-estore.com/collectio ... to-pcie-4x

https://www.amazon.com/Dr-meter-6-Pack- ... 150&sr=8-2

disabling clock gating down the page a bit: https://magazine.odroid.com/article/net ... odroid-h2/

brad
Posts: 1208
Joined: Tue Mar 29, 2016 1:22 pm
languages_spoken: english
ODROIDs: C2 N1 N2 N2+ H2 H2+ (64 bit ftw)
Location: Australia
Has thanked: 75 times
Been thanked: 124 times
Contact:

Re: H2+ with External GPU issue

Post by brad »

Interesting, I ran external GPU on H2 for some time with no problems and now I have a H2+ been wanting to try it out. Ill do this now, will be using a Radeon GPU(s) and ADT Link adaptor.

misaz
Posts: 76
Joined: Sat Jul 27, 2019 3:58 am
languages_spoken: english, czech
ODROIDs: H2+
Has thanked: 7 times
Been thanked: 12 times
Contact:

Re: H2+ with External GPU issue

Post by misaz »

How much RAM do you have?

misaz
Posts: 76
Joined: Sat Jul 27, 2019 3:58 am
languages_spoken: english, czech
ODROIDs: H2+
Has thanked: 7 times
Been thanked: 12 times
Contact:

Re: H2+ with External GPU issue

Post by misaz »

Please also post screen of memory ranges reserved by hardware. This could be done using typing Win + R > msinfo32 > enter > select Hardware resources section > Input and Output and post screenshot of that page.

brad
Posts: 1208
Joined: Tue Mar 29, 2016 1:22 pm
languages_spoken: english
ODROIDs: C2 N1 N2 N2+ H2 H2+ (64 bit ftw)
Location: Australia
Has thanked: 75 times
Been thanked: 124 times
Contact:

Re: H2+ with External GPU issue

Post by brad »

Just done an initial setup and appears to be OK for me. I'm downloading some games to check it out.

I have

- Odroid H2+ with 16Gb RAM (2x8Gb)
- Radeon RX 5700 8Gb GPU RAM
- ADT Link adaptor (https://www.adt.link/product/R43SL.html)
- Windows 10 Pro

I/O screen export for msinfo32

Code: Select all

System Information report written at: 08/09/20 21:46:08
System Name: DESKTOP-ITUMOU8
[I/O]

Resource	Device	Status	
0x0000C000-0x0000CFFF	Intel(R) Celeron(R)/Pentium(R) Silver Processor PCI Express Root Port - 31D7	OK	
0x0000C000-0x0000CFFF	Realtek PCIe 2.5GbE Family Controller	OK	
0x00000A00-0x00000A07	Motherboard resources	OK	
0x0000002E-0x0000002F	Motherboard resources	OK	
0x0000004E-0x0000004F	Motherboard resources	OK	
0x00000061-0x00000061	Motherboard resources	OK	
0x00000063-0x00000063	Motherboard resources	OK	
0x00000065-0x00000065	Motherboard resources	OK	
0x00000067-0x00000067	Motherboard resources	OK	
0x00000070-0x00000070	Motherboard resources	OK	
0x00000070-0x00000070	System CMOS/real time clock	OK	
0x00000080-0x0000008F	Motherboard resources	OK	
0x00000092-0x00000092	Motherboard resources	OK	
0x000000B2-0x000000B3	Motherboard resources	OK	
0x00000680-0x0000069F	Motherboard resources	OK	
0x00000400-0x0000047F	Motherboard resources	OK	
0x00000500-0x000005FE	Motherboard resources	OK	
0x00000600-0x0000061F	Motherboard resources	OK	
0x0000164E-0x0000164F	Motherboard resources	OK	
0x0000E000-0x0000EFFF	PCI Express Upstream Switch Port	OK	
0x0000E000-0x0000EFFF	Intel(R) Celeron(R)/Pentium(R) Silver Processor PCI Express Root Port - 31D8	OK	
0x0000E000-0x0000EFFF	PCI Express Downstream Switch Port	OK	
0x000003F8-0x000003FF	Communications Port (COM1)	OK	
0x000002F8-0x000002FF	Communications Port (COM2)	OK	
0x00000020-0x00000021	Programmable interrupt controller	OK	
0x00000024-0x00000025	Programmable interrupt controller	OK	
0x00000028-0x00000029	Programmable interrupt controller	OK	
0x0000002C-0x0000002D	Programmable interrupt controller	OK	
0x00000030-0x00000031	Programmable interrupt controller	OK	
0x00000034-0x00000035	Programmable interrupt controller	OK	
0x00000038-0x00000039	Programmable interrupt controller	OK	
0x0000003C-0x0000003D	Programmable interrupt controller	OK	
0x000000A0-0x000000A1	Programmable interrupt controller	OK	
0x000000A4-0x000000A5	Programmable interrupt controller	OK	
0x000000A8-0x000000A9	Programmable interrupt controller	OK	
0x000000AC-0x000000AD	Programmable interrupt controller	OK	
0x000000B0-0x000000B1	Programmable interrupt controller	OK	
0x000000B4-0x000000B5	Programmable interrupt controller	OK	
0x000000B8-0x000000B9	Programmable interrupt controller	OK	
0x000000BC-0x000000BD	Programmable interrupt controller	OK	
0x000004D0-0x000004D1	Programmable interrupt controller	OK	
0x0000F090-0x0000F097	Standard SATA AHCI Controller	OK	
0x0000F080-0x0000F083	Standard SATA AHCI Controller	OK	
0x0000F060-0x0000F07F	Standard SATA AHCI Controller	OK	
0x0000D000-0x0000DFFF	Intel(R) Celeron(R)/Pentium(R) Silver Processor PCI Express Root Port - 31D6	OK	
0x0000D000-0x0000DFFF	Realtek PCIe 2.5GbE Family Controller #2	OK	
0x00000000-0x0000006F	PCI Express Root Complex	OK	
0x00000078-0x00000CF7	PCI Express Root Complex	OK	
0x00000D00-0x0000FFFF	PCI Express Root Complex	OK	
0x0000F040-0x0000F05F	Intel(R) Celeron(R)/Pentium(R) Silver Processor Gaussian Mixture Model - 31D4	OK	
0x0000EF00-0x0000EFFF	AMD Radeon RX 5700	OK	
0x00000040-0x00000043	System timer	OK	
0x00000050-0x00000053	System timer	OK	
0x0000F000-0x0000F03F	Intel(R) UHD Graphics 600	OK	
and looks like this
20200809_222240.jpg
20200809_222240.jpg (334.81 KiB) Viewed 1390 times
These users thanked the author brad for the post:
anasazi29 (Sun Aug 09, 2020 11:29 pm)

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

16GB DDR4 ripjaws
misaz wrote:
Sun Aug 09, 2020 4:13 pm
How much RAM do you have?

brad
Posts: 1208
Joined: Tue Mar 29, 2016 1:22 pm
languages_spoken: english
ODROIDs: C2 N1 N2 N2+ H2 H2+ (64 bit ftw)
Location: Australia
Has thanked: 75 times
Been thanked: 124 times
Contact:

Re: H2+ with External GPU issue

Post by brad »

Yes it is working fine for me i was playing Forza horizon 4. Are you running the latest release update of Windows 10?

I need to put a fan on it, cpu gets warm and it seems to throttle a bit after some time.
These users thanked the author brad for the post:
anasazi29 (Sun Aug 09, 2020 11:17 pm)

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

0x00000000-0x0000006F PCI Express Root Complex OK
0x00000020-0x00000021 Programmable interrupt controller OK
0x00000024-0x00000025 Programmable interrupt controller OK
0x00000028-0x00000029 Programmable interrupt controller OK
0x0000002C-0x0000002D Programmable interrupt controller OK
0x0000002E-0x0000002F Motherboard resources OK
0x00000030-0x00000031 Programmable interrupt controller OK
0x00000034-0x00000035 Programmable interrupt controller OK
0x00000038-0x00000039 Programmable interrupt controller OK
0x0000003C-0x0000003D Programmable interrupt controller OK
0x00000040-0x00000043 System timer OK
0x0000004E-0x0000004F Motherboard resources OK
0x00000050-0x00000053 System timer OK
0x00000061-0x00000061 Motherboard resources OK
0x00000063-0x00000063 Motherboard resources OK
0x00000065-0x00000065 Motherboard resources OK
0x00000067-0x00000067 Motherboard resources OK
0x00000070-0x00000070 Motherboard resources OK
0x00000070-0x00000070 System CMOS/real time clock OK
0x00000078-0x00000CF7 PCI Express Root Complex OK
0x00000080-0x0000008F Motherboard resources OK
0x00000092-0x00000092 Motherboard resources OK
0x000000A0-0x000000A1 Programmable interrupt controller OK
0x000000A4-0x000000A5 Programmable interrupt controller OK
0x000000A8-0x000000A9 Programmable interrupt controller OK
0x000000AC-0x000000AD Programmable interrupt controller OK
0x000000B0-0x000000B1 Programmable interrupt controller OK
0x000000B2-0x000000B3 Motherboard resources OK
0x000000B4-0x000000B5 Programmable interrupt controller OK
0x000000B8-0x000000B9 Programmable interrupt controller OK
0x000000BC-0x000000BD Programmable interrupt controller OK
0x00000400-0x0000047F Motherboard resources OK
0x000004D0-0x000004D1 Programmable interrupt controller OK
0x00000500-0x000005FE Motherboard resources OK
0x00000600-0x0000061F Motherboard resources OK
0x00000680-0x0000069F Motherboard resources OK
0x00000A00-0x00000A07 Motherboard resources OK
0x00000D00-0x0000FFFF PCI Express Root Complex OK
0x0000164E-0x0000164F Motherboard resources OK
0x0000D000-0x0000DFFF PCI Express Root Port OK
0x0000E000-0x0000EFFF PCI Express Root Port OK
0x0000E000-0x0000EFFF Realtek PCIe 2.5GbE Family Controller #2 OK
0x0000F000-0x0000F03F Intel(R) UHD Graphics 600 OK
0x0000F040-0x0000F05F Intel(R) Celeron(R)/Pentium(R) Silver Processor Gaussian Mixture Model - 31D4 OK
0x0000F060-0x0000F07F Standard SATA AHCI Controller OK
0x0000F080-0x0000F083 Standard SATA AHCI Controller OK
0x0000F090-0x0000F097 Standard SATA AHCI Controller OK

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

H2+ / 16GB mem / 64gb emmc / 750w PS / nvidia 2060 gtx
Attachments
20200809_100431.jpg
20200809_100431.jpg (503.8 KiB) Viewed 1377 times

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

the video card shows up in device manager, but doesn't show in msinfo32
Attachments
h2_io.PNG
h2_io.PNG (325 KiB) Viewed 1376 times

misaz
Posts: 76
Joined: Sat Jul 27, 2019 3:58 am
languages_spoken: english, czech
ODROIDs: H2+
Has thanked: 7 times
Been thanked: 12 times
Contact:

Re: H2+ with External GPU issue

Post by misaz »

Interesting. It looks like (maybe PCIe) drivers related problem.

It is correct that it does not show up in msinfo32 bacause it has no allocated memory as the error says. The reason why I wanted to see that output is to determine if only GPU is affected or any other devices is affected with the same error.

Some your PCIe lanes are unusuable because they have no driver loaded (missing PCI Express Root Port XXXX entries). Could you post screen of device manager with System devices section expanded? What Windows 10 Installer did you used? Are you able test running live linux and post output of follwoing commands?

Code: Select all

dmesg 
lspci

misaz
Posts: 76
Joined: Sat Jul 27, 2019 3:58 am
languages_spoken: english, czech
ODROIDs: H2+
Has thanked: 7 times
Been thanked: 12 times
Contact:

Re: H2+ with External GPU issue

Post by misaz »

You can also try installing latest nvidia drivers from website. Sometimes it helps with lots of interesting and crazy issues.

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

device manager/ system devices
Attachments
system_devices_h2.PNG
system_devices_h2.PNG (53.9 KiB) Viewed 1369 times

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

brad wrote:
Sun Aug 09, 2020 8:59 pm
Just done an initial setup and appears to be OK for me. I'm downloading some games to check it out.

I have

- Odroid H2+ with 16Gb RAM (2x8Gb)
- Radeon RX 5700 8Gb GPU RAM
- ADT Link adaptor (https://www.adt.link/product/R43SL.html)
*** I've ordered 3 different ones to test, I might as well order one like this one your using and test it. :-\
- Windows 10 Pro

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

misaz wrote:
Sun Aug 09, 2020 11:23 pm
You can also try installing latest nvidia drivers from website. Sometimes it helps with lots of interesting and crazy issues.
fresh re-installation of Windows 10 and downloaded the latest Nvidia drivers and it asked me to reboot, but comes back still unavailable to use the video card.
Attachments
code_12.PNG
code_12.PNG (70.46 KiB) Viewed 1362 times

brad
Posts: 1208
Joined: Tue Mar 29, 2016 1:22 pm
languages_spoken: english
ODROIDs: C2 N1 N2 N2+ H2 H2+ (64 bit ftw)
Location: Australia
Has thanked: 75 times
Been thanked: 124 times
Contact:

Re: H2+ with External GPU issue

Post by brad »

Try to disable the Intel UHD Graphics device (should be able to right click and disable)

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

brad wrote:
Sun Aug 09, 2020 11:42 pm
Try to disable the Intel UHD Graphics device (should be able to right click and disable)
it did disable, but continues to show a display from that card. the Nvidia yellow triangle went away, but I tried 2 different monitors and 2 different HDMI cables, but it doesn't display anything from it.
Attachments
intel_gpu_diabled.PNG
intel_gpu_diabled.PNG (13.71 KiB) Viewed 1347 times

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

also after disabling the onboard video card, the Nvidia's properties says:
Attachments
intel_gpu_diabled_code12.PNG
intel_gpu_diabled_code12.PNG (65.62 KiB) Viewed 1345 times

brad
Posts: 1208
Joined: Tue Mar 29, 2016 1:22 pm
languages_spoken: english
ODROIDs: C2 N1 N2 N2+ H2 H2+ (64 bit ftw)
Location: Australia
Has thanked: 75 times
Been thanked: 124 times
Contact:

Re: H2+ with External GPU issue

Post by brad »

if you have not tried might need to reboot once disabled and have the hdmi plugged in on boot to the external card.

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

after disabling intel onboard GPU and rebooting. :(
Attachments
intel_gpu_diabled_after_reboot.PNG
intel_gpu_diabled_after_reboot.PNG (14.99 KiB) Viewed 1340 times

misaz
Posts: 76
Joined: Sat Jul 27, 2019 3:58 am
languages_spoken: english, czech
ODROIDs: H2+
Has thanked: 7 times
Been thanked: 12 times
Contact:

Re: H2+ with External GPU issue

Post by misaz »

fresh re-installation of Windows 10 ...
What is the source of installer. It is media creation tool, official DVD disk, creacked installer?

I found that msinfo32 can export full log to file. Could you export and upload it. It is in File > Export. It contains more detailed informations from all pages of that utility.

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

misaz wrote:
Mon Aug 10, 2020 5:23 am
fresh re-installation of Windows 10 ...
What is the source of installer. It is media creation tool, official DVD disk, creacked installer?

I found that msinfo32 can export full log to file. Could you export and upload it. It is in File > Export. It contains more detailed informations from all pages of that utility.
both using Microsoft Media Creation Tool. The first installation, I actually had activated and up-to-date.
Full exported i/o file attached.
Attachments
H2_IO_export.txt
(5.33 KiB) Downloaded 10 times

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

under components / Problem devices:
High Definition Audio Controller PCI\VEN_10DE&DEV_10F8&SUBSYS_3FC01458&REV_A1\4&19EE62C3&0&0198 This device cannot find enough free resources that it can use.
NVIDIA GeForce RTX 2060 PCI\VEN_10DE&DEV_1E89&SUBSYS_3FC01458&REV_A1\4&19EE62C3&0&0098 This device cannot find enough free resources that it can use.
NVIDIA USB 3.10 eXtensible Host Controller - 1.10 (Microsoft) PCI\VEN_10DE&DEV_1AD8&SUBSYS_3FC01458&REV_A1\4&19EE62C3&0&0298 This device cannot find enough free resources that it can use.
NVIDIA USB Type-C Port Policy Controller PCI\VEN_10DE&DEV_1AD9&SUBSYS_3FC01458&REV_A1\4&19EE62C3&0&0398 This device cannot find enough free resources that it can use.

User avatar
odroid
Site Admin
Posts: 35297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1089 times
Been thanked: 824 times
Contact:

Re: H2+ with External GPU issue

Post by odroid »

Which BIOS version did you run on the old H2 board?
https://wiki.odroid.com/odroid-h2/hardw ... glk-sf_110

misaz
Posts: 76
Joined: Sat Jul 27, 2019 3:58 am
languages_spoken: english, czech
ODROIDs: H2+
Has thanked: 7 times
Been thanked: 12 times
Contact:

Re: H2+ with External GPU issue

Post by misaz »

Full exported i/o file attached.
I need all sections because I/O section does not contains any related ifnromations to investigate issue. The issue is probably not memory related but some other resources like DMA, IRQs or something other colides.

domih
Posts: 315
Joined: Mon Feb 11, 2019 4:48 pm
languages_spoken: English, French
ODROIDs: UX4, HC2, N2, H2, C4, H2+
Location: San Francisco Bay Area
Has thanked: 103 times
Been thanked: 113 times
Contact:

Re: H2+ with External GPU issue

Post by domih »

anasazi29 wrote:
Sun Aug 09, 2020 11:10 pm
H2+ / 16GB mem / 64gb emmc / 750w PS / nvidia 2060 gtx
Which M.2 to PCIe do you use exactly? The UReach carries 4 lanes, the Dr Meter carries only one. So you want to use the UReach to leverage the 4 lanes of the NVMe slot. The Dr Meter is for coin mining, not really for graphics usage.

Boot with a Linux USB stick to double-check how many lanes the card actually gets:
1) lspci to find out the PCIe address of the NVidia graphics card (xx:xx.x)
2) sudo lspci -vv -s xx:xx.x | grep Width

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

odroid wrote:
Mon Aug 10, 2020 9:30 am
Which BIOS version did you run on the old H2 board?
https://wiki.odroid.com/odroid-h2/hardw ... glk-sf_110
I'm pretty sure it was bios version 1.08 on my original H2.

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

domih wrote:
Tue Aug 11, 2020 8:09 am
anasazi29 wrote:
Sun Aug 09, 2020 11:10 pm
H2+ / 16GB mem / 64gb emmc / 750w PS / nvidia 2060 gtx
Which M.2 to PCIe do you use exactly? The UReach carries 4 lanes, the Dr Meter carries only one. So you want to use the UReach to leverage the 4 lanes of the NVMe slot. The Dr Meter is for coin mining, not really for graphics usage.

Boot with a Linux USB stick to double-check how many lanes the card actually gets:
1) lspci to find out the PCIe address of the NVidia graphics card (xx:xx.x)
2) sudo lspci -vv -s xx:xx.x | grep Width
First, I just wanted to say, thank you all for your comments, advice and recommendation. However, this shouldn’t be that difficult. It was a simple plug and play on the H2.
- I am trying the exact adapter I used on my original H2. Not a new purchased adapter, the exact one. When I sold my H2, they didn’t want the external GPU, so I removed the adapter and external cables, etc.
- Here is the item link: https://www.ebay.com/itm/EXPLOMOS-M-2-K ... 4679ffac60
I am downloading the newest Ubuntu and setting it up on USB via Rufus. I will run the commands to see what results I get and post them on here.
Additional information. When I go into the bios and change certain settings and reboot, then it freezes up and I cannot do anything until I unplug it.
After unplugging it, the bios settings will all be reset to default.
If an adapter is meant for bit mining, technically it should still show up and be functioning, wouldn’t you agree.
I’m just mostly confused about it saying “not enough resources” and its weird that when the bios keeps the appropriate settings, the video card doesn’t show up immediately in device manager, until I manually tell it to search for new hardware. Then it finds it but says it can’t be used because not enough resources.
Here is my actual video on YouTube: https://www.youtube.com/watch?v=xrTfUZi5nLo

User avatar
odroid
Site Admin
Posts: 35297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1089 times
Been thanked: 824 times
Contact:

Re: H2+ with External GPU issue

Post by odroid »

anasazi29 wrote:
Tue Aug 11, 2020 9:40 am
odroid wrote:
Mon Aug 10, 2020 9:30 am
Which BIOS version did you run on the old H2 board?
https://wiki.odroid.com/odroid-h2/hardw ... glk-sf_110
I'm pretty sure it was bios version 1.08 on my original H2.
Can you try installing BIOS 1.08 to your H2+ to narrow down root causes?

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

odroid wrote:
Tue Aug 11, 2020 10:47 am
anasazi29 wrote:
Tue Aug 11, 2020 9:40 am
odroid wrote:
Mon Aug 10, 2020 9:30 am
Which BIOS version did you run on the old H2 board?
https://wiki.odroid.com/odroid-h2/hardw ... glk-sf_110
I'm pretty sure it was bios version 1.08 on my original H2.
Can you try installing BIOS 1.08 to your H2+ to narrow down root causes?
yes, i think that might be good thing to try. ALSO, I haven't tried a regular NVMe hard drive on that port. maybe that port just isn't working appropriately.

I also ran the lspci on Ubuntu and the NVIDIA card doesn't show up. so couldn't run the second command with any results.

domih
Posts: 315
Joined: Mon Feb 11, 2019 4:48 pm
languages_spoken: English, French
ODROIDs: UX4, HC2, N2, H2, C4, H2+
Location: San Francisco Bay Area
Has thanked: 103 times
Been thanked: 113 times
Contact:

Re: H2+ with External GPU issue

Post by domih »

anasazi29 wrote:
Tue Aug 11, 2020 11:31 am
I also ran the lspci on Ubuntu and the NVIDIA card doesn't show up. so couldn't run the second command with any results.
Hah! So the problem starts right away. You mentioned in the OP that PCI Express Clock Gating is disabled. Fine.

I think I remember that for some other cards disabling Compliance Mode also helped (I think it was with the SolarFlare network cards).

No guaranty. Try the 4 cases of PCI Express Clock Gating and Compliance Mode enabled or disabled.

I also remember that I never got some card models to work no matter what.
These users thanked the author domih for the post:
anasazi29 (Tue Aug 11, 2020 8:29 pm)

brad
Posts: 1208
Joined: Tue Mar 29, 2016 1:22 pm
languages_spoken: english
ODROIDs: C2 N1 N2 N2+ H2 H2+ (64 bit ftw)
Location: Australia
Has thanked: 75 times
Been thanked: 124 times
Contact:

Re: H2+ with External GPU issue

Post by brad »

It might be worth checking the power supply cables as well just to ensure the cards are not resetting when initializing and causing the error. (and not showing up straight away for the OS)

I notice in the photo your using a sata connector to supply the external GPU power. This might not be enough, do you have a modular plug for the power supply to have it connect direct to the GPU with no adapter?

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

brad wrote:
Tue Aug 11, 2020 5:56 pm
It might be worth checking the power supply cables as well just to ensure the cards are not resetting when initializing and causing the error. (and not showing up straight away for the OS)

I notice in the photo your using a sata connector to supply the external GPU power. This might not be enough, do you have a modular plug for the power supply to have it connect direct to the GPU with no adapter?
yeah, the picture might be a bit deceiving, but the GPU has its own 8-pin power cable coming directly from the power supply.

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

domih wrote:
Tue Aug 11, 2020 3:55 pm
anasazi29 wrote:
Tue Aug 11, 2020 11:31 am
I also ran the lspci on Ubuntu and the NVIDIA card doesn't show up. so couldn't run the second command with any results.
Hah! So the problem starts right away. You mentioned in the OP that PCI Express Clock Gating is disabled. Fine.

I think I remember that for some other cards disabling Compliance Mode also helped (I think it was with the SolarFlare network cards).

No guaranty. Try the 4 cases of PCI Express Clock Gating and Compliance Mode enabled or disabled.

I also remember that I never got some card models to work no matter what.
dang, I was hoping something simple in the bios would help but ...I checked and Compliance Mode is disabled by default, so I enabled it and booted Windows 10 Pro and Ubuntu, neither show the video card. but on Windows, as normal, if I run scan hardware, it finds the nvidia card, but continues to say no resources to run it.

brad
Posts: 1208
Joined: Tue Mar 29, 2016 1:22 pm
languages_spoken: english
ODROIDs: C2 N1 N2 N2+ H2 H2+ (64 bit ftw)
Location: Australia
Has thanked: 75 times
Been thanked: 124 times
Contact:

Re: H2+ with External GPU issue

Post by brad »

anasazi29 wrote:
Tue Aug 11, 2020 8:19 pm
yeah, the picture might be a bit deceiving, but the GPU has its own 8-pin power cable coming directly from the power supply.
When I first set mine up recently for this test the power supply was initially controlled by a new PC motherboard / cpu but with no RAM installed. I thought by just turning it on I would get a constant supply but no it would reset every 3 mins. (hey the pc bios did not like missing ram so reset the supply so fair enough)

I just used a copper run on the 24 pin PS connector to turn the power supply on constantly with no problems (green wire / pin 5 to one of the earths in the connector).

I always turned this on just before power to the H2+

My PS supplies 12v external power via a 8 pin connector to my gpu, and via another modular connector a 12v + 5v supply (the sata to floppy adapter in my pic) direct to the ADT adapter. It is important that this last connection can supply both a steady 12v & 5v supply of ample wattage that would be expected by the pcie standard as the M.2 connector cannot do this.

I'm probably wrong but it is worth a try if possible (I don't have any nvidia cards to check how they work)

Good luck :)

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

at the moment I have ordered the same adapter that Brad used, tested and showed above. once I get that and test it and if that doesn't work, then I'm going to try to return this one and order another one. as simple as this should be, I think there might be something wrong with the NVMe port.

User avatar
odroid
Site Admin
Posts: 35297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1089 times
Been thanked: 824 times
Contact:

Re: H2+ with External GPU issue

Post by odroid »

Do you have a spare NVMe storage device to check the M.2 socket functionality on your H2+ board?

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

brad wrote:
Tue Aug 11, 2020 9:24 pm
anasazi29 wrote:
Tue Aug 11, 2020 8:19 pm
yeah, the picture might be a bit deceiving, but the GPU has its own 8-pin power cable coming directly from the power supply.
When I first set mine up recently for this test the power supply was initially controlled by a new PC motherboard / cpu but with no RAM installed. I thought by just turning it on I would get a constant supply but no it would reset every 3 mins. (hey the pc bios did not like missing ram so reset the supply so fair enough)

I just used a copper run on the 24 pin PS connector to turn the power supply on constantly with no problems (green wire / pin 5 to one of the earths in the connector).

I always turned this on just before power to the H2+

My PS supplies 12v external power via a 8 pin connector to my gpu, and via another modular connector a 12v + 5v supply (the sata to floppy adapter in my pic) direct to the ADT adapter. It is important that this last connection can supply both a steady 12v & 5v supply of ample wattage that would be expected by the pcie standard as the M.2 connector cannot do this.

I'm probably wrong but it is worth a try if possible (I don't have any nvidia cards to check how they work)

Good luck :)
received EXACT pcie nvme adapter you had and the video card has no response. doesn't show up in hardware at all.
Attachments
20200817_211759.jpg
20200817_211759.jpg (531.8 KiB) Viewed 939 times

domih
Posts: 315
Joined: Mon Feb 11, 2019 4:48 pm
languages_spoken: English, French
ODROIDs: UX4, HC2, N2, H2, C4, H2+
Location: San Francisco Bay Area
Has thanked: 103 times
Been thanked: 113 times
Contact:

Re: H2+ with External GPU issue

Post by domih »

I concur with the last suggestion from Odroid, try a spare NVMe and use 'lspci' + 'sudo lspci --vv -s nn:nn.n | grep Width' to check that the M.2 slot is working and has x4 lanes. Then format the NVMe and do some file IO with it to confirm it works. If yes, to all of that the M.2 slot is no longer a culprit candidate.

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

odroid wrote:
Fri Aug 14, 2020 9:58 am
Do you have a spare NVMe storage device to check the M.2 socket functionality on your H2+ board?
Several things.
First I removed my eMMC 64GB module. Just to leave this out of the equation.
After connecting a new NVMe drive, the bios shows nothing connected. (snapshot shown)
Windows 10 installation shows no hard drive to install on. Even using F10, command prompt, disk part, list disk, nothing listed except USB booted flash drive.
Ubuntu Linux boot, ran the lspci command and nothing regarding the NVMe drive or port to run the second command on.
I connect the NVMe drive via USB to my windows machine and removed all partitions, then reattached and checked it on the H2 through the bios, windows 10 installation and ubuntu, nothing listed.
I reconnected the device to my windows machine, formatted a 32GB fat32 partition and reconnect to my H2 and looked in bios, checked windows 10 installation and ubuntu, and nothing found or available.
Thank you ALL for you diagnostics, recommendation, etc.
Attachments
ubuntu_lspci.jpg
ubuntu_lspci.jpg (615.68 KiB) Viewed 900 times
win10_install_noHD.jpg
win10_install_noHD.jpg (349.21 KiB) Viewed 900 times
odroid_h2plus_bios.jpg
odroid_h2plus_bios.jpg (737.27 KiB) Viewed 900 times
odroid_h2plus_bottom.jpg
odroid_h2plus_bottom.jpg (542.71 KiB) Viewed 900 times

User avatar
odroid
Site Admin
Posts: 35297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1089 times
Been thanked: 824 times
Contact:

Re: H2+ with External GPU issue

Post by odroid »

@anasazi29,
Can you tell me the exact model name of the NVMe storage device?
Is it working with your old H2 board?

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

I was contact by Sienna Kim from Odroid and being that my H2 is slightly over 30 days while trying to diagnose this issue, my device is no longer under warranty. if I wanted service on it, i would have to pay shipping to and from South Korea, which would cost me about $70 one direction. since the H2 only cost $118, obviously I'll just have to keep it and use the device for another purpose that doesn't use the bottom NVMe port.

User avatar
odroid
Site Admin
Posts: 35297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1089 times
Been thanked: 824 times
Contact:

Re: H2+ with External GPU issue

Post by odroid »

It is not fair.
We will extend the warranty since you spent very long time for the test. Just pay one-way shipping cost and we will send you a new H2+ board with our cost.
Please contact her again with a link of this reply.
These users thanked the author odroid for the post:
domih (Sat Aug 22, 2020 1:49 pm)

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

odroid wrote:
Sat Aug 22, 2020 11:46 am
It is not fair.
We will extend the warranty since you spent very long time for the test. Just pay one-way shipping cost and we will send you a new H2+ board with our cost.
Please contact her again with a link of this reply.
thank you very much. I have replied to the email with your information and link to this forum.

I am willing to pay for the shipping to you.

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

first of all, I want to tell everyone how much I appreciate the recommendations and various ideas of testing the hardware.
second the Hardkernel company and especially the Odroid forums team for allowing me to receive a replacement device.

I received it today and just as a first test, I have connected the original ram for it, and the NVMe hard drive and booted with Windows 10 and it immediately show the hard drive ready to and ready to install. I have since installed Windows 10 and everything is working as it should.
Attachments
H2plus_2_HD_showing.jpg
H2plus_2_HD_showing.jpg (330.88 KiB) Viewed 501 times
These users thanked the author anasazi29 for the post (total 3):
brad (Tue Sep 01, 2020 12:10 pm) • odroid (Tue Sep 01, 2020 1:28 pm) • domih (Wed Sep 02, 2020 5:03 am)

anasazi29
Posts: 26
Joined: Sun Aug 09, 2020 6:57 am
languages_spoken: english
ODROIDs: Odroid XU4, H2, N2(2GB), H2+ and N2+ (4GB)
Has thanked: 3 times
Been thanked: 6 times
Contact:

Re: H2+ with External GPU issue

Post by anasazi29 »

last post for this category issue, but everything is working amazing now. other reading this.. the Odroid product is a great piece of hardware and will work with just about any other hardware right out of the box, including an external video card.

thanks,
Attachments
20200902_211901.jpg
20200902_211901.jpg (361.91 KiB) Viewed 376 times
20200901_213439.jpg
20200901_213439.jpg (959.15 KiB) Viewed 376 times
20200901_201450.jpg
20200901_201450.jpg (941.47 KiB) Viewed 376 times
These users thanked the author anasazi29 for the post (total 3):
brad (Sat Sep 05, 2020 11:42 pm) • domih (Sun Sep 06, 2020 6:37 am) • odroid (Mon Sep 07, 2020 10:45 am)

mad_ady
Posts: 8463
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 577 times
Been thanked: 461 times
Contact:

Re: H2+ with External GPU issue

Post by mad_ady »

For an external gpu with H2 I'd be interested in seeing a case design that prevents cables from being accessible...

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 0 guests