Problem with micro SD card after last Updates

Post Reply
rasto001
Posts: 15
Joined: Fri Jan 05, 2018 4:41 pm
languages_spoken: english
ODROIDs: C2
Has thanked: 0
Been thanked: 1 time
Contact:

Problem with micro SD card after last Updates

Post by rasto001 » Sat Apr 25, 2020 4:53 pm

Hello. I wrote this notice in other threat but without relevant response so I will repeat it here. Last two Android Pie 64bit updates (20200422) and (20200414) brought to my N2 new bug. After update I had problem with mounting microSD card which was already present from beginning. Changing for other piece of micro SD didn't help too. Both of tested microSD cards are OK (read/write) in other Android and Windows equipment. So I've downgraded to version Android Pie 64bit (20200318) and microSD card is working again without problem. So I wanted to let responsible persons know :)

User avatar
odroid
Site Admin
Posts: 34162
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 683 times
Been thanked: 619 times
Contact:

Re: Problem with micro SD card after last Updates

Post by odroid » Wed May 06, 2020 1:53 pm

What is the brand and model name of your microSD card?

rasto001
Posts: 15
Joined: Fri Jan 05, 2018 4:41 pm
languages_spoken: english
ODROIDs: C2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: Problem with micro SD card after last Updates

Post by rasto001 » Sun May 17, 2020 8:29 pm

SanDisk micro SDHC 32 GB Extreme Pro A1 UHS-I (V30)

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Mon May 18, 2020 12:13 am

rasto001 wrote:
Sun May 17, 2020 8:29 pm
SanDisk micro SDHC 32 GB Extreme Pro A1 UHS-I (V30)
Have you tried the recent version 20200507 yet? The version has a fix for SD failure.
https://wiki.odroid.com/odroid-n2/os_im ... t_android1

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Mon May 18, 2020 4:23 am

I have your last version.20200507 and CE 9.2.2 on eMMC. With latest Android 64 bit 20200507 everything works OK, as expected.

But with latest "ROM AOSP Android 9.0 Pie + Android-TV" version by @secuflag and after selecting this to boot from uSD card it gets stuck on HK black logo from Android.

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Mon May 18, 2020 6:50 am

Sholander wrote:
Mon May 18, 2020 4:23 am
I have your last version.20200507 and CE 9.2.2 on eMMC. With latest Android 64 bit 20200507 everything works OK, as expected.

But with latest "ROM AOSP Android 9.0 Pie + Android-TV" version by @secuflag and after selecting this to boot from uSD card it gets stuck on HK black logo from Android.
Did you update Android-TV recently?

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Mon May 18, 2020 8:08 am

Yes, of course I'm talking about the latest OS/Petitboot versions.

(Both Androids, Pie regular and ATV have the same .DTB, boot.ini and display.bin but different default.prop
In env.ini there is a difference colorattribute="444,8bit" vs colorattribute="444,12bit" in ATV)

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Mon May 18, 2020 8:13 am

Sholander wrote:
Mon May 18, 2020 8:08 am
Yes, of course I'm talking about the latest OS/Petitboot versions.

(Both Androids, Pie regular and ATV have the same .DTB, boot.ini and display.bin but different default.prop
In env.ini there is a difference colorattribute="444,8bit" vs colorattribute="444,12bit" in ATV)
I doubt that the A-TV kernel has not been updated very recently, the SD issue has been reported a week ago with LineageOS and had been fixed.

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Mon May 18, 2020 9:42 am

I am very sorry for wrong information I wrote in previous posts, I got my results completely wrong. This is my situation now:

Both versions, Pie 64 and ATV 64 don't boot from uSD card via Petitboot when CE 9.2.2 eMMC is inserted, both get stuck at HK logo after they are selected in Petitboot. At the same time CoreElec on eMMC starts via Petitboot with both Android (PIE & ATV) versions on uSD card. Both Android boot/reboot OK if only uSD cards are inserted.

So it looks as if my Petitboot version from 20200508 does not work...

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Mon May 18, 2020 10:25 am

Sholander wrote:
Mon May 18, 2020 9:42 am
Both versions, Pie 64 and ATV 64 don't boot from uSD card via Petitboot when CE 9.2.2 eMMC is inserted, both get stuck at HK logo after they are selected in Petitboot. At the same time CoreElec on eMMC starts via Petitboot with both Android (PIE & ATV) versions on uSD card. Both Android boot/reboot OK if only uSD cards are inserted.
Well...sorry, I do not quite understand this. Are you saying the Android 64 or ATV 64 cannot boot while 32 bit versions can?

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Mon May 18, 2020 6:09 pm

No, I use only 64 bit Android versions, latest ATV https://github.com/odroid-dev/android-pie/releases/ and latest Pie https://wiki.odroid.com/odroid-n2/os_im ... 4_20200507 installed on 2 different uSD cards.

They both work OK only if there is no eMMC with CE inserted. When I insert eMMC and flip the switch to SPI position none can boot. When I select to boot any Android version in Petitboot, N2 reboots and then freezes on Hardkernel logo. If I select to boot CE from eMMC it boots OK.

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Mon May 18, 2020 7:25 pm

Sholander wrote:
Mon May 18, 2020 6:09 pm
No, I use only 64 bit Android versions, latest ATV https://github.com/odroid-dev/android-pie/releases/ and latest Pie https://wiki.odroid.com/odroid-n2/os_im ... 4_20200507 installed on 2 different uSD cards.

They both work OK only if there is no eMMC with CE inserted. When I insert eMMC and flip the switch to SPI position none can boot. When I select to boot any Android version in Petitboot, N2 reboots and then freezes on Hardkernel logo. If I select to boot CE from eMMC it boots OK.
I made the same OS setup with you, but my Android 64 bit can boot with the Petitboot while CE on eMMC is attached. My Android 64 bit version is 20200507 and CE is 9.2.2 Stable. Do you have any log through the serial port? Which uSD card do you use?
Just in case, can you test with yet another test version 20200511?
http://ppa.linuxfactory.or.kr/images/pe ... 200511.img

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Tue May 19, 2020 1:52 am

Interesting, I am using same OS versions as you, and form me this combination doesn't work :?: Both cards I use are Sandisk (Ultra and Extreme) -32GB HC1, proven to work excellent on N2.

Will try new Petitboot test version tonight, and report result...

Btw, cannot get any boot logs at the moment; I have an uSD SDIO Debug Board, but lost (forgot where I stored it) my CP2102 UART converter. Ordered a new one but it takes ages to arrive...

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Tue May 19, 2020 3:45 am

Sholander wrote:
Tue May 19, 2020 1:52 am
Interesting, I am using same OS versions as you, and form me this combination doesn't work :?: Both cards I use are Sandisk (Ultra and Extreme) -32GB HC1, proven to work excellent on N2.
Will try new Petitboot test version tonight, and report result...
Same results, nothing changed. Tried with "spiboot-20200511.img", "spiboot-20200508.img", "spiboot-20200224.img" and "spiboot-20200118.img".

Tested with: CoreElec 9.2.2 on eMMC and CoreElec nightly on Sandisk Ultra uSD. CEs boot and work OK with ANY possible SPI/Petitboot combination. with only eMMC, or any OS on uSD card.

Tested with latest fresh installation of Android "selfinstall-odroidn2-55-64bit-20200507.img" on Sandisk Ultra and latest fresh installation of "ROM AOSP Android 9.0 Pie + Android-TV" version on Sandisk extreme.

Results: Both Androids work OK, boot/reboot when only uSD card is inserted. Both Androids don't boot when SPI switch is in SPI position with or without CE on eMMC is inserted.

Behavior: with SPI switch on SPI position and only (any) Android on uSD card is booted, it boots Petitboot and after selecting, or auto boot to Android, N2 reboots and gets stuck on Hardkernel logo. Blue led is constantly on, and there is no power on USB 3.0 ports (did not check front micro USB port). Ethernet led is on. The same behavior is with all Petitboot versions and with or without eMMC inserted.

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Tue May 19, 2020 4:57 am

Sholander wrote:
Tue May 19, 2020 3:45 am
Sholander wrote:
Tue May 19, 2020 1:52 am
Interesting, I am using same OS versions as you, and form me this combination doesn't work :?: Both cards I use are Sandisk (Ultra and Extreme) -32GB HC1, proven to work excellent on N2.
Will try new Petitboot test version tonight, and report result...
Same results, nothing changed. Tried with "spiboot-20200511.img", "spiboot-20200508.img", "spiboot-20200224.img" and "spiboot-20200118.img".

Tested with: CoreElec 9.2.2 on eMMC and CoreElec nightly on Sandisk Ultra uSD. CEs boot and work OK with ANY possible SPI/Petitboot combination. with only eMMC, or any OS on uSD card.

Tested with latest fresh installation of Android "selfinstall-odroidn2-55-64bit-20200507.img" on Sandisk Ultra and latest fresh installation of "ROM AOSP Android 9.0 Pie + Android-TV" version on Sandisk extreme.

Results: Both Androids work OK, boot/reboot when only uSD card is inserted. Both Androids don't boot when SPI switch is in SPI position with or without CE on eMMC is inserted.

Behavior: with SPI switch on SPI position and only (any) Android on uSD card is booted, it boots Petitboot and after selecting, or auto boot to Android, N2 reboots and gets stuck on Hardkernel logo. Blue led is constantly on, and there is no power on USB 3.0 ports (did not check front micro USB port). Ethernet led is on. The same behavior is with all Petitboot versions and with or without eMMC inserted.
I've tested with the "Android "selfinstall-odroidn2-55-64bit-20200507.img" and CoreELEC nightly version, they worked as expected. Something suspicious is SD card, it may cause the problem. Recently Android has been updated due to incompatible SD card issue, this may cause the problem. Let me find the same SD card Sandisk Ultra to test. Meanwhile, can you please to apply disable_uhs=true option with the Petitboot (20200118+)?
viewtopic.php?f=182&t=33873&hilit=disab ... 50#p278201

What was the Petitboot version before updating? 20191128?

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Tue May 19, 2020 5:44 am

tobetter wrote:
Tue May 19, 2020 4:57 am
Sholander wrote:
Tue May 19, 2020 3:45 am

Behavior: with SPI switch on SPI position and only (any) Android on uSD card is booted, it boots Petitboot and after selecting, or auto boot to Android, N2 reboots and gets stuck on Hardkernel logo. Blue led is constantly on, and there is no power on USB 3.0 ports (did not check front micro USB port). Ethernet led is on. The same behavior is with all Petitboot versions and with or without eMMC inserted.
I've tested with the "Android "selfinstall-odroidn2-55-64bit-20200507.img" and CoreELEC nightly version, they worked as expected. Something suspicious is SD card, it may cause the problem. Recently Android has been updated due to incompatible SD card issue, this may cause the problem. Let me find the same SD card Sandisk Ultra to test. Meanwhile, can you please to apply disable_uhs=true option with the Petitboot (20200118+)?
viewtopic.php?f=182&t=33873&hilit=disab ... 50#p278201

What was the Petitboot version before updating? 20191128?
Updatet Petitboot as versions became available: spiboot-20200118.img -> spiboot-20200224.img -> spiboot-20200508.img -> spiboot-20200511.img

Since CE works with last 2 Petitboot versions without any problem, from uSD and from eMMC, SPI in left or right position, I don't think that Petitboot is cause of my problem.

Will try with "disable_uhs=true" option when I find out how...

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Tue May 19, 2020 9:57 pm

Sholander wrote:
Tue May 19, 2020 5:44 am

Will try with "disable_uhs=true" option when I find out how...
Bad news, changed "disable_uhs=false" to "disable_uhs=true", and checked that it stayed fixed at "disable_uhs=true" after power off/on, but no change:
Both Androids don't boot with switch in SPI position, same as with "disable_uhs=false"...

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Tue May 19, 2020 10:02 pm

Sholander wrote:
Sholander wrote:
Tue May 19, 2020 5:44 am

Will try with "disable_uhs=true" option when I find out how...
Bad news, changed "disable_uhs=false" to "disable_uhs=true", and checked that it stayed fixed at "disable_uhs=true" after power off/on, but no change:
Both Androids don't boot with switch in SPI position, same as with "disable_uhs=false"...
Very odd...is the colour of your eMMC orange? I have tried new Android and had no issue when CE on eMMC is installed. Do you know which version of the Petitboot can start Android when CE on eMMC is attached?

"Tapatalk wishes you to have fun with ODROID"


lightsout
Posts: 83
Joined: Wed Aug 28, 2019 5:26 am
languages_spoken: english
Has thanked: 3 times
Been thanked: 4 times
Contact:

Re: Problem with micro SD card after last Updates

Post by lightsout » Tue May 19, 2020 11:08 pm

I have been having similar issue. With two different SD cards but both are Samsung Evo 32 GB.

I too have the stable coreelec 9.2.2 on emmc and it boots fine.

I recently again tried both versions of Android TV and can't get Android to boot. I haven't tested with the most recent version if they have put out updates.

I posted elsewhere a similar issue with Ubuntu on an SD card. Oddly I updated petiboot and it booted the first time. But yesterday tried to boot Ubuntu and just got a black screen.

Honestly at this point I've given up on the N2 for anything besides coreelec, it's given me too many issues trying to boot any other os.

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Tue May 19, 2020 11:39 pm

lightsout wrote:
Tue May 19, 2020 11:08 pm
I have been having similar issue. With two different SD cards but both are Samsung Evo 32 GB.

I too have the stable coreelec 9.2.2 on emmc and it boots fine.

I recently again tried both versions of Android TV and can't get Android to boot. I haven't tested with the most recent version if they have put out updates.

I posted elsewhere a similar issue with Ubuntu on an SD card. Oddly I updated petiboot and it booted the first time. But yesterday tried to boot Ubuntu and just got a black screen.

Honestly at this point I've given up on the N2 for anything besides coreelec, it's given me too many issues trying to boot any other os.
Sorry to hear that, that's very odd. I've set up the same OS configuration and having tested with multiple OS images on the SD card I have. None of them makes an error except Samsung EVO but that's a different problem than the screen issue. Don't get me wrong, just I am not able to reproduce the same problem with same OS images. :(

EDIT: I dislike Samsung EVO uSD since they behave differently between their colours. If you have not tried to disable_uhs=true once yet, it's worth to try.

lightsout
Posts: 83
Joined: Wed Aug 28, 2019 5:26 am
languages_spoken: english
Has thanked: 3 times
Been thanked: 4 times
Contact:

Re: Problem with micro SD card after last Updates

Post by lightsout » Tue May 19, 2020 11:46 pm

tobetter wrote:
Tue May 19, 2020 11:39 pm
lightsout wrote:
Tue May 19, 2020 11:08 pm
I have been having similar issue. With two different SD cards but both are Samsung Evo 32 GB.

I too have the stable coreelec 9.2.2 on emmc and it boots fine.

I recently again tried both versions of Android TV and can't get Android to boot. I haven't tested with the most recent version if they have put out updates.

I posted elsewhere a similar issue with Ubuntu on an SD card. Oddly I updated petiboot and it booted the first time. But yesterday tried to boot Ubuntu and just got a black screen.

Honestly at this point I've given up on the N2 for anything besides coreelec, it's given me too many issues trying to boot any other os.
Sorry to hear that, that's very odd. I've set up the same OS configuration and having tested with multiple OS images on the SD card I have. None of them makes an error except Samsung EVO but that's a different problem than the screen issue. Don't get me wrong, just I am not able to reproduce the same problem with same OS images. :(
Please don't take my comment as a complaint, it came off that way, I am thankful for the work that goes into these. I thought I was doing something
wrong for a while. But at least am happy to see I am not alone. I did read the issue with the Evo specifically, so I tried the SD card that ameridroid sold
with the coreelec kit and had the same issue. Not sure what it is but I install android on the N2 more as something to mess with, it never gets used in real
usage for me so I haven't put a ton of time into it.

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Tue May 19, 2020 11:52 pm

lightsout wrote:
Tue May 19, 2020 11:46 pm
tobetter wrote:
Tue May 19, 2020 11:39 pm
lightsout wrote:
Tue May 19, 2020 11:08 pm
I have been having similar issue. With two different SD cards but both are Samsung Evo 32 GB.

I too have the stable coreelec 9.2.2 on emmc and it boots fine.

I recently again tried both versions of Android TV and can't get Android to boot. I haven't tested with the most recent version if they have put out updates.

I posted elsewhere a similar issue with Ubuntu on an SD card. Oddly I updated petiboot and it booted the first time. But yesterday tried to boot Ubuntu and just got a black screen.

Honestly at this point I've given up on the N2 for anything besides coreelec, it's given me too many issues trying to boot any other os.
Sorry to hear that, that's very odd. I've set up the same OS configuration and having tested with multiple OS images on the SD card I have. None of them makes an error except Samsung EVO but that's a different problem than the screen issue. Don't get me wrong, just I am not able to reproduce the same problem with same OS images. :(
Please don't take my comment as a complaint, it came off that way, I am thankful for the work that goes into these. I thought I was doing something
wrong for a while. But at least am happy to see I am not alone. I did read the issue with the Evo specifically, so I tried the SD card that ameridroid sold
with the coreelec kit and had the same issue. Not sure what it is but I install android on the N2 more as something to mess with, it never gets used in real
usage for me so I haven't put a ton of time into it.
No worries, not at all. It's just a shame of mine that I am not able to manage the issue properly.

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Wed May 20, 2020 12:10 am

tobetter wrote:
Tue May 19, 2020 10:02 pm
Very odd...is the colour of your eMMC orange? I have tried new Android and had no issue when CE on eMMC is installed. Do you know which version of the Petitboot can start Android when CE on eMMC is attached?
This is my eMMC module https://www.hardkernel.com/shop/32gb-em ... -n2-linux/
None Petitboot published this year can start new 64bit Androids (the ones with black HK logo) when CE is on eMMC or even without eMMC inserted. Just flipping SPI switch to left position stops Android from booting...

Old Android 64 bit versions (with white HK logo) all worked without problems on same uSD cards that I use now for latest Android versions.

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Wed May 20, 2020 12:18 am

Sholander wrote:
Wed May 20, 2020 12:10 am
tobetter wrote:
Tue May 19, 2020 10:02 pm
Very odd...is the colour of your eMMC orange? I have tried new Android and had no issue when CE on eMMC is installed. Do you know which version of the Petitboot can start Android when CE on eMMC is attached?
This is my eMMC module https://www.hardkernel.com/shop/32gb-em ... -n2-linux/
None Petitboot published this year can start new 64bit Androids (the ones with black HK logo) when CE is on eMMC or even without eMMC inserted.

Old Android 64 bit versions (with white HK logo) all worked without problems on same uSD cards that I use now for latest Android versions.
:( That's really odd...
Can you please update this image?
This is the modified 20191127 image because of Android boot script change.
http://ppa.linuxfactory.or.kr/images/pe ... 7-0508.img
Last edited by tobetter on Wed May 20, 2020 12:20 am, edited 1 time in total.

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Wed May 20, 2020 12:19 am

Will try it tonight and report...

User avatar
tobetter
Posts: 5101
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: Problem with micro SD card after last Updates

Post by tobetter » Wed May 20, 2020 12:31 am

@lightscout, can you let me know the colour of your Samsung EVO 32G card?

lightsout
Posts: 83
Joined: Wed Aug 28, 2019 5:26 am
languages_spoken: english
Has thanked: 3 times
Been thanked: 4 times
Contact:

Re: Problem with micro SD card after last Updates

Post by lightsout » Wed May 20, 2020 12:47 am

tobetter wrote:@lightscout, can you let me know the colour of your Samsung EVO 32G card?
Yes it's green and white.


Samsung (MB-ME32GA/AM) 32GB 95MB/s (U1) microSDHC EVO Select Memory Card with Full-Size Adapter https://www.amazon.com/dp/B06XWN9Q99/re ... WEbMM7VBGX
These users thanked the author lightsout for the post:
tobetter (Wed May 20, 2020 12:57 am)

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

Re: Problem with micro SD card after last Updates

Post by Sholander » Wed May 20, 2020 2:26 am

tobetter wrote:
Wed May 20, 2020 12:18 am

Can you please update this image?
This is the modified 20191127 image because of Android boot script change.
http://ppa.linuxfactory.or.kr/images/pe ... 7-0508.img
Tried with this image, NO change. It behaves the same as all other versions.
The only thing is that I always update only spiboot.img file, and never used "SPI Recovery.img" and replacing default spiboot.img with the latest one.
Can this method make any difference to Petitboot behaviour?
Otherwise it looks to me like both my 64bit Androids (PIE and ATV) have something wrong...

Sholander
Posts: 126
Joined: Wed Jun 05, 2019 1:02 am
languages_spoken: english
ODROIDs: ODROID N2
Has thanked: 0
Been thanked: 12 times
Contact:

[SOLVED] Problem with micro SD card after last Updates

Post by Sholander » Sun May 31, 2020 12:43 am

Just to inform, I solved my Android dual boot with CoreElec problem. For more info how I did it look here:
viewtopic.php?f=182&t=33873&p=294292#p294292

Post Reply

Return to “Android”

Who is online

Users browsing this forum: rusnak666 and 3 guests