mmc issues ==>solved

Post Reply
Mangasora
Posts: 37
Joined: Sun Oct 09, 2016 9:00 pm
languages_spoken: bulgarian
ODROIDs: XU4 & N2
Location: Bulgaria
Has thanked: 3 times
Been thanked: 1 time
Contact:

mmc issues ==>solved

Post by Mangasora » Mon May 11, 2020 9:21 pm

Hello,
I use N2 with a CoreELEC of the mmc module and ATV of the sd card.I use petitboot to boot the required operating system.
After an update of CoreELEC, the same disappeared from the petitboot menu.I decided that something went wrong during the update and installed it on a clean CoreELEC image.Nothing has changed. CoreELEC starts successfully when the switch is to MMC boot mode.When switch is to SPI boot mode only the sd card is visible.The petitboot indicates that the MMC module partitions are mounted but not visible in the boot menu.Also when mmc boot mode is selected and mmc module and sd card are installed we have bootloop.If anyone has encountered a similar problem I would be grateful to help with advice, an idea or a ready-made solution.
Last edited by Mangasora on Tue May 12, 2020 3:12 pm, edited 1 time in total.

User avatar
tobetter
Posts: 5100
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 160 times
Been thanked: 492 times
Contact:

Re: mmc issues

Post by tobetter » Tue May 12, 2020 12:03 am

Can you let me know the version of your CoreELEC that keeps rebooting when SD card is inserted?

EDIT: I've contact with CE team and found that their boot script is changed.. Problem is CE update or my Petitboot has to be updated, and waiting for the response from the right person while I am looking into the code to fix the issue.

The simplest fix for you is to add a single line booti ${loadaddr} - ${dtb_mem_addr} at the end of the boot.ini in your COREELEC partition. So it would be looked like:

Code: Select all

load mmc ${mmc_dev}:1 ${loadaddr} kernel.img
load mmc ${mmc_dev}:1 ${dtb_mem_addr} dtb.img
booti ${loadaddr} - ${dtb_mem_addr}
bootm
EDIT: I've rebuilt the Petitboot image with the fix, please download and update with the image. Copy the file 'spiboot-20200511.img' to 'spiboot.img' to the 1st partition of your SD card and do the power cycle while boot select switch is at "SPI".
http://ppa.linuxfactory.or.kr/images/pe ... 200511.img

Please try...
These users thanked the author tobetter for the post:
Mangasora (Tue May 12, 2020 3:11 pm)

Mangasora
Posts: 37
Joined: Sun Oct 09, 2016 9:00 pm
languages_spoken: bulgarian
ODROIDs: XU4 & N2
Location: Bulgaria
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: mmc issues

Post by Mangasora » Tue May 12, 2020 3:06 pm

EDIT: I've rebuilt the Petitboot image with the fix...
Thanks a lot tobetter, the problem is solved.
These users thanked the author Mangasora for the post:
tobetter (Tue May 12, 2020 3:16 pm)

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests