RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post Reply
User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

only issue thus far is the flycast plugin, im trying another rom in cdi format because the previouse one i tried was chd
(Update)
cdi, bin/cue and gdi run just fine

Everything else psx, psp, etc run fabulouse, kodi thus far is extremely stable.

Just out of curiouseity would this image be installable to emmc?

I did just notice something inputstream adaptive and sidplay audio decoder cant be updated due to unmet dependancys.

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

I just uploaded a rebuilt emmc image. Those addons are included in the image, I’ll update them.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

Any possibility in adding the mame2003 and 2003-plus libretro-cores? oops nevermind 2003-plus is in there (Sweet!)

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

There isn't any newer inputstream for Leia.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

trying to find a working picodrive_libretro.so for my segacd roms
other than stuff we can do on our own as users this is freaking awsome. The only thing I could possibly love to see is the tft screen module built into the kernel, but heck not being able to access the ogst screen is worth the loss for something stable like this.
Last edited by rfrayer on Thu Feb 27, 2020 5:18 am, edited 1 time in total.

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

What about the already included genesis_plus_gx?
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

escalade wrote:
Thu Feb 27, 2020 5:09 am
What about the already included genesis_plus_gx?
I didnt even notice it in the tmp/cores directory until you said that lol, works great.

is there any possibility of adjusting the heat thresholds for the fans on here, I cant seem to find any reference to them in the proc folder

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

Look at /usr/bin/cpufreq for how to configure the "conservative" governor, I haven't played with it yet so have just set performance as it doesn't trigger fast enough atm. Let me know if you come up with some sane default values.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

/sys/devices/platform/pwm-fan/hwmon/hwmon0/power

has some threshold levels but doing an echo doesnt do anything

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

/sys/devices/virtual/thermal/thermal_zone0/trip_point_0_temp
/sys/devices/virtual/thermal/thermal_zone1/trip_point_1_temp

and so on would need to be adjusted, but cant directly on libreelec elec because of the filesystem

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

It's the same sysfs as any other Linux distro. Others use extra software daemons to take care of handling it, but I think scripting it as simply and effectively as possible is a better and more lightweight way.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

the dreamcast core crashes on everything but gdi

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

did a bit more testing on the emmc build, anything having to do with iptv or remote streaming crashes kodi with nothing in the crash logs regarding why.

Code: Select all

############## kodi CRASH LOG ###############

################ SYSTEM INFO ################
 Date: Wed Feb 26 22:35:10 EST 2020
 kodi Options: --standalone -fs
 Arch: armv7l
 Kernel: Linux 5.4.6 #1 SMP PREEMPT Wed Feb 26 10:05:08 CET 2020
 Release: LibreELEC devel-20200226132803-28eddc2
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################


############### END LOG FILE ################

############ END kodi CRASH LOG #############
Also volume control in emulation station does not work (It has sound but it cant be turned up or down)

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

Yeah I think someone reported the same a while back, no idea why it would crash or how to debug it. Do you have a clear way I can reproduce it?

Regarding volume control, Emulationstation is kind of stuck in time it hasn't had real development other than the occational small fixes and improvements from RetroPie. The volume controls work for ALSA/RPi only I think, can't say it's an issue for me. You could script your own volume preset on Emulationstation launch.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

yes i do.
Enroll for a trial run in one of the iptv services (Ill get banned if i post a link), or install ccloud or ustvnow and try to play anything.

rinku
Posts: 18
Joined: Tue May 28, 2019 1:08 am
languages_spoken: english, french
Has thanked: 1 time
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rinku »

Concerning the crashing issue with tv (the same happens with the twitch extension for kodi), I reported it a while back, here's what the output of dmesg was:

Code: Select all

[583870.526037] s5p_mfc_handle_error:468: Interrupt Error: 00000066
[583870.526105] s5p_mfc_queue_setup:915: State seems invalid. State = 109, vq->type = 9
[583870.526114] reqbufs_capture:542: Failed allocating buffers for CAPTURE queue
[583870.526314] vidioc_qbuf:603: Call on QBUF after unrecoverable error
Seems it's more an error from the system than Kodi itself

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

New image uploaded:

Code: Select all

- Kodi 18.6
- Pulseaudio A2DP codecs support (like aptX)
- New boot splash
- Updated RetroArch and cores
- CEC and MFC fix
@rinku

Can you try the latest? I noticed that the direct firmware load for s5p-mfc-v8.fw failed, although the firmware is in the image itself the driver was built-in. I've fixed this by building s5p-mfc as a module, it now seems to have loaded the firmware. Could very possibly solve the issue.

EDIT - maybe not: viewtopic.php?t=31951#p233089
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

There's a guy that came up with a kernel patch for the Mali gpu I just can't remember his username but he posted a project under other os compiling a bunch of stuff including Kodi 18 with full use of the streaming decoders.

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

The kernel patch is unnecessary.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

Maasto
Posts: 1
Joined: Wed Mar 04, 2020 9:27 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by Maasto »

I own the HardKernel's Wifi dongle but it is not working with RetroELEC. Works fine with Odroid Ubuntu 18.04 img.

If I lsusb via ssh it appear as Ralink Technology, Corp. RT5370 Wireless Adapter
Ifconfig doesn't show any wireless interface.
My usb dongle is recognized but not working as a wifi adapter. I don't see anything regarding wifi in the LibreELEC menu.

Is there anything to do for this dongle to be working with your RetroELEC img ?

Thanks :)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

trying to echo in a new heat trigger gets an error permission denied /sys/devices/virtual/thermal/thermal_zone0/trip_point_0_temp (and its varients) I cant even temporarily modify it.

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

Slightly off topic but do you have any plans for the odroid go advance? That would be mega-awsome.

MastaG
Posts: 333
Joined: Mon Aug 26, 2013 6:05 pm
languages_spoken: english
Has thanked: 24 times
Been thanked: 14 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by MastaG »

rfrayer wrote:
Thu Mar 05, 2020 7:10 am
trying to echo in a new heat trigger gets an error permission denied /sys/devices/virtual/thermal/thermal_zone0/trip_point_0_temp (and its varients) I cant even temporarily modify it.
I think this requires some stuff (writable tripoints?) to be enabled in the kernel

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

@Maasto

Try the latest image, I've enabled RT-53XX support in the RT2800 kernel driver.

@rfrayer

Hardkernel has been kind enough to send me one, so I am actually planning to add support :)

Looks like CONFIG_THERMAL_WRITABLE_TRIPS is needed for what you want to do, I'll enable it in the next build.

Oh, and flycast has been fixed in the latest image ;)
These users thanked the author escalade for the post:
rfrayer (Fri Mar 06, 2020 1:55 pm)
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

Oh that is awesome as heck I'm trying to talk the wife into letting me splurge on one. Has the emmc image been updated?

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

It has now. As mentioned, you can update using an SD image as well. Just drop it in the update folder and reboot.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

escalade wrote:
Fri Mar 06, 2020 6:49 pm
It has now. As mentioned, you can update using an SD image as well. Just drop it in the update folder and reboot.
my dragnrise gamepad stopped working with emulationstation after update on the emmc

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

An update doesn't touch the /storage partition. Check your /storage/.config/emulationstation/es_settings.cfg, which is where the controller configuration for ES is stored.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

looks normal

Code: Select all

<?xml version="1.0"?>
<bool name="BackgroundJoystickInput" value="false" />
<bool name="CaptionsCompatibility" value="true" />
<bool name="CollectionShowSystemInfo" value="true" />
<bool name="DrawFramerate" value="false" />
<bool name="EnableSounds" value="true" />
<bool name="ForceDisableFilters" value="false" />
<bool name="LocalArt" value="false" />
<bool name="MoveCarousel" value="false" />
<bool name="ParseGamelistOnly" value="false" />
<bool name="QuickSystemSelect" value="true" />
<bool name="ScrapeRatings" value="true" />
<bool name="ScreenSaverControls" value="true" />
<bool name="ScreenSaverOmxPlayer" value="false" />
<bool name="ShowHelpPrompts" value="true" />
<bool name="ShowHiddenFiles" value="false" />
<bool name="SlideshowScreenSaverCustomImageSource" value="false" />
<bool name="SlideshowScreenSaverRecurse" value="false" />
<bool name="SlideshowScreenSaverStretch" value="false" />
<bool name="SortAllSystems" value="false" />
<bool name="StretchVideoOnScreenSaver" value="false" />
<bool name="ThreadedLoading" value="true" />
<bool name="UseCustomCollectionsSystem" value="true" />
<bool name="VideoAudio" value="false" />
<bool name="VideoOmxPlayer" value="false" />
<int name="MaxVRAM" value="100" />
<int name="ScraperResizeHeight" value="0" />
<int name="ScraperResizeWidth" value="400" />
<int name="ScreenSaverSwapImageTimeout" value="10000" />
<int name="ScreenSaverSwapVideoTimeout" value="30000" />
<int name="ScreenSaverTime" value="300000" />
<string name="AudioCard" value="default" />
<string name="AudioDevice" value="PCM" />
<string name="CollectionSystemsAuto" value="" />
<string name="CollectionSystemsCustom" value="" />
<string name="GamelistViewStyle" value="automatic" />
<string name="OMXAudioDev" value="both" />
<string name="PowerSaverMode" value="disabled" />
<string name="SaveGamelistsMode" value="on exit" />
<string name="Scraper" value="ScreenScraper" />
<string name="ScreenSaverBehavior" value="dim" />
<string name="ScreenSaverGameInfo" value="never" />
<string name="SlideshowScreenSaverBackgroundAudioFile" value="/storage/.config/emulationstation/slideshow/audio/slideshow_bg.wav" />
<string name="SlideshowScreenSaverImageDir" value="/storage/.config/emulationstation/slideshow/image" />
<string name="SlideshowScreenSaverImageFilter" value=".png,.jpg" />
<string name="StartupSystem" value="" />
<string name="ThemeSet" value="Boxalloy-B-Plus" />
<string name="TransitionStyle" value="instant" />
<string name="UIMode" value="Full" />
<string name="UIMode_passkey" value="uuddlrlrba" />

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

Just tried my AfterGlow Generic Xbox and my ps3 controller as well, none of them work in ES, they still work in retroarch though, I even tried generating a new file and that didnt change anything. The controllers work just fine in retroarch itself and are still working on kodi.

rinku
Posts: 18
Joined: Tue May 28, 2019 1:08 am
languages_spoken: english, french
Has thanked: 1 time
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rinku »

escalade wrote:
Tue Mar 03, 2020 11:55 pm
@rinku

Can you try the latest? I noticed that the direct firmware load for s5p-mfc-v8.fw failed, although the firmware is in the image itself the driver was built-in. I've fixed this by building s5p-mfc as a module, it now seems to have loaded the firmware. Could very possibly solve the issue.

EDIT - maybe not: viewtopic.php?t=31951#p233089
I can confirm it still doesn't work. The same error.

Also I have the same problem than @rfrayer with emulationstation. The latest image doesn't detect my xbox 360 wireless gamepad while it worked just fine with an older image. I tried to remove my input settings from emulationstation and then the configuration gamepad screen shows up saying "1 gamepad detected" but doesn't do anything when I try to hold a button to configure. I have only my 360 gamepad plugged in.

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

Looks like there was a regression in SDL: https://hg.libsdl.org/SDL/rev/3ff45857428d

I've uploaded a fixed image.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

escalade wrote:
Mon Mar 09, 2020 8:40 pm
Looks like there was a regression in SDL: https://hg.libsdl.org/SDL/rev/3ff45857428d

I've uploaded a fixed image.
Working on this end

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

I mispoke, video playback is fine but when the video finishes rather than continuing to the next video the system freezes solid and has to be forced into a reboot and iptv still causes kodi to restart.

rinku
Posts: 18
Joined: Tue May 28, 2019 1:08 am
languages_spoken: english, french
Has thanked: 1 time
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rinku »

Controller in emulationstation works again after having to reconfigure it. Thanks.
Didn't try video playback on kodi yet. I believe the iptv issue is something related to mfc that can't decode the stream. No idea why tho. But it looks like an hardware limitation rather than something fixable. I might be wrong.

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

Lost the ability to scan for new videos since update, checking to see if resetting kodi will fix.

User avatar
rfrayer
Posts: 42
Joined: Thu Feb 06, 2020 10:13 am
languages_spoken: english
ODROIDs: xu4, hc1
Location: Rutledge, Tn USA
Has thanked: 3 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by rfrayer »

I just tried again after resetting everything to default, it is not reading all of my folders shared via smb

Tony32
Posts: 13
Joined: Sun Mar 04, 2018 1:39 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by Tony32 »

Tried this today as this was the only image I found for the XU4 which has kodi 18..
Does not work for me tho installing using etcher on EMMC..
Tried both EMMC image from google drive and "normal" image.
No signal or just black screen :(

To be exact, I tried these:
RetroELEC-OdroidXU3.arm-9.2-devel-20200309123837-251e0c5.img.gz = no signal at all
and
RetroELEC-OdroidXU3.arm-9.2-devel-20200312212432.img.gz = no signal or sometimes just black screen

agronom413
Posts: 1
Joined: Sat Apr 04, 2020 12:33 am
languages_spoken: english, russian
ODROIDs: XU4
Has thanked: 1 time
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by agronom413 »

Could you please clarify if it is ok to use the passive cooling instead of the standard active fan while running this system. Thanks

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

New build uploaded:

Code: Select all

- Samba 4.12
- Qt 5.15 beta2
- Added GUI for Connman and Pulseaudio to the Weston desktop
- Added wlogout to the Weston power icon
- Improvements to Plymouth boot splash
- Latest Kodi Leia git
- Pulseaudio fixes
- All cores updated
@agronom413

I don't know, but CPUs run at full speed when Kodi or ES is running.
These users thanked the author escalade for the post (total 3):
odroid (Wed Apr 08, 2020 10:00 am) • XslushedX (Thu Apr 09, 2020 7:14 am) • agronom413 (Mon Apr 13, 2020 11:14 pm)
Maintainer of RetroELEC (XU4 / OGA / x86_64)

XslushedX
Posts: 2
Joined: Thu Apr 09, 2020 7:07 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 1 time
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by XslushedX »

First thank you for your work to bring RetroELEC to the OdroidXU4 !!

Tried your new build "RetroELEC-OdroidXU3.arm-9.2-devel-20200408010806.img.gz" on sd card but get no signal and no boot.

Wondermusic
Posts: 19
Joined: Tue Nov 05, 2019 7:47 pm
languages_spoken: German, English
ODROIDs: XU4
Has thanked: 8 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by Wondermusic »

Hi escalade,
after a while absent from XU4 stuff I'm back again and my hardware settings changed. So I installed the latest eMMc Version from Google Drive and resizing and first boot works perfect.
But if I try to install or update addons, I get the message: "The dependency on kodi.binary.global.main in version 1.1.0 could not be resolved."
Can I change that somewhere within Kodi or do you have to change something?

I've also tried the complete image from March and with the system files from April (SD boot is not working on my XU4 - I don't know why...)

Cheers,
Richy

EDIT: It's not for all addons. I have problems to update InputStream Adaptive and Sidplay Audio Decoder (no really need for that, but there's allways the error message after booting the machine). My real Problem is that I'm not able to install any pvr addons. In fact I need at least Enigma2 Client and Tvheadend HTSP Client.

Wondermusic
Posts: 19
Joined: Tue Nov 05, 2019 7:47 pm
languages_spoken: German, English
ODROIDs: XU4
Has thanked: 8 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by Wondermusic »

Hi escalade,

tried your new image from GoogleDrive, you uploaded last friday, but I can't get this one working.
Flashed on a SD Card is not working (due to my mentioned problem above - tried it with different Cards and Micro SD- Adapters for flashing with Etcher).
Doing the same thing with this image, flashed the new one with use of the boot files from March, is also not working anymore.

Cheers,
Richy

EDIT: The error message as follows (I used the UUID of the original and the UUID of my emmc)

*** Error in mount_storage: mount_common: Could not mount UUID=e139ce78-9841-40fe-8823-96a304a09859 ***
### Starting debugging shell for boot step: mount_storage--- type exit to quit ###

ring-0
Posts: 26
Joined: Fri Jan 03, 2020 4:59 am
languages_spoken: english
ODROIDs: XU4 and N2
Has thanked: 0
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by ring-0 »

CEC is dead for me with the latest image :(

Code: Select all

# cec-client
No device type given. Using 'recording device'
CEC Parser created - libCEC version 4.0.4
no serial port given. trying autodetect:
 path:     /dev/cec0
 com port: Linux

opening a connection to the CEC adapter...
DEBUG:   [              39]     Broadcast (F): osd name set to 'Broadcast'
DEBUG:   [              39]     CLinuxCECAdapterCommunication::Open - m_fd=3 bStartListening=1
ERROR:   [              39]     CLinuxCECAdapterCommunication::Open - ioctl CEC_S_MODE failed - errno=16
DEBUG:   [              39]     CLinuxCECAdapterCommunication::Close - m_fd=3
ERROR:   [              39]     could not open a connection (try 1)
DEBUG:   [              39]     CLinuxCECAdapterCommunication::Close - m_fd=-1
DEBUG:   [            1039]     CLinuxCECAdapterCommunication::Open - m_fd=3 bStartListening=1


 # cec-client
No device type given. Using 'recording device'
CEC Parser created - libCEC version 4.0.4
no serial port given. trying autodetect:
 path:     /dev/cec0
 com port: Linux

opening a connection to the CEC adapter...
DEBUG:   [              88]     Broadcast (F): osd name set to 'Broadcast'
DEBUG:   [              88]     CLinuxCECAdapterCommunication::Open - m_fd=3 bStartListening=1
DEBUG:   [              88]     CLinuxCECAdapterCommunication::Open - ioctl CEC_ADAP_G_PHYS_ADDR - addr=3000
DEBUG:   [              88]     CLinuxCECAdapterCommunication::Open - ioctl CEC_ADAP_S_LOG_ADDRS - log_addr_mask=0000 num_log_addrs=0
DEBUG:   [              88]     CLinuxCECAdapterCommunication::Open - ioctl CEC_ADAP_S_LOG_ADDRS - log_addr_mask=8000 num_log_addrs=1
NOTICE:  [              89]     connection opened
DEBUG:   [              89]     << Broadcast (F) -> TV (0): POLL
TRAFFIC: [              89]     << f0
DEBUG:   [              89]     processor thread started
DEBUG:   [              89]     CLinuxCECAdapterCommunication::Process - CEC_DQEVENT - CEC_EVENT_STATE_CHANGE - log_addr_mask=8000 phys_addr=3000

Kodi won't recognize it, the CEC service/addon is enabled.

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

Fresh new images uploaded (eMMC image updated too) for you guys. Noteable changes are the addition of pulseaudio-modules-bt which adds Sony LDAC, aptX, aptX HD, AAC codecs (A2DP Audio) support to PulseAudio. Everything libretro updated as well.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

Wondermusic
Posts: 19
Joined: Tue Nov 05, 2019 7:47 pm
languages_spoken: German, English
ODROIDs: XU4
Has thanked: 8 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by Wondermusic »

Same again... After flashing eMMC or SD (this time booting worked), the device shows directly "Retroelec is booting" and after that the error message like above appears. :|

Cheers,
Richy

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

I've uploaded a new build with a possible fix, would you mind testing it? I don't have a spare SD card here atm.
Maintainer of RetroELEC (XU4 / OGA / x86_64)

Wondermusic
Posts: 19
Joined: Tue Nov 05, 2019 7:47 pm
languages_spoken: German, English
ODROIDs: XU4
Has thanked: 8 times
Been thanked: 1 time
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by Wondermusic »

SD no boot at all - like before.
eMMC again the error message. Device is directly booting without resizing partitions.

XslushedX
Posts: 2
Joined: Thu Apr 09, 2020 7:07 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 1 time
Been thanked: 0
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by XslushedX »

No luck here too. It starts to boot from SD card but then the error message comes :

*** Error in mount_storage: mount_common: Could not mount UUID=e139ce78-984-40fe-8823-96a304a09859 ***
### Starting debugging shell for boot step: mount_storage--- type exit to quit ###

escalade
Posts: 212
Joined: Thu Mar 14, 2019 8:34 pm
languages_spoken: english and norwegian
Has thanked: 7 times
Been thanked: 68 times
Contact:

Re: RetroELEC Emulationstation/RetroArch/Kodi image for XU4

Post by escalade »

Ok, I found the error. I forgot I enabled F2FS compression for my NUC, and it's not supported until kernel 5.6. Fixed images uploaded :)
These users thanked the author escalade for the post:
odroid (Sun Apr 26, 2020 9:06 am)
Maintainer of RetroELEC (XU4 / OGA / x86_64)

Post Reply

Return to “Other OS”

Who is online

Users browsing this forum: No registered users and 1 guest