ps4 controller pairs but doesn't work

Post Reply
Sav
Posts: 110
Joined: Mon Sep 02, 2019 2:33 am
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 26 times
Been thanked: 8 times
Contact:

ps4 controller pairs but doesn't work

Unread post by Sav » Sun Nov 24, 2019 3:15 am

Hi,
I paired my ps4 in HardKernel latest Android pie 64bit and it was seen as wireless controller.
I tried some games but it doesn't work.
I tried to connect it by cable, but with the same results.

In lineage 32 bit version it works

User avatar
voodik
Posts: 1645
Joined: Sat Dec 07, 2013 2:36 am
languages_spoken: english,russian
Has thanked: 12 times
Been thanked: 109 times
Contact:

Re: ps4 controller pairs but doesn't work

Unread post by voodik » Sun Nov 24, 2019 7:10 am

64-bit lineage work in progress)
These users thanked the author voodik for the post (total 2):
Sav (Sun Nov 24, 2019 4:58 pm) • rooted (Mon Nov 25, 2019 3:56 pm)
Buy me a beer ;)
https://www.paypal.me/voodikjan
BTC: 377wXjEr3QsDDzRqfMco3a41wicrsv3Sfs
--------------------------------------------------------
dump logs
(dmesg; logcat -d; lsusb) | curl -F 'f:1=<-' ix.io

Slaminger
Posts: 53
Joined: Tue Jul 16, 2019 12:30 am
languages_spoken: english
ODROIDs: Xu4, n2, c2, odroid go advance
Location: Canada
Has thanked: 7 times
Been thanked: 5 times
Contact:

Re: ps4 controller pairs but doesn't work

Unread post by Slaminger » Sun Dec 08, 2019 11:29 pm

Compile Android yourself from source and go into the kernel, check out the drivers used, it may be missing something. On xu4 I had to manually add files in for it to detect some 3rd party controllers and get Xbox one working properly. It might simply be lacking something it needs. Or it might be being picky about the Bluetooth stack used. On Linux bluez is the best for controller support. You should be able to alter or change up the Bluetooth stack a bit as well.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 0 guests