Time-controlled wake-up fills log files

Post Reply
Steffen
Posts: 7
Joined: Tue Nov 19, 2019 1:15 am
languages_spoken: english,german
ODROIDs: Odroid H2
Has thanked: 1 time
Been thanked: 0
Contact:

Time-controlled wake-up fills log files

Unread post by Steffen » Tue Nov 19, 2019 1:30 am

Hello community,
if I want my Odroid H2 to wake up automatically via rtcwake, the system log will be flooded with these messages:

Code: Select all

Nov 18 17:07:34 homeserver kernel: hpet1: lost 7161 rtc interrupts
Nov 18 17:07:35 homeserver kernel: hpet1: lost 7161 rtc interrupts
Nov 18 17:07:36 homeserver kernel: hpet1: lost 7160 rtc interrupts
Nov 18 17:07:37 homeserver kernel: hpet1: lost 7161 rtc interrupts
Nov 18 17:07:38 homeserver kernel: hpet1: lost 7161 rtc interrupts
Nov 18 17:07:39 homeserver kernel: hpet1: lost 7161 rtc interrupts
Nov 18 17:07:40 homeserver kernel: hpet1: lost 7161 rtc interrupts
Nov 18 17:07:40 homeserver kernel: hpet1: lost 7160 rtc interrupts
Nov 18 17:07:41 homeserver kernel: hpet1: lost 7161 rtc interrupts
Why is that? Waking up still works. This is my wakeup command:

Code: Select all

rtcwake -a --date 17:10
My System is using Proxmox VE 6.

Thanks for the help.

User avatar
odroid
Site Admin
Posts: 32704
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 213 times
Been thanked: 367 times
Contact:

Re: Time-controlled wake-up fills log files

Unread post by odroid » Tue Nov 19, 2019 9:49 am

I've tried rtcwake -a -m mem -s 10on Ubuntu 19.10 & Kernel 5.3.0-23.
Suspend to RAM and wake up worked well.
But I also had the same thing in dmesg output. I have no idea why the annoying message appears. :(

Code: Select all

[247626.063806] hpet: Lost 7161 RTC interrupts
[247626.961470] hpet: Lost 7161 RTC interrupts
[247627.858653] hpet: Lost 7161 RTC interrupts
[247628.756716] hpet: Lost 7161 RTC interrupts
[247629.656657] hpet: Lost 7160 RTC interrupts
[247630.538176] hpet: Lost 7160 RTC interrupts
[247631.436683] hpet: Lost 7160 RTC interrupts
[247632.336953] hpet: Lost 7161 RTC interrupts
[247633.238825] hpet: Lost 7161 RTC interrupts
[247634.126992] hpet: Lost 7160 RTC interrupts
[247635.016727] hpet: Lost 7161 RTC interrupts
[247635.910316] hpet: Lost 7161 RTC interrupts
[247636.808056] hpet: Lost 7161 RTC interrupts
[247637.702490] hpet: Lost 7161 RTC interrupts
[247638.582113] hpet: Lost 7161 RTC interrupts
[247639.461332] hpet: Lost 7160 RTC interrupts
[247640.361103] hpet: Lost 7161 RTC interrupts
[247641.261032] hpet: Lost 7161 RTC interrupts
[247642.151197] hpet: Lost 7160 RTC interrupts
[247643.047452] hpet: Lost 7160 RTC interrupts
[247643.944865] hpet: Lost 7160 RTC interrupts
[247644.838779] hpet: Lost 7161 RTC interrupts
[247645.729292] hpet: Lost 7161 RTC interrupts
[247646.625622] hpet: Lost 7161 RTC interrupts
[247647.499628] hpet: Lost 7160 RTC interrupts
[247648.386216] hpet: Lost 7161 RTC interrupts
[247650.008382] hpet: Lost 7161 RTC interrupts
[247650.911571] hpet: Lost 7161 RTC interrupts
[247651.809099] hpet: Lost 7161 RTC interrupts
[247652.710501] hpet: Lost 7160 RTC interrupts
[247653.573375] hpet: Lost 7161 RTC interrupts
[247654.434152] hpet: Lost 7161 RTC interrupts
[247655.337734] hpet: Lost 7161 RTC interrupts
[247656.247292] hpet: Lost 7161 RTC interrupts
[247657.148671] hpet: Lost 7160 RTC interrupts
[247658.043446] hpet: Lost 7161 RTC interrupts
[247658.937229] hpet: Lost 7161 RTC interrupts
[247659.829813] hpet: Lost 7161 RTC interrupts
[247660.727014] hpet: Lost 7161 RTC interrupts
[247661.593201] hpet: Lost 7161 RTC interrupts
[247662.524601] hpet: Lost 7161 RTC interrupts
[247663.484997] hpet: Lost 7161 RTC interrupts
[247664.443769] hpet: Lost 7161 RTC interrupts
[247665.349644] hpet: Lost 7161 RTC interrupts
[247666.251970] hpet: Lost 7161 RTC interrupts
[247667.154445] hpet: Lost 7160 RTC interrupts
[247668.054735] hpet: Lost 7161 RTC interrupts
[247668.954099] hpet: Lost 7161 RTC interrupts
[247669.915351] hpet: Lost 7161 RTC interrupts
[247670.847500] hpet: Lost 7161 RTC interrupts
[247671.794653] hpet: Lost 7160 RTC interrupts
[247672.728248] hpet: Lost 7161 RTC interrupts
[247673.646066] hpet: Lost 7161 RTC interrupts
[247674.518463] hpet: Lost 7161 RTC interrupts
[247675.431158] hpet: Lost 7161 RTC interrupts
[247676.317875] hpet: Lost 7161 RTC interrupts
[247677.205019] hpet: Lost 7161 RTC interrupts
[247678.094246] hpet: Lost 7161 RTC interrupts
[247678.984679] hpet: Lost 7160 RTC interrupts
These users thanked the author odroid for the post:
Steffen (Wed Nov 20, 2019 6:51 am)

Steffen
Posts: 7
Joined: Tue Nov 19, 2019 1:15 am
languages_spoken: english,german
ODROIDs: Odroid H2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Time-controlled wake-up fills log files

Unread post by Steffen » Wed Nov 20, 2019 4:35 am

Okay it seem not only me does have these messages in log and have also Ubuntu have these problems. Then it seems to be a Kernel, bios or hardware defect?

fvolk
Posts: 300
Joined: Sun Jun 05, 2016 11:04 pm
languages_spoken: english
ODROIDs: C2, HC1, H2
Has thanked: 0
Been thanked: 11 times
Contact:

Re: Time-controlled wake-up fills log files

Unread post by fvolk » Wed Nov 20, 2019 5:38 am

odroid wrote: I've tried rtcwake -a -m mem -s 10on Ubuntu 19.10 & Kernel 5.3.0-23.
Suspend to RAM and wake up worked well.
ran it... works... does not reproduce problem

Code: Select all

$ grep -i hpet /usr/src/linux-5.2.9/.config
CONFIG_HPET_TIMER=y
CONFIG_HPET_EMULATE_RTC=y
CONFIG_HPET=y
CONFIG_HPET_MMAP=y
CONFIG_HPET_MMAP_DEFAULT=y
$ grep ^NAME /etc/os-release
NAME=Gentoo
...maybe it's an Ubuntu issue?

Steffen
Posts: 7
Joined: Tue Nov 19, 2019 1:15 am
languages_spoken: english,german
ODROIDs: Odroid H2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Time-controlled wake-up fills log files

Unread post by Steffen » Wed Nov 20, 2019 6:58 am

@fvolk can you tell me please how i can check my HPET configuration in the kernel?

User avatar
odroid
Site Admin
Posts: 32704
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 213 times
Been thanked: 367 times
Contact:

Re: Time-controlled wake-up fills log files

Unread post by odroid » Wed Nov 20, 2019 9:41 am

@fvolk,

My Ubuntu system shows the same Kernel config.

Code: Select all

odroid@h2:~$ grep -i hpet /boot/config-$(uname -r)
CONFIG_HPET_TIMER=y
CONFIG_HPET_EMULATE_RTC=y
CONFIG_HPET=y
CONFIG_HPET_MMAP=y
CONFIG_HPET_MMAP_DEFAULT=y
odroid@h2:~$ grep ^NAME /etc/os-release
NAME="Ubuntu"

Steffen
Posts: 7
Joined: Tue Nov 19, 2019 1:15 am
languages_spoken: english,german
ODROIDs: Odroid H2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Time-controlled wake-up fills log files

Unread post by Steffen » Thu Nov 21, 2019 12:45 am

I have the same configuration.

Code: Select all

grep -i hpet /boot/config-$(uname -r)
CONFIG_HPET_TIMER=y
CONFIG_HPET_EMULATE_RTC=y
CONFIG_HPET=y
CONFIG_HPET_MMAP=y
CONFIG_HPET_MMAP_DEFAULT=y
grep ^NAME /etc/os-release
NAME="Debian GNU/Linux"

fvolk
Posts: 300
Joined: Sun Jun 05, 2016 11:04 pm
languages_spoken: english
ODROIDs: C2, HC1, H2
Has thanked: 0
Been thanked: 11 times
Contact:

Re: Time-controlled wake-up fills log files

Unread post by fvolk » Thu Nov 21, 2019 3:00 am

found a USB stick with an older Kubuntu 18.10 live image, Kernel 4.18.0
tried.... also works fine, no messages in syslog

Steffen
Posts: 7
Joined: Tue Nov 19, 2019 1:15 am
languages_spoken: english,german
ODROIDs: Odroid H2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Time-controlled wake-up fills log files

Unread post by Steffen » Thu Nov 21, 2019 3:30 am

That is curious. I suggest it doesn't is a problem with the OS. Is mine and odroid's "Odroid H2" defect or different? Is there any hidden Bios setting for the hwclock? I cant find any.

Steffen
Posts: 7
Joined: Tue Nov 19, 2019 1:15 am
languages_spoken: english,german
ODROIDs: Odroid H2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Time-controlled wake-up fills log files

Unread post by Steffen » Thu Nov 21, 2019 5:05 am

Well i found a solution. These log messages cant 't happen when the Odroid H2 isn't on, so i put simply this command in my crontab:

Code: Select all

30 0 * * * * sudo rtcwake -a -m mem -t $(date -d today -d '16:00' +%s)
H2 goes sleep at 0:30, wakes up at same day 16:00.

fvolk
Posts: 300
Joined: Sun Jun 05, 2016 11:04 pm
languages_spoken: english
ODROIDs: C2, HC1, H2
Has thanked: 0
Been thanked: 11 times
Contact:

Re: Time-controlled wake-up fills log files

Unread post by fvolk » Thu Nov 21, 2019 5:08 am

Got a shiny new Ubuntu 19.10 iso, flashed USB stick.
Boot from USB stick into live system... still does not reproduce?
hmm... what are you doing differently?
Note also this is another H2 hardware.
Attachments
rtcwake.png
rtcwake.png (160.94 KiB) Viewed 238 times

Steffen
Posts: 7
Joined: Tue Nov 19, 2019 1:15 am
languages_spoken: english,german
ODROIDs: Odroid H2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Time-controlled wake-up fills log files

Unread post by Steffen » Thu Nov 21, 2019 5:59 am

@fvolk These messages only appear when a rtcwake time is set and the system is awake.
try this:

rtcwake -a --date 17:10

but anyway i found a solution for this problem see above.

fvolk
Posts: 300
Joined: Sun Jun 05, 2016 11:04 pm
languages_spoken: english
ODROIDs: C2, HC1, H2
Has thanked: 0
Been thanked: 11 times
Contact:

Re: Time-controlled wake-up fills log files

Unread post by fvolk » Thu Nov 21, 2019 6:50 am

ah... now I can reproduce it under all variants.
I followed command from odroid and this alone does not trigger it, but setting a specific time does.
Sorry for the confusion :-)

User avatar
odroid
Site Admin
Posts: 32704
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 213 times
Been thanked: 367 times
Contact:

Re: Time-controlled wake-up fills log files

Unread post by odroid » Thu Nov 21, 2019 9:30 am

Steffen wrote:
Thu Nov 21, 2019 5:05 am
Well i found a solution. These log messages cant 't happen when the Odroid H2 isn't on, so i put simply this command in my crontab:

Code: Select all

30 0 * * * * sudo rtcwake -a -m mem -t $(date -d today -d '16:00' +%s)
H2 goes sleep at 0:30, wakes up at same day 16:00.
Thank you for sharing the nice solution.

Post Reply

Return to “Other OS”

Who is online

Users browsing this forum: No registered users and 1 guest