[SOLVED] Odroid HC2 boot problems

Post Reply
justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

[SOLVED] Odroid HC2 boot problems

Unread post by justtim » Fri Oct 04, 2019 10:41 pm

Hi,

I am experiencing issues when my ODROID HC2 is restarted or shutdown and cold booted.

Behaviour: As soon as the power is connected, the red LED turns on, the green LED shortly after. The NIC amber light is also on and blinking. The blue LED blinks in very long, about 5 second sequences (5 seconds on, 5 seconds off), and the HC2 does not boot.
I than have to disconnect the power, reseat the HDD and connect the power again for a couple of times, until the blue LED starts blinking in a normal fashion of a few miliseconds off, few miliseconds on.

I already replaced the traditional HDD with an SSD, thinking the HDD might have been broken, but that didn't solve the issue. I also tried swapping the memory card but to no avail.

I am running OMV and there is nothing in the OMV logs at the time when the device fails to boot.

Looks like this is a hardware issue with the ODROID itself, possibly the SATA connector, or is there anything else you can think of?

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Sat Oct 05, 2019 10:21 am

Which power supply do you use?
It must be a stable 12V/2A.

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Sun Oct 13, 2019 7:44 pm

odroid wrote:
Sat Oct 05, 2019 10:21 am
Which power supply do you use?
It must be a stable 12V/2A.
Sorry for the late response, I wasn’t notified of your reply by email. Yes, I am using a 12v/2A power supply. Do you think this somehow isn’t stable enough?
I haven’t had any issues for a year or so before this started happening.
The problem is getting worse over the last few days, the same behavior now also occurs while the device is in use/online. The device suddenly goes offline and the blue LED starts blinking in very slow intervals instead of normal heartbeats.
I than have to reboot several times before I can get it back online.
With the SSD disconnected, the device boots without any issues.

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Mon Oct 14, 2019 9:59 am


justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Mon Oct 14, 2019 2:30 pm

odroid wrote:
Mon Oct 14, 2019 9:59 am
Do you use this official PSU?
https://www.hardkernel.com/shop/12v-2a- ... y-us-plug/
No, I use a different 12v-2a PSU.

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Mon Oct 14, 2019 3:17 pm

In that case, carefully measure the 12V power rail on the PCB when the system boots if you have DMM.
Image
There is "12V & GND" pads near the SATA connector.

How about if you don't connect the SATA storage device?
Is it booting well?

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Mon Oct 14, 2019 5:06 pm

odroid wrote:
Mon Oct 14, 2019 3:17 pm
In that case, carefully measure the 12V power rail on the PCB when the system boots if you have DMM.
Image
There is "12V & GND" pads near the SATA connector.
Thank you, I will give this a shot.
odroid wrote:
Mon Oct 14, 2019 3:17 pm
How about if you don't connect the SATA storage device?
Is it booting well?
Without the SATA device connected, the systems boots fine.

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Tue Oct 15, 2019 6:35 am

odroid wrote:
Mon Oct 14, 2019 3:17 pm
There is "12V & GND" pads near the SATA connector.
I was about to measure the voltage but discovered I don’t seem to have these measure pads, see below.
I did measure the voltage output directly on the adapter though, and it is a stable 12v, although that is without any load.
30FE3E67-0BF2-4547-9AC9-59F1C81B3DD2.jpeg
30FE3E67-0BF2-4547-9AC9-59F1C81B3DD2.jpeg (803.87 KiB) Viewed 763 times

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Tue Oct 15, 2019 10:14 am

Sorry... my picture was the proto-type sample.

Look at the below pictures.
Right side 3 pins are +12V and following 3 pins are GND(COM).
sata_power.jpeg
sata_power.jpeg (402.6 KiB) Viewed 743 times
Image
These users thanked the author odroid for the post:
justtim (Fri Oct 18, 2019 12:27 am)

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Tue Oct 15, 2019 4:49 pm

odroid wrote:
Tue Oct 15, 2019 10:14 am
Sorry... my picture was the proto-type sample.

Look at the below pictures.
Right side 3 pins are +12V and following 3 pins are GND(COM).
I measured the voltage going in the SATA port, it varies between 10.6 and 10.8. There are no voltage drops. Would that be correct?

User avatar
mad_ady
Posts: 6783
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 215 times
Been thanked: 164 times
Contact:

Re: Odroid HC2 boot problems

Unread post by mad_ady » Tue Oct 15, 2019 6:10 pm

Since a 2.5" ssd doesn't work as well, 5V sata output might be broken too. Can you measure that as well?
These users thanked the author mad_ady for the post:
justtim (Fri Oct 18, 2019 12:28 am)

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Tue Oct 15, 2019 6:13 pm

Yes, it is very worth to measure the +5VDC rails.
It must be stable at 4.8Volt at least in the booting process.

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Tue Oct 15, 2019 6:33 pm

mad_ady wrote:
Tue Oct 15, 2019 6:10 pm
5V sata output might be broken too.
Are you saying that the 12v sata output is broken since it is only delivering 10.6 - 10.8V? I will measure the 5V pins as well when I have a chance today.

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Tue Oct 15, 2019 6:58 pm

If your PSU is okay, the 12V rail must be near 12Volt (+/- 5%) in the booting process.
10.6V is too low.

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Tue Oct 15, 2019 8:11 pm

odroid wrote:
Tue Oct 15, 2019 6:58 pm
If your PSU is okay, the 12V rail must be near 12Volt (+/- 5%) in the booting process.
10.6V is too low.
So if I understand correctly, the PSU must be able to deliver peaks over 2A as it has to power both the board and the SATA connector, right?

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Wed Oct 16, 2019 4:41 am

odroid wrote:
Tue Oct 15, 2019 6:13 pm
Yes, it is very worth to measure the +5VDC rails.
It must be stable at 4.8Volt at least in the booting process.
I just measured the 5V pins and seeing really weird behaviour. Right after booting, the voltage is only 1.8V, but then it starts dropping all the way to almost 0, before it comes back at 1.8V.
When it goes back to 1.8V, the green light blinks shortly, and the process starts over again.
I measured the 12V pin as well to make sure I wasn't doing something wrong, which was still constant at 10.6V.

Regarding my other question, wouldn't I be better off buying a 12V 3A or 4A PSU since it needs to deliver power to both the board and the disk?

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Wed Oct 16, 2019 9:51 am

12V/2A PSU must be fine if the output quality is good.

Anyway, 1.8V output is really weird.
Can you take a picture to show us how did you measure the +5VDC rail?

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Thu Oct 17, 2019 3:52 am

I made a picture of how I measured as well as a short video displaying the behaviour.

Picture:
ODROID.jpeg
ODROID.jpeg (524.84 KiB) Viewed 607 times

Video:
https://youtu.be/FSvY-0P7GtM

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Thu Oct 17, 2019 1:33 pm

Thank you for the picture and video.
The measuring method looks fine.

What is the voltage on the DC plug?

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Thu Oct 17, 2019 2:15 pm

odroid wrote:
Thu Oct 17, 2019 1:33 pm
Thank you for the picture and video.
The measuring method looks fine.

What is the voltage on the DC plug?
The plug output directly on the plug is 12V without any load.

ruppi
Posts: 106
Joined: Fri Feb 22, 2013 11:13 pm
languages_spoken: korean
Location: South Korea
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Odroid HC2 boot problems

Unread post by ruppi » Thu Oct 17, 2019 2:26 pm

Hi justtim,

what is the voltage on the DC plug with load ?

If you are a normal adaptor, you will see a voltage drop near 12V with little or no voltage drop.
If a voltage drop of more than 0.2V is generated, it is believed that the current of the adapter is above the rated current, or that the adapter is faulty.

5V and 12V of the SATA connector are equipped with SATA connector SSD/HDD and the USB related Kernel Module must probe when the kernel boots to output 5V and 12V.

-BR-
Ruppi
These users thanked the author ruppi for the post:
justtim (Fri Oct 18, 2019 12:28 am)

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Thu Oct 17, 2019 2:46 pm

ruppi wrote:
Thu Oct 17, 2019 2:26 pm
Hi justtim,

what is the voltage on the DC plug with load ?
I don’t know where I should measure with load? In the ODROID, I can only measure the SATA rails, correct?

ruppi
Posts: 106
Joined: Fri Feb 22, 2013 11:13 pm
languages_spoken: korean
Location: South Korea
Has thanked: 0
Been thanked: 5 times
Contact:

Re: Odroid HC2 boot problems

Unread post by ruppi » Thu Oct 17, 2019 4:02 pm

Hi justtim,

You must measure the input end of the adapter.
Please measure the voltage at the arrow shown below.
HC2_12V.png
HC2_12V.png (1.83 MiB) Viewed 557 times

justtim
Posts: 15
Joined: Sun Jan 06, 2019 9:13 pm
languages_spoken: english
ODROIDs: Odroid HC2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Odroid HC2 boot problems

Unread post by justtim » Fri Oct 18, 2019 12:26 am

Hi all, problem solved! I brought the device to work, and we connected it to a professional variable power supply set to 12V. The device booted instantly and without any issues, and we monitored it pulled no more than 0.8A during peak boot phase.
So the problem is clear, it was caused by a failing adapter. I have already ordered a new one (suspecting this, thanks to your suggestions), and it will hopefully be delivered soon.

Thank you all for your help!

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: Odroid HC2 boot problems

Unread post by odroid » Fri Oct 18, 2019 9:20 am

Glad to hear that. :D
These users thanked the author odroid for the post:
talltxn88030 (Fri Oct 18, 2019 2:17 pm)

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 2 guests