Slow Boot Times and Slow/Stuttery Aplications

Post Reply
jimbo721
Posts: 2
Joined: Thu Oct 03, 2019 7:41 pm
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Slow Boot Times and Slow/Stuttery Aplications

Unread post by jimbo721 » Thu Oct 03, 2019 8:09 pm

I recently bought an XU4. I was looking to use it for arcade emulation. I downloaded an image file from arcade punks and used Etcher to flash it. On first boot up there was a big pause and nothing was happening and then all of a sudden I got the intro animations for the emulator, but then it stopped again and the screen just froze.

I thought that maybe there was a corruption on the SD card so I formatted the card and flashed the image on again. This time I got nothing happening on the screen (The blue light was flashing so I assume it was reading the SD card). After 10 minutes with nothing happening I decided to restart the Odroid but again got nothing but a flashing blue light.

I thought maybe there was a problem with the image file so I downloaded a smaller image and tried again. Now I was getting it to boot up but it was taking 2-3 minutes to get to the emulator dashboard (intro animations still stuttering and freezing)
The emulator would freeze up mostly on the menus and occasionally in game.

So i thought maybe I should try a different SD card. Just the same was happening as with the other card.

Then I decided to download Ubuntu Mate and flashed it to both cards. It most of the time loaded from both cards but took over 2 minutes to get to the log in screen. Once loaded there was no problem navigating with the mouse but windows were very slow in opening.

I have done speed tests for the two cards I am using:-

1)SanDisk Extreme Pro 400GB read speed 16.975MB/S
2) SanDisk Ultra 256GB class 10 A1 read speed 17.583MB/S

I am thinking there is a problem with the board or the powersupply (purchased with the Odroid)

Can anyone shine a light on this please, thanks James

User avatar
meveric
Posts: 10541
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2, H2 (J4105)
Has thanked: 17 times
Been thanked: 154 times
Contact:

Re: Slow Boot Times and Slow/Stuttery Aplications

Unread post by meveric » Fri Oct 04, 2019 12:42 am

The board were originally designed with 64GB max for SD card, I'm not sure if 400GB or 256GB is really supported.
You should try a more common SD card and compare.
Your SD cards are rather slow anyway so it could also be that they are somewhat damaged.

Poweradapter could be an issues.. it's not unheard of but unlikely with a new device. Still if you have a spare it's something you can try.
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

jimbo721
Posts: 2
Joined: Thu Oct 03, 2019 7:41 pm
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Slow Boot Times and Slow/Stuttery Aplications

Unread post by jimbo721 » Fri Oct 04, 2019 1:39 am

Thanks Meveric, I think I have worked out the issue. Both SD cards I bought on ebay and are both fakes. I had another card (16gb) which I did a speed test on and I was reaching 40MB/S. This card works perfectly. I have wasted two days due to scam artists on ebay :( I will only buy SD cards from bricks and mortar shops from now on.

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 3 guests