Is The RA broken or what?

Post Reply
samuraiblur
Posts: 2
Joined: Fri Sep 27, 2019 8:46 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 1 time
Been thanked: 0
Contact:

Is The RA broken or what?

Unread post by samuraiblur » Fri Sep 27, 2019 9:08 am

Hello, all. I posted this question on Reddit a little while ago and received no answers. I've run into a very weird issue and am searching for the fix. Unfortunately I've scoured the internet for a couple of days now and found nothing so far.Any help is appreciated.
I'm new to Odroid (just got a XU4). Been using retropie/emulationstation with Raspberry Pi. I got my hands on a ES image to use on my Odroid (XU4-TheRA-Base-Pub-v3.1.2) and I am having a very funny thing happen that I've never experienced with ES. I loaded my N64 library and I can only play each game one time. I back out and try to load it again and it fails. I've deleted the .srm files to see if that's what's doing it and nothing. I can play as long as I want the first time, but once I back out it doesn't ever let me load that game again.. Also, I have different versions of some ROMs and once I load one of them and play it, then back out I can't open it or any other versions of it. I'm going down my list right now testing all of them and every single ROM in the N64 folder is doing this. Only does this on N64 games (I've only tested N64 and Dreamcast so far, but DC is not having this issue). The same ROMs do not do this in RetroPie for the RP3b+ I have. Do I have a bad image or did I possibly do something in configuration that I shouldn't have? Anyone else ever experience this before?


Edit: I have cleared out the entire library, reset, and reloaded the ROMs and the problem still persists. If the game is ever played on the system one time it seems it is rejected no matter what after that. Scratching my head here. haha
I got this image from theretroarena.com and it seems to be the most up to date base image 3.1.2.7
I have tried reloading the image fresh and checked for this issue before I configured anything at all and the problem still exists. Can anyone provide some incite as what is going on here? I'd really like to be able to use this OS, especially since it has support to the OGST N64 style case screen, but it's starting to look grim at this point.. Thanks in advance.

User avatar
odroid
Site Admin
Posts: 32360
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: Is The RA broken or what?

Unread post by odroid » Fri Sep 27, 2019 9:20 am

Post your questions on their DISCORD channel to have an answer quickly since very few people are using it in this forum.
https://theretroarena.com/
These users thanked the author odroid for the post:
samuraiblur (Fri Sep 27, 2019 9:33 am)

samuraiblur
Posts: 2
Joined: Fri Sep 27, 2019 8:46 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 1 time
Been thanked: 0
Contact:

Re: Is The RA broken or what?

Unread post by samuraiblur » Fri Sep 27, 2019 11:53 am

Update for any who may experience this issue with TheRA OS. The issue was in the cache of mupen64plus. The development team gave me this suggestion.

- Clear the shaders cache in mupen64plus

- Go into the retroarch-core-options.cfg file and find mupen64plus-EnableShadersStorage and set it to False


To do this, open your XU4 folders on the network (same way you add ROMs over network). The file path should be \\(your Odroid IP address)\configs\all

Right click on the file retroarch-core-options.cfg and choose "Open with." Open it with notepad. Scroll down to the line that says "mupen64plus-EnableShadersStorage." It should say "True." Delete that and change it to "False." Save and exit. That was the fix for me.

User avatar
odroid
Site Admin
Posts: 32360
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: Is The RA broken or what?

Unread post by odroid » Fri Sep 27, 2019 3:48 pm

Thank you sharing the useful solutions.

Post Reply

Return to “Other OS”

Who is online

Users browsing this forum: No registered users and 5 guests