[SOLVED] N2 Ethernet doesn't work

Post Reply
drgary
Posts: 4
Joined: Wed Sep 25, 2019 2:21 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

[SOLVED] N2 Ethernet doesn't work

Unread post by drgary » Wed Sep 25, 2019 4:31 am

I am assembling a small cluster with 8 N2 SBCs and all of them are working except one. The amber light on the Ethernet connector flashes continuously. The red power LED is illuminated and the blue LED flashes so I think the power is ok and the system seems to have booted successfully. Last week I was able to configure the OS on that computer but since then I've lost connectivity.

I can't find the meaning of the flashing Ethernet LED. Does anyone know what that means?

Thanks in advance.

User avatar
odroid
Site Admin
Posts: 32508
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 181 times
Been thanked: 349 times
Contact:

Re: N2 Ethernet doesn't work

Unread post by odroid » Wed Sep 25, 2019 10:19 am

Green LED: Flashing by data traffics at 100Mbps connection
Amber LED: Flashing by data traffics at 1000Mbps connection
https://wiki.odroid.com/odroid-n2/hardw ... ifications

I think you might need a USB-UART cable to monitor the system status.

drgary
Posts: 4
Joined: Wed Sep 25, 2019 2:21 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: N2 Ethernet doesn't work

Unread post by drgary » Wed Sep 25, 2019 9:31 pm

Thank you for the advice. The link you provide, and the printed material that came with the N2, does not mention regular blinking of the Ethernet LED. In fact, I have 7 other N2 SBCs in my cluster and none of them are blinking, all are amber and solidly lit. This is the only one behaving like this and the only one not accessible through my network.

User avatar
tobetter
Posts: 4117
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 47 times
Been thanked: 211 times
Contact:

Re: N2 Ethernet doesn't work

Unread post by tobetter » Wed Sep 25, 2019 9:50 pm

drgary wrote:
Wed Sep 25, 2019 9:31 pm
Thank you for the advice. The link you provide, and the printed material that came with the N2, does not mention regular blinking of the Ethernet LED. In fact, I have 7 other N2 SBCs in my cluster and none of them are blinking, all are amber and solidly lit. This is the only one behaving like this and the only one not accessible through my network.
Can you run the command ifconfig eth0 to see if available?

drgary
Posts: 4
Joined: Wed Sep 25, 2019 2:21 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: N2 Ethernet doesn't work

Unread post by drgary » Thu Sep 26, 2019 12:08 am

The cluster is currently in our data center but when I get the chance I'll go over there and connect a monitor, keyboard and mouse and do some sleuthing. It's still odd that it worked and suddenly stopped.

drgary
Posts: 4
Joined: Wed Sep 25, 2019 2:21 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: N2 Ethernet doesn't work

Unread post by drgary » Thu Sep 26, 2019 12:48 am

I found the solution. I connected the machine to a monitor and saw that it wasn't booting into the OS. After a bit of looking around I noticed that I had inadvertently moved the slide switch that selects the boot medium to the micro SD position. Once I fixed that everything is ok again. This taught me a valuable lesson, check out the simple stuff first.

User avatar
mad_ady
Posts: 6783
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 215 times
Been thanked: 164 times
Contact:

Re: N2 Ethernet doesn't work

Unread post by mad_ady » Thu Sep 26, 2019 3:45 am

Update the spi flash to the latest version and petitboot will autoboot the os even if the switch is in the spi position
These users thanked the author mad_ady for the post (total 2):
xabolcs (Thu Sep 26, 2019 3:50 am) • rooted (Sun Sep 29, 2019 7:34 pm)

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests