new N2 doesn't work

Post Reply
aaabaaab
Posts: 21
Joined: Mon Oct 22, 2018 5:48 pm
languages_spoken: english
ODROIDs: XU4, XU4Q
Has thanked: 0
Been thanked: 0
Contact:

new N2 doesn't work

Unread post by aaabaaab » Sat Sep 21, 2019 4:05 am

Hi,

I bought 2 Odroid N2. On one I've installed Android without any difficulty.

Unfortunately the second one seems to be dead: I've inserted the microSD with the Android image but the screen remains black. Red light is on and the blue one is blinking but nothing happens even after 15-20 minutes...

I've tried also an Ubuntu image but no luck.

Any ideas ? :roll:

elatllat
Posts: 1528
Joined: Tue Sep 01, 2015 8:54 am
languages_spoken: english
ODROIDs: XU4, N1, N2
Has thanked: 21 times
Been thanked: 53 times
Contact:

Re: new N2 doesn't work

Unread post by elatllat » Sat Sep 21, 2019 7:09 am

AFAIK Blue blinking light generally means it has booted, do you have a uart?

aaabaaab
Posts: 21
Joined: Mon Oct 22, 2018 5:48 pm
languages_spoken: english
ODROIDs: XU4, XU4Q
Has thanked: 0
Been thanked: 0
Contact:

Re: new N2 doesn't work

Unread post by aaabaaab » Sat Sep 21, 2019 2:43 pm

No, I don't

User avatar
tobetter
Posts: 4038
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 43 times
Been thanked: 189 times
Contact:

Re: new N2 doesn't work

Unread post by tobetter » Sat Sep 21, 2019 2:47 pm

The problem is the board does not show anything to your display? Can you do ssh to Ubuntu image? Or can you try to boot from SPI flash memory?

User avatar
mad_ady
Posts: 6679
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 194 times
Been thanked: 148 times
Contact:

Re: new N2 doesn't work

Unread post by mad_ady » Sat Sep 21, 2019 3:12 pm

What kind of display/resolution do you have?

aaabaaab
Posts: 21
Joined: Mon Oct 22, 2018 5:48 pm
languages_spoken: english
ODROIDs: XU4, XU4Q
Has thanked: 0
Been thanked: 0
Contact:

Re: new N2 doesn't work

Unread post by aaabaaab » Sat Sep 21, 2019 4:00 pm

Indeed, the board doesn't show anything. The screen is black and then it says there is no signal and goes in standby.

I've tried both with Android and Ubuntu images.

How can I boot from SPI flash memory ?

User avatar
mad_ady
Posts: 6679
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 194 times
Been thanked: 148 times
Contact:

Re: new N2 doesn't work

Unread post by mad_ady » Sat Sep 21, 2019 7:43 pm

Use a 1080p screen and flip the boot switch to spi. See if you get a screen displayed.

aaabaaab
Posts: 21
Joined: Mon Oct 22, 2018 5:48 pm
languages_spoken: english
ODROIDs: XU4, XU4Q
Has thanked: 0
Been thanked: 0
Contact:

Re: new N2 doesn't work

Unread post by aaabaaab » Sun Sep 22, 2019 1:54 am

I've tried but got exactly the same: No signal message...

User avatar
mad_ady
Posts: 6679
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 194 times
Been thanked: 148 times
Contact:

Re: new N2 doesn't work

Unread post by mad_ady » Sun Sep 22, 2019 2:17 am

Something may be wrong with video output then. Have you tested the same display with the other N2?

aaabaaab
Posts: 21
Joined: Mon Oct 22, 2018 5:48 pm
languages_spoken: english
ODROIDs: XU4, XU4Q
Has thanked: 0
Been thanked: 0
Contact:

Re: new N2 doesn't work

Unread post by aaabaaab » Sun Sep 22, 2019 2:32 am

Yes. The second N2 I've got works perfectly with the same display.

User avatar
odroid
Site Admin
Posts: 32360
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: new N2 doesn't work

Unread post by odroid » Mon Sep 23, 2019 8:33 am

I think one you for N2 boards seemed to be damaged unknown electrical shock.

Please contact "odroid at hardkernel dot com" with a link of this post.
They will help your RMA process if you purchased the board from our web-store directly.
Otherwise, contact your local distributor/reseller.
Sorry for the inconvenience caused.

dsystems
Posts: 3
Joined: Tue Sep 24, 2019 9:49 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: new N2 doesn't work

Unread post by dsystems » Tue Sep 24, 2019 9:58 am

Hello, I just received my new N2, CoreElec special edition today. I have a boot problem too but mine will not go past the Petiboot screen. The CoreElec SD is firmly in place and the switch is on the SD position. I also tried another MicroSD with the Ubuntu Mate image and get the same issue. I'm sure I am forgetting a setting somewhere. Can you please help?

User avatar
tobetter
Posts: 4038
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 43 times
Been thanked: 189 times
Contact:

Re: new N2 doesn't work

Unread post by tobetter » Tue Sep 24, 2019 10:37 am

dsystems wrote:
Tue Sep 24, 2019 9:58 am
Hello, I just received my new N2, CoreElec special edition today. I have a boot problem too but mine will not go past the Petiboot screen. The CoreElec SD is firmly in place and the switch is on the SD position. I also tried another MicroSD with the Ubuntu Mate image and get the same issue. I'm sure I am forgetting a setting somewhere. Can you please help?
Please do create your own thread for your issue next time.

Please download the update image from the link and copy to COREELECT partition of your SD card as spiboot.img.
https://wiki.odroid.com/odroid-n2/os_im ... ev20190705

Before power cycle, place the boot select switch to SPI and attach your SD card to the slot, Petitboot in SPI will start to update and it will give you CoreELEC boot entry on next boot. If you have further question about Petitboot, please visit the link.
viewtopic.php?f=182&t=33873
These users thanked the author tobetter for the post:
dsystems (Tue Sep 24, 2019 11:13 am)

dsystems
Posts: 3
Joined: Tue Sep 24, 2019 9:49 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: new N2 doesn't work

Unread post by dsystems » Tue Sep 24, 2019 10:52 am

OK, thank you. I have Dev.20190416 so should I use 20190417 ?

dsystems
Posts: 3
Joined: Tue Sep 24, 2019 9:49 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: new N2 doesn't work

Unread post by dsystems » Tue Sep 24, 2019 11:12 am

I used dev.20190705 and it works great. Thank you so much. 대단히 감사합니다
These users thanked the author dsystems for the post (total 2):
tobetter (Tue Sep 24, 2019 11:27 am) • odroid (Wed Sep 25, 2019 10:21 am)

grapenose
Posts: 12
Joined: Mon Sep 23, 2019 8:54 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: new N2 doesn't work

Unread post by grapenose » Thu Oct 03, 2019 10:36 am

Having same problems as dsytems.
Do I need to use Etcher to copy the image to the SD card or just copy and rename.
I tried to copy and rename but it failed to update the SPI image.
Will try Etcher next

User avatar
tobetter
Posts: 4038
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 43 times
Been thanked: 189 times
Contact:

Re: new N2 doesn't work

Unread post by tobetter » Thu Oct 03, 2019 2:11 pm

grapenose wrote:
Thu Oct 03, 2019 10:36 am
Having same problems as dsytems.
Do I need to use Etcher to copy the image to the SD card or just copy and rename.
I tried to copy and rename but it failed to update the SPI image.
Will try Etcher next
If you are meaning to update Petitboot, download the latest firmware and copy the file to uSD as spiboot.img. After attaching the uSD, you must flip the boot switch to SPI and do power cycle.

grapenose
Posts: 12
Joined: Mon Sep 23, 2019 8:54 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: new N2 doesn't work

Unread post by grapenose » Thu Oct 03, 2019 2:37 pm

Box arrived yesterday, powered on and Coreelec screen came up twice then all I had was a rectangle in the top left hand corner of the screen. Lights seemed to be right but no OS

Downloaded latest firmware.
Copied to SD without using Etcher?
Renamed but not recognised by box.Still has the old version ending in 416.
Lucky I had a SD reader.

User avatar
tobetter
Posts: 4038
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 43 times
Been thanked: 189 times
Contact:

Re: new N2 doesn't work

Unread post by tobetter » Thu Oct 03, 2019 4:39 pm

grapenose wrote:
Thu Oct 03, 2019 2:37 pm
Box arrived yesterday, powered on and Coreelec screen came up twice then all I had was a rectangle in the top left hand corner of the screen. Lights seemed to be right but no OS

Downloaded latest firmware.
Copied to SD without using Etcher?
Renamed but not recognised by box.Still has the old version ending in 416.
Lucky I had a SD reader.
Are you trying to install CoreELEC or Petitboot?
For CoreELEC, you should use Ether and for Petitboot, you should copy the firmware file to uSD.

grapenose
Posts: 12
Joined: Mon Sep 23, 2019 8:54 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: new N2 doesn't work

Unread post by grapenose » Fri Oct 04, 2019 7:47 am

Trying to install Petitboot and then CoreELEC.
Does it matter what the file system is for the SD card?
I think I had it as FAT32.
Have a Ubuntu NUC, would it help to use that to add the firmware to the SD card?
Will have another go with different SD cards.

User avatar
tobetter
Posts: 4038
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 43 times
Been thanked: 189 times
Contact:

Re: new N2 doesn't work

Unread post by tobetter » Fri Oct 04, 2019 11:57 am

grapenose wrote:
Fri Oct 04, 2019 7:47 am
Trying to install Petitboot and then CoreELEC.
Does it matter what the file system is for the SD card?
I think I had it as FAT32.
Have a Ubuntu NUC, would it help to use that to add the firmware to the SD card?
Will have another go with different SD cards.
For Petitboot, download the latest firmware (ver.20190705) and copy it as spiboot.img to SD card (FAT32 or EXT2). Then flip the boot select switch to SPI after attaching the SD card, then the firmware in SPI will start to update itself.
The CoreELEC already works with Petitboot, so if you properly flash CoreELEC to a memory card then Petitboot will show it up.

grapenose
Posts: 12
Joined: Mon Sep 23, 2019 8:54 am
languages_spoken: english
ODROIDs: N2
Has thanked: 0
Been thanked: 0
Contact:

Re: new N2 doesn't work

Unread post by grapenose » Fri Oct 04, 2019 2:07 pm

Tried with SD card as ext4.
Did not update.
Installed both coreELEC and Android pie on SD cards . Both worked,
Will stick with present firmware version and try again later.
Thanks for your help

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 3 guests