u-boot and sd_fuse

Post Reply
adilinden
Posts: 7
Joined: Mon Jan 13, 2014 2:46 am
languages_spoken: english, deutsch
ODROIDs: ordoid-u3 hopefully
Location: Ontario, Canada
Has thanked: 0
Been thanked: 0
Contact:

u-boot and sd_fuse

Unread post by adilinden » Thu Jan 16, 2014 4:01 am

I am building u-boot from odroid sources https://github.com/hardkernel/u-boot.git. The u-boot tree builds successfully, but how do I run sd_fuse? Do I run ./sd_fuse/sd_fusing.sh or ./sd_fuse/smdk4x12/sd_fusing.sh? Where do I find the E4x12_N.bl1.bin and E4x12_tzsw.bin for the later or c210N.nbl1.bin and v310N.nbl1.bin for the former?

- Thanks

LiquidAcid
Posts: 1093
Joined: Fri Oct 11, 2013 11:07 pm
languages_spoken: english
ODROIDs: X2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: u-boot and sd_fuse

Unread post by LiquidAcid » Thu Jan 16, 2014 4:05 am

Make sure that you're not using the master branch, but, in the case of the U2, the odroid-v2010.12 one.

adilinden
Posts: 7
Joined: Mon Jan 13, 2014 2:46 am
languages_spoken: english, deutsch
ODROIDs: ordoid-u3 hopefully
Location: Ontario, Canada
Has thanked: 0
Been thanked: 0
Contact:

Re: u-boot and sd_fuse

Unread post by adilinden » Thu Jan 16, 2014 12:01 pm

Oh yes, I see it in the odroid-v2010.12 branch. I was using the odroid-v2012.07 branch and they weren't there.

J4rl
Posts: 5
Joined: Tue Jan 29, 2019 3:04 am
languages_spoken: english
ODROIDs: U2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: u-boot and sd_fuse

Unread post by J4rl » Tue Jun 11, 2019 5:59 pm

Hello,

I'd like to upgrade my U2 with U-boot. My Xserver doesn't work so I can only connect to it via ssh.

My current version is:

Code: Select all

U-Boot 2010.12-svn (Dec 21 2012 - 19:44:04) for Exynox4412

Linux odroid 3.8.13.7 #1 SMP PREEMPT Mon Sep 2 22:50:51 BRT 2013 armv7l GNU/Linux

No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.9 (stretch)
Release:        9.9
Codename:       stretch

Code: Select all

odroid@odroid:/boot$ cat boot.txt
setenv initrd_high "0xffffffff"
setenv fdt_high "0xffffffff"
setenv hdtv_type "hdmi"
setenv hdtv_format "720p60hz"
setenv bootcmd "fatload mmc 0:1 0x40008000 zImage; fatload mmc 0:1 0x42000000 uInitrd; bootm 0x40008000 0x42000000"
setenv bootargs "console=tty1 console=ttySAC1,115200n8 hdtv_type=${hdtv_type} hdtv_format=${hdtv_format} root=UUID=e139ce78-9841-40fe-8823-96a304a09859 rootwait ro  mem=2047M"
boot
I've tried several times and always failed :( I read this instuctions because it looks to easy way and simply put ready u-boot but also with fail.

I build from hardkernel source v2010 and doesn't work.

I found whole ubuntu image with works on my U2 with v2018 u-boot and I simply try:

Code: Select all

dd if=ubuntu.img of=/dev/mmblk0 bs=512 skip=1 seek=1 count=2046
but also with fail.

U2 bliks with blue but system (kernel?) didn't boot. It seems that u-boot start but system don't.

I don't change boot directory or boot.scr.
  1. Is there any prepared u-boot to download and put to 63 sector?
  2. Can I flush only U-boot to 63 sector (with SD card not eMMc) without Bl1 Bl2 and tzwd or I have always put them together?
  3. After flush is there any necessary step to do which I missed? What is it?
I understand that u-boot should automatically seek /boot/boot.src in first or second partition and next boot.scr show where is the kernel right?

Thank you.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests