[solved] no video output except for CoreElec

Post Reply
Sav
Posts: 56
Joined: Mon Sep 02, 2019 2:33 am
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 19 times
Been thanked: 2 times
Contact:

[solved] no video output except for CoreElec

Unread post by Sav » Fri Sep 06, 2019 7:11 am

Hi,
my N2 is attached to an LG led TV (47LW650G: 1080p@50 to 60 hz).
I always used CoreElec without problems.
Today I tried some linux distros (ubuntu from hardkernel, armbian, manjaro lxqt and android lineageos-16 from Voodik). I can't see anything, except the hardkernel logo on android booting for a second.
From what I understand only CoreElec is able to detect the proper video settings (1080p@59.84 hz).
Is there a way to troubleshooting this?
thanks
Last edited by Sav on Sat Sep 07, 2019 5:30 am, edited 1 time in total.

User avatar
odroid
Site Admin
Posts: 32745
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 223 times
Been thanked: 369 times
Contact:

Re: no video output except for CoreElec

Unread post by odroid » Fri Sep 06, 2019 9:15 am

Did you flash this image with Etcher?
ubuntu-18.04.3-4.9-mate-odroid-n2-20190812.img.xz
https://wiki.odroid.com/odroid-n2/os_im ... u/20190812

Do you use SD card? or eMMC?

Sav
Posts: 56
Joined: Mon Sep 02, 2019 2:33 am
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 19 times
Been thanked: 2 times
Contact:

Re: no video output except for CoreElec

Unread post by Sav » Fri Sep 06, 2019 4:31 pm

odroid wrote:
Fri Sep 06, 2019 9:15 am
Did you flash this image with Etcher?
ubuntu-18.04.3-4.9-mate-odroid-n2-20190812.img.xz
https://wiki.odroid.com/odroid-n2/os_im ... u/20190812
yesI used etcher, but I downloaded the image from https://dn.odroid.com/S922X/ODROID-N2/U ... 812.img.xz I think is the same.
Do you use SD card? or eMMC?
eMMc

User avatar
odroid
Site Admin
Posts: 32745
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 223 times
Been thanked: 369 times
Contact:

Re: no video output except for CoreElec

Unread post by odroid » Fri Sep 06, 2019 6:05 pm

Is the blue LED flashing like hearbeat?
If you can access your N2 Ubuntu machine via Ethernet SSH connection remotely, edit /media/boot/boot.ini file to disable the display auto-detection feature.
https://github.com/mdrjr/n2_bootini/blo ... oot.ini#L7

Sav
Posts: 56
Joined: Mon Sep 02, 2019 2:33 am
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 19 times
Been thanked: 2 times
Contact:

Re: no video output except for CoreElec

Unread post by Sav » Fri Sep 06, 2019 6:16 pm

odroid wrote:
Fri Sep 06, 2019 6:05 pm
Is the blue LED flashing like hearbeat?
If you can access your N2 Ubuntu machine via Ethernet SSH connection remotely, edit /media/boot/boot.ini file to disable the display auto-detection feature.
https://github.com/mdrjr/n2_bootini/blo ... oot.ini#L7
Do I must to disable the auto-detecion feature and manually enable one of the video mode listed ( setenv hdmimode "1080p60hz", for example)?

User avatar
odroid
Site Admin
Posts: 32745
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 223 times
Been thanked: 369 times
Contact:

Re: no video output except for CoreElec

Unread post by odroid » Fri Sep 06, 2019 6:34 pm

The default value is "1080p60hz". So just disable the auto-detection feature. ("true" to "false")
https://github.com/mdrjr/n2_bootini/blo ... ot.ini#L50
These users thanked the author odroid for the post:
Sav (Sat Sep 07, 2019 5:29 am)

Sav
Posts: 56
Joined: Mon Sep 02, 2019 2:33 am
languages_spoken: english
ODROIDs: odroid-n2
Has thanked: 19 times
Been thanked: 2 times
Contact:

Re: no video output except for CoreElec

Unread post by Sav » Sat Sep 07, 2019 5:29 am

odroid wrote:
Fri Sep 06, 2019 6:34 pm
The default value is "1080p60hz". So just disable the auto-detection feature. ("true" to "false")
https://github.com/mdrjr/n2_bootini/blo ... ot.ini#L50
It works, thanks a lot.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests