Enabling WakeOnLan - not working?

Post Reply
qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Enabling WakeOnLan - not working?

Unread post by qcasey1 » Wed Jul 31, 2019 2:21 am

Hi all, I'm trying to follow this seemingly simple guide: https://wiki.odroid.com/odroid-n2/appli ... ake-on-lan

But for some reason sending the magic packet is not waking up the device? Is there a special tool or something to be enabled?

This is what I've done so far

Code: Select all

$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.0.26  netmask 255.255.255.0  broadcast 10.0.0.255
        inet6 fe80::5920:df40:ffc9:bced  prefixlen 64  scopeid 0x20<link>
        ether 00:1e:06:42:0d:b3  txqueuelen 1000  (Ethernet)
        RX packets 78  bytes 9818 (9.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 77  bytes 11436 (11.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 21  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 113  bytes 9857 (9.8 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 113  bytes 9857 (9.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Code: Select all

$ cat /proc/cmdline
root=UUID=e139ce78-9841-40fe-8823-96a304a09859 rootwait rw console=ttyS0,115200n8  no_console_suspend fsck.repair=yes net.ifnames=0 elevator=noop hdmimode=1080p60hz cvbsmode=576cvbs max_freq_a53=1896 max_freq_a73=1800 maxcpus=6 voutmode=hdmi  disablehpd=false cvbscable=0 overscan=100  monitor_onoff=false enable_wol=1

Code: Select all

poweroff
the N2, leave attached to DC of course

From my laptop and desktop I've tried both:

Code: Select all

$ wakeonlan 00:1e:06:42:0d:b3
Sending magic packet to 255.255.255.255:9 with 00:1e:06:42:0d:b3
and

Code: Select all

$ wakeonlan -i 10.0.0.255 00:1e:06:42:0d:b3
Sending magic packet to 10.0.0.255:9 with 00:1e:06:42:0d:b3
but nothing is working. I don't see any lights on the N2's ethernet port (although the light on the switch it's plugged into is solid). Does this require an RTC battery? Any advice? Thank you very much! :)
Last edited by qcasey1 on Wed Jul 31, 2019 2:28 am, edited 1 time in total.

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Wed Jul 31, 2019 2:27 am

I also tried plugging N2 ethernet to my router (no switch) and directly to my latptop too, still nothing

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Wed Jul 31, 2019 3:34 am

Found someone having this issue in April, looks like the thread died or still no solution? viewtopic.php?t=34727

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Wed Jul 31, 2019 5:16 am

Like in the thread above, WOL works when doing

Code: Select all

systemctl suspend
, but there is no heartbeat light and the filesystem does not remount. Can't ssh back in either, but this proves the magic packets are being received. Why does this not work with poweroff?

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by odroid » Wed Jul 31, 2019 10:40 am

We will check the WoL functionality.
BTW, are you running Kernel 4.9.185-43 on Ubuntu?

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Wed Jul 31, 2019 12:41 pm

Thank you, please let me know of what to do. Yes, this looks like the latest update

Code: Select all

$ uname -a
Linux lucio 4.9.185-43 #1 SMP PREEMPT Mon Jul 29 23:55:54 -03 2019 aarch64 aarch64 aarch64 GNU/Linux

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by odroid » Thu Aug 01, 2019 6:06 pm

We can check it early next week since many colleagues are having a summer vacation.
Sorry.

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by odroid » Fri Aug 02, 2019 9:28 am

We've tested it.
But the N2 waked up around 15 minutes later. :o
We will try to check why it is so lazy.

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Fri Aug 02, 2019 10:30 am

Oh that's interesting, hmm.

I noticed WOL sort of works on the stock image (20190329) when I

1. Boot from Petiteboot (switch on SPI not MMC) and

2. Do systemctl suspend instead of poweroff

The system comes back to life immediately and the filesystem is remounted (USB doesn't reattach though). WOL doesn't work in any case after doing apt update && apt upgrade.

I don't know if that's helpful but thought I'd post

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Fri Aug 02, 2019 10:31 am

Thank you for investigating this by the way

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by odroid » Wed Aug 07, 2019 11:41 am

Try the latest Kernel update 4.9.187-52.
It wakes up immediately now.
These users thanked the author odroid for the post:
qcasey1 (Thu Aug 08, 2019 9:41 am)

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Thu Aug 08, 2019 8:01 am

How are you triggering WOL? I upgraded to the latest kernel and it's still acting as it did before - I think I may be doing something wrong

Also petiteboot doesn't recognize my EMMC module anymore, is that normal in this use case?

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Thu Aug 08, 2019 8:53 am

I transferred my image from EMMC to SD Card, and WOL works OK with systemctl suspend. The only issue I still see is USB disks not coming back online.

Can you confirm systemctl suspend is the proper method? Also is there any way to fix USB disks? Getting a lot of

Code: Select all

Cannot enable. Maybe the USB cable is bad?
After waking from suspend

qcasey1
Posts: 23
Joined: Thu Apr 18, 2019 7:29 am
languages_spoken: english
ODROIDs: XU4, N2
Location: California
Has thanked: 5 times
Been thanked: 0
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by qcasey1 » Thu Aug 08, 2019 9:40 am

Sorry for the post spam, just tried a different USB -> SATA cable and everything works great, even on EMMC! USB2 speeds on that disk still but I'm following the thread on that, so far so good.

Thank you very much!

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: Enabling WakeOnLan - not working?

Unread post by odroid » Thu Aug 08, 2019 9:44 am

Glad to hear that! :)

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 0 guests