Issues running a 32bit binary on my N2 with Ubuntu

Post Reply
User avatar
Spag
Posts: 4
Joined: Thu Jul 04, 2019 3:38 am
languages_spoken: english
ODROIDs: N2
Has thanked: 3 times
Been thanked: 0
Contact:

Issues running a 32bit binary on my N2 with Ubuntu

Unread post by Spag » Wed Jul 10, 2019 9:06 pm

Hi guys,

I am having issues running a 32 bit binary on my N2 with Ubuntu (MATE image installed and all packages upgraded).

I can see the file, it has execute permissions:

Code: Select all

file blocknetdx-qt
blocknetdx-qt: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-, for GNU/Linux 3.2.0, BuildID[sha1]=8e3ab66b810b9acc975335e6502dfa8bc9252eee, stripped
However when trying to run it:

Code: Select all

./blocknetdx-qt
-bash: ./blocknetdx-qt: No such file or directory
Do I need to install any 32bit libraries so that I can run this application?

Thank you for your help! :)

User avatar
mad_ady
Posts: 6805
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 218 times
Been thanked: 167 times
Contact:

Re: Issues running a 32bit binary on my N2 with Ubuntu

Unread post by mad_ady » Wed Jul 10, 2019 10:51 pm

Yes. You're missing the 32bit loader. You should be able to add it with:

Code: Select all

sudo dpkg --add-architecture armhf
sudo apt-get update
sudo apt-get install libc:armhf
Then you can use ldd to see what other armhf libraries are missing and install those.
See the 32bit legacy programs section here: https://magazine.odroid.com/article/odr ... -to-arm64/
These users thanked the author mad_ady for the post (total 2):
Spag (Thu Jul 11, 2019 4:49 pm) • xabolcs (Fri Jul 12, 2019 4:58 am)

User avatar
Spag
Posts: 4
Joined: Thu Jul 04, 2019 3:38 am
languages_spoken: english
ODROIDs: N2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Issues running a 32bit binary on my N2 with Ubuntu

Unread post by Spag » Wed Jul 10, 2019 11:30 pm

Thanks! I followed your instructions but on apt-get update I get:

Code: Select all

Reading package lists... Done                      
N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'http://deb.odroid.in/n2 bionic InRelease' doesn't support architecture 'armhf'
Any idea?

User avatar
meveric
Posts: 10544
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2, H2 (J4105)
Has thanked: 17 times
Been thanked: 155 times
Contact:

Re: Issues running a 32bit binary on my N2 with Ubuntu

Unread post by meveric » Wed Jul 10, 2019 11:41 pm

alter the sources.list file that has the deb.odroid.in entries and add [arch=arm64] behind the deb... looking something like this:

Code: Select all

deb [arch=arm64] http://deb.odroid.in n2 bionic
These users thanked the author meveric for the post:
Spag (Thu Jul 11, 2019 4:49 pm)
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

User avatar
Spag
Posts: 4
Joined: Thu Jul 04, 2019 3:38 am
languages_spoken: english
ODROIDs: N2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Issues running a 32bit binary on my N2 with Ubuntu

Unread post by Spag » Thu Jul 11, 2019 12:00 am

My /etc/apt/sources.list does not contain any line pointing to deb.odroid.in:

Code: Select all

deb http://ports.ubuntu.com/ubuntu-ports/ bionic main restricted
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic main restricted

deb http://ports.ubuntu.com/ubuntu-ports/ bionic-updates main restricted
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic-updates main restricted

deb http://ports.ubuntu.com/ubuntu-ports/ bionic universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic universe
deb http://ports.ubuntu.com/ubuntu-ports/ bionic-updates universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic-updates universe

deb http://ports.ubuntu.com/ubuntu-ports/ bionic multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic multiverse
deb http://ports.ubuntu.com/ubuntu-ports/ bionic-updates multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic-updates multiverse

deb http://ports.ubuntu.com/ubuntu-ports/ bionic-backports main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu bionic partner
deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://ports.ubuntu.com/ubuntu-ports/ bionic-security main restricted
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic-security main restricted
deb http://ports.ubuntu.com/ubuntu-ports/ bionic-security universe
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic-security universe
deb http://ports.ubuntu.com/ubuntu-ports/ bionic-security multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ bionic-security multiverse
I tried to add an additional line:

Code: Select all

deb [arch=arm64] http://deb.odroid.in n2 bionic
But then I get:

Code: Select all

sudo apt-get update
Hit:1 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Hit:2 http://archive.canonical.com/ubuntu bionic InRelease                                              
Hit:3 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease                                     
Hit:4 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease   
Hit:5 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease
Ign:6 http://deb.odroid.in n2 InRelease           
Hit:7 http://deb.odroid.in/n2 bionic InRelease    
Err:8 http://deb.odroid.in n2 Release             
  404  Not Found [IP: 104.236.30.141 80]
x                            
Reading package lists... 8%
Reading package lists... Done
E: The repository 'http://deb.odroid.in n2 Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'http://deb.odroid.in/n2 bionic InRelease' doesn't support architecture 'armhf'
I'm a n00b sorry, maybe you need to give me more detailed explanations.. ;)

User avatar
mad_ady
Posts: 6805
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 218 times
Been thanked: 167 times
Contact:

Re: Issues running a 32bit binary on my N2 with Ubuntu

Unread post by mad_ady » Thu Jul 11, 2019 12:14 am

It should be in /etc/apt/sources.list.d/odroid.list.
It's normal for the N2 branch not to have armhf packages.
These users thanked the author mad_ady for the post:
Spag (Thu Jul 11, 2019 4:49 pm)

User avatar
Spag
Posts: 4
Joined: Thu Jul 04, 2019 3:38 am
languages_spoken: english
ODROIDs: N2
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Issues running a 32bit binary on my N2 with Ubuntu

Unread post by Spag » Thu Jul 11, 2019 4:49 pm

Even adding this change into /etc/apt/sources.list.d/odroid.list didn't solve the issue.. when running

sudo apt-get install libc:armhf

I get no package "libc:armhf" found

But anyway I do not need this anymore, as I was able to compile the desired application directly on my N2. So now it's running fine! :D

Thanks anyway for your help guys, much appreciated! :)

User avatar
mad_ady
Posts: 6805
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 218 times
Been thanked: 167 times
Contact:

Re: Issues running a 32bit binary on my N2 with Ubuntu

Unread post by mad_ady » Thu Jul 11, 2019 5:07 pm

You can try with sudo apt-get install libc6:armhf

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 7 guests