C1+ with Hifi Shield 2 - White Screen on S/PDIF Audio Out

Post Reply
Kapster
Posts: 2
Joined: Sat Jun 22, 2019 3:37 am
languages_spoken: english, german
ODROIDs: C1+, C0
Has thanked: 1 time
Been thanked: 0
Contact:

C1+ with Hifi Shield 2 - White Screen on S/PDIF Audio Out

Unread post by Kapster » Sat Jun 22, 2019 3:48 am

Hi,

I have posted my question allready on the volumio forum, but with no success...

After OSMC and Runeaudio I just recently ended up with Volumio, also due to lagging support for Runeaudio. I am using an Odroid C1+ with an Hifi Shield 2 to stream via SPDIF to my WAF Najda DSP. I have also tested the analog outs, but the digital out is far above, also it really doesn't make sense to me to go Digital->Analog->Digital->Analog. I am really happy with the result, however when choosing SPDIF as an output for audio, the screen running the UI turns blank white. I was really happy to see my waveshare 7" screen running natively the UI on analog out, so I am hoping to get this back. When choosing Hifi Shield 2 (analog outs) as the output, everything works fine. I hope there is no restriction, but I couldn't find anything on the forum.

The screen works fine during boot up, but turns white the exact moment the SPDIF out is turned on and my external DAC gives me a green light meaning that the SPDIF receiver can extract a suitable clock from the supplied SPDIF stream! I am still wondering wether it is possible to have a video out via HDMI while having the digital audio out via SPDIF at the same time, because to me this looks like what is causing the problem!

1. Boot log with Playback Output "HDMI/TOSLINK (S/PDIF)" - Blank white screen on HDMI out http://logs.volumio.org/volumio/YAWdC9R.html
2. Boot log with Playback Output "Hifi Shield 2" - Screen on HDMI out works as it should http://logs.volumio.org/volumio/tjWoBSD.html

Is there a problem with the kernel, I am still running the old 3.10.104? What I did - Flashed Volumio on SD, installed the Touchscreen plugin, changed the Boot.ini to have 800x480 60p screen resolution.

Looking forward! Thanks in advance! Kind regards, Alex

User avatar
odroid
Site Admin
Posts: 32519
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 184 times
Been thanked: 349 times
Contact:

Re: C1+ with Hifi Shield 2 - White Screen on S/PDIF Audio Out

Unread post by odroid » Mon Jun 24, 2019 9:16 am

Can you find vout_mode option in your boot.ini file?
https://github.com/mdrjr/c1_bootini/blo ... ot.ini#L32

If yes, change it to "dvi" from "hdmi".
These users thanked the author odroid for the post:
Kapster (Thu Jun 27, 2019 4:42 am)

Kapster
Posts: 2
Joined: Sat Jun 22, 2019 3:37 am
languages_spoken: english, german
ODROIDs: C1+, C0
Has thanked: 1 time
Been thanked: 0
Contact:

Re: C1+ with Hifi Shield 2 - White Screen on S/PDIF Audio Out

Unread post by Kapster » Thu Jun 27, 2019 4:43 am

odroid wrote:
Mon Jun 24, 2019 9:16 am
Can you find vout_mode option in your boot.ini file?
https://github.com/mdrjr/c1_bootini/blo ... ot.ini#L32

If yes, change it to "dvi" from "hdmi".
Well that was an easy fix! Thank you very much. All running smooth now! I'll spread the word on the volumio forum.

Keep it up! Best regards, Alex

Post Reply

Return to “I2S Devices (HiFi Shield DAC and Stereo Boom Bonnet Kit)”

Who is online

Users browsing this forum: No registered users and 4 guests