kplayer nor c2play works after 4.9.180 update

Post Reply
XOR
Posts: 4
Joined: Wed May 22, 2019 12:30 am
languages_spoken: english
ODROIDs: N2
Has thanked: 18 times
Been thanked: 1 time
Contact:

kplayer nor c2play works after 4.9.180 update

Unread post by XOR » Mon Jun 17, 2019 8:19 am

Hello,

is it only me or kplayer and c2play are not working after last update (4.9.180 ubuntu minimal)?

Code: Select all

Init [/dev/amstream_vbuf] failed,ret = -1 error=2 retry_open!
Playback won't start – get no audio and just blank screen.

Tried to update u-boot, and got out of ideas :)
Attachments
kplayer_stderr.txt
(62 Bytes) Downloaded 14 times
kplayer_stdout.txt
(4 KiB) Downloaded 17 times
These users thanked the author XOR for the post:
thomas-teknique (Tue Jun 18, 2019 8:05 am)

User avatar
odroid
Site Admin
Posts: 31297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 44 times
Been thanked: 179 times
Contact:

Re: kplayer nor c2play works after 4.9.180 update

Unread post by odroid » Mon Jun 17, 2019 1:35 pm

Try to reinstall mali gpu driver if you can't run "glmark2-es2-fbdev".

Code: Select all

sudo apt install -reinstall mali-fbdev
If it doesn't help, please let me know again.


Edit: I could reproduce the issue.
We will check what's wrong.
These users thanked the author odroid for the post:
XOR (Mon Jun 17, 2019 9:08 pm)

User avatar
odroid
Site Admin
Posts: 31297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 44 times
Been thanked: 179 times
Contact:

Re: kplayer nor c2play works after 4.9.180 update

Unread post by odroid » Wed Jun 19, 2019 9:31 am

Update your Kernel to 4.9.182-31 and kplayer & c2play will work again.
These users thanked the author odroid for the post (total 2):
thomas-teknique (Wed Jun 19, 2019 9:32 am) • XOR (Wed Jun 19, 2019 7:35 pm)

XOR
Posts: 4
Joined: Wed May 22, 2019 12:30 am
languages_spoken: english
ODROIDs: N2
Has thanked: 18 times
Been thanked: 1 time
Contact:

Re: kplayer nor c2play works after 4.9.180 update

Unread post by XOR » Wed Jun 19, 2019 7:35 pm

Yes, it works! Thank you!

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests