XU4 DOA

Post Reply
txusyk
Posts: 9
Joined: Wed May 29, 2019 8:02 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 0
Been thanked: 0
Contact:

XU4 DOA

Unread post by txusyk » Wed May 29, 2019 8:11 am

Hey!

I just bought a XU4 (I bought it alongside some friends who bought another XU4 and 2 Odroid Go). When I've connected for the first time it displayed some error messages and then it got impossible to turn off.
Now, I'm trying to boot it with the same eMMC that came with the XU4 but it stacks on boot while only shows a red light and the fan doesn't turn on. I've tried to flash DietPi using balenaEtcher (after extracting the .xz and getting the .img), also tried with ubuntu-16.04-mate-odroid-u2u3-20160920 and I got the same result. Tomorrow, at morning I will try to flash an SD Card and if it doesn't work I will try this method shown by an administrator on this post viewtopic.php?f=53&t=6173.
If it doesn't work I assume that I have to get a RMA?

Thanks!

Have a good night

User avatar
meveric
Posts: 10270
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2
Has thanked: 13 times
Been thanked: 102 times
Contact:

Re: XU4 DOA

Unread post by meveric » Wed May 29, 2019 8:32 am

txusyk wrote:
Wed May 29, 2019 8:11 am
also tried with ubuntu-16.04-mate-odroid-u2u3-20160920 and I got the same result.
Make sure you flash the correct images, the one above is for the ODROID U2/U3 NOT for the ODROID XU4 and therefore will not be able to boot!
Make sure the images you try have either "xu3" or "xu4" in their name, non other will work.
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

txusyk
Posts: 9
Joined: Wed May 29, 2019 8:02 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 DOA

Unread post by txusyk » Wed May 29, 2019 8:36 am

Thanks for fast replying!

And also thanks for correcting me, I'm gonna try right now!

txusyk
Posts: 9
Joined: Wed May 29, 2019 8:02 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 DOA

Unread post by txusyk » Wed May 29, 2019 9:09 am

Just tried with ubuntu-16.04.2-mate-odroid-xu4-20170510 and ubuntu-16.04-mate-odroid-xu4-20170731. Same problem, after flashing eMMC and connecting it to the UX4 I try to run it (without nothing more than the official 5V 4A PSU) and the board just doesn't starts.
Red fixed light and no power on the fan.
Any idea?

User avatar
meveric
Posts: 10270
Joined: Mon Feb 25, 2013 2:41 pm
languages_spoken: german, english
ODROIDs: X2, U2, U3, XU-Lite, XU3, XU3-Lite, C1, XU4, C2, C1+, XU4Q, HC1, N1, Go, H2 (N4100), N2
Has thanked: 13 times
Been thanked: 102 times
Contact:

Re: XU4 DOA

Unread post by meveric » Wed May 29, 2019 9:17 am

the boot switch is set to eMMC?
Try the SD card as you said you wanted to do.. if that doesn't help I guess HardKernel will tell you about RMA.
Donate to support my work on the ODROID GameStation Turbo Image for U2/U3 XU3/XU4 X2 X C1 as well as many other releases.
Check out the Games and Emulators section to find some of my work or check the files in my repository to find the software i build for ODROIDs.
If you want to add my repository to your image read my HOWTO integrate my repo into your image.

txusyk
Posts: 9
Joined: Wed May 29, 2019 8:02 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 DOA

Unread post by txusyk » Wed May 29, 2019 9:25 am

meveric wrote:
Wed May 29, 2019 9:17 am
the boot switch is set to eMMC?
Yep, but when I try with a microSD that I flashed before it's just the same result.
meveric wrote:
Wed May 29, 2019 9:17 am
Try the SD card as you said you wanted to do.. if that doesn't help I guess HardKernel will tell you about RMA.
I am not able right now to flash the androidSD2eMMC image, but as soon as possible I will try and update the post with the results. But yeah, It looks DOA from the first moment I tried it.

Thanks for the help

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: XU4 DOA

Unread post by odroid » Wed May 29, 2019 10:19 am

Try this image.
ubuntu-18.04.1-4.14-mate-odroid-xu4-20181203.img.xz

Do not extract .xz file to .img if you use Etcher for flashing.
https://wiki.odroid.com/troubleshooting ... extracting

BTW, do you have an Orange eMMC?
https://wiki.odroid.com/accessory/emmc/reference_chart

txusyk
Posts: 9
Joined: Wed May 29, 2019 8:02 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 DOA

Unread post by txusyk » Wed May 29, 2019 10:14 pm

odroid wrote:
Wed May 29, 2019 10:19 am
Try this image.
ubuntu-18.04.1-4.14-mate-odroid-xu4-20181203.img.xz

Do not extract .xz file to .img if you use Etcher for flashing.
https://wiki.odroid.com/troubleshooting ... extracting
I've tried the image while flashing it directly to the microSD card and It looks right. Red fixed light and blue blinking one.

I connected only the SD and boot, and it works.
odroid wrote:
Wed May 29, 2019 10:19 am
BTW, do you have an Orange eMMC?
https://wiki.odroid.com/accessory/emmc/reference_chart
Yeah. I have an orange one (with blue sticker on back). I've tried several distro images that would work as the post say, but every time I try to boot from the eMMC the result is the same, red fixed light.

I've tried the eMMC recovery method. And it looked alright until the blue light shutdowns and never come back (blinking as expected).

txusyk
Posts: 9
Joined: Wed May 29, 2019 8:02 am
languages_spoken: english
ODROIDs: XU4, N2
Has thanked: 0
Been thanked: 0
Contact:

Re: XU4 DOA

Unread post by txusyk » Thu May 30, 2019 12:00 am

So, after all my tries. These are my results:

- I can boot almost any OS from the microSD card port. Tried with several flavors of ubuntu, dietPi, arch...
- I can not boot anything from the eMMC. Tried the same just mentioned above.
- It seems that the board doesn't detect the eMMC. When I do the recovery method described above (trying with android-4.4.4-alpha-6.6-emmc_installer-odroidxu4-20181105 & android-4.4.4-alpha-5.8-sd2emmc_installer-odroidxu4-20171026) over the eMMC (blank) and after the process if I check the eMMC card it stills blank.

So... if the eMMC card works fine on PC, the partition structure & file structure its almost equal to the one created in the SD card... and still doesn't boot from eMMC, could be that the switch isn't working or the board just can read the eMMC?

User avatar
odroid
Site Admin
Posts: 31363
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 50 times
Been thanked: 184 times
Contact:

Re: XU4 DOA

Unread post by odroid » Thu May 30, 2019 10:55 am

Did you set the slide switch to "eMMC" when you insert only eMMC?
Please move the slide switch several times.

Was there any error while running Ethcher validation?

If it doesn't help, please contact "odroid at hardkernel dot com" with a link of this post.
They will help your RMA process if you purchased the board from us directly.
Otherwise, contact your local distributor/reseller.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests