Struggling with SDCard/eMMC install

Post Reply
Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Struggling with SDCard/eMMC install

Unread post by Richfilth » Mon May 13, 2019 4:37 pm

I picked up an Odroid-C1 recently, and I'm struggling to make any progress with installing any image to it. It came with an 8Gb eMMC card with a Linux image on it, and that booted fine, so I know the Odroid and that eMMC card were in good working condition when I started. Here's what I've tried:

1) Flashing Android 5.1 to a 32Gb Class 10 SD Card with Win32Imager. With the 5.1 image the Odroid powered up with the blue LED flashing, but nothing happened on screen.
2) Flashing Android 4.4.4, to the same 32Gb card with Win32Imager, the Odroid powered up with the blue LED on permanently. I saw the Hardkernel flash screen and the Android update image, then the screen went black. The solid blue remained for over an hour and then started blinking. When I power-cycled the Odroid, it didn't boot and the blue LED flashed.
3) Flashing Android 4.4.4 to the eMMC card with Etcher on an Ubuntu machine. Etcher said the process completed successfully, but the Odroid only powered up with the blue LED flashing, but nothing happened on screen. Checking the eMMC card on Linux showed that the Android directories had been created on the card.

I'm guessing that the 32Gb SD Card is also somehow not compatible with the C1, since I've read that this board is extremely picky about which SD Cards it will boot from. I don't want to throw more money at random SD cards in the hope that one will boot, soI'm not sure what to do at this point. I'm not a great Linux user, so although I've seen forum posts about modifying the boot record on the eMMC, I'm not sure how to go about it without permanently destroying the card.

I did search the forum but a lot of the older links are dead now. If anyone has had similar issues and can explain how they resolved it, that would be great.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Mon May 13, 2019 4:44 pm

Can you check the file name of OS images?
For 4.4: selfinstall-odroidc-eng-s805_4.4.4_master-462-v4.1.img.xz
For 5.1 : selfinstall-odroidc-eng-s805_5.1.1_master-29-v1.4.img.xz

What is the native resolution of your HDMI monitor?
What is the brand/model name of your 32GB microSD? Is it UHS-1 compatible?

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Mon May 13, 2019 4:50 pm

The 32Gb card is an ADATA Premiere UHS-1, so I didn't expect to have any compatibility problems. I can't double-check the image file names right now, but they look ok to me and they were downloaded straight from the Odroid wiki pages and unpacked with 7-Zip. As for the monitor, it defaults to 1920x1080 - is it worth trying with a smaller screen?

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Mon May 13, 2019 5:14 pm

No. 1080p monitor must be fine.

Do not unpack it.
Use the xz file with Etcher as it is. Etcher has a proven uncompressing feature inside.
Some uncompressing utilities could corrupt the image file.

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Mon May 13, 2019 5:18 pm

Aha, that's good to know, thanks. I'll try that and report back.

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Tue May 14, 2019 4:07 am

OK, I flashed the 5.1 image to the SD card using Etcher without unpacking the file first. The Odroid booted to the Hardkernal logo, and proceeded to the Android screen "Installing system update", so that's more progress than I had before! But after over an hour the power LED was still solid blue, and after a quick power cycle it just blink blue and I get nothing on the screen.

Flashing the 5.1 image to the eMMC card using the exact same method is nowhere near as successful: plain flashing blue LED, nothing on the screen.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Tue May 14, 2019 9:31 am

Was there any validation error while flashing the OS image?
Please try selfinstall-odroidc-eng-s805_4.4.4_master-462-v4.1.img.xz file too to narrow down root causes.
Don't connect SD and eMMC together.

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Tue May 14, 2019 3:29 pm

No validation errors, and no using the two cards together. I also tried the 4.4.4 image on both cards, as well as the latest Ubuntu image on the eMMC, all using Etcher, and none of them successfully booted. So it's not an image problem.

Power and video both delivered through genuine Hardkernel cables.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Tue May 14, 2019 4:24 pm

Remove J8 jumper if you use our official 5V/2A PSU.
https://wiki.odroid.com/odroid-c1/hardw ... wer_enable

Did you flash "ubuntu-18.04.1-mate-odroid-c1-20180726.img"?
Note that,
The RootFS Auto-resize feature has changed!!!
Once everything is done after auto-resizing, the power will turn off automatically.
Please Wait a couple of minutes and plug/unplug the power cable when the blue LED is off.
Is the blue LED flashing like heartbeat?

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Tue May 14, 2019 4:33 pm

odroid wrote:
Tue May 14, 2019 4:24 pm
Remove J8 jumper if you use our official 5V/2A PSU.
https://wiki.odroid.com/odroid-c1/hardw ... wer_enable
I'm using the C1, not the C1-plus, so there's no jumper.
odroid wrote:
Tue May 14, 2019 4:24 pm
Did you flash "ubuntu-18.04.1-mate-odroid-c1-20180726.img"?
Note that,
The RootFS Auto-resize feature has changed!!!
Once everything is done after auto-resizing, the power will turn off automatically.
Please Wait a couple of minutes and plug/unplug the power cable when the blue LED is off.
Yes, that's the image I flashed.
odroid wrote:
Tue May 14, 2019 4:24 pm
Is the blue LED flashing like heartbeat?
On all of these attempts I get the heartbeat (flash-flash-pause, flash-flash-pause), most of the time as soon as I power up the device, so there's no solid blue to indicate that the bootloader has started.
Last edited by Richfilth on Tue May 14, 2019 5:24 pm, edited 1 time in total.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Tue May 14, 2019 4:40 pm

The solid blue period should be a couple of second once you plug the DC barrel. After Kernel is loading and running, the blue LED must act as a heartbeat.
So your board should run the kernel well probably.

BTW, where did you buy the C1? It was discontinued almost three years ago and replaced with C1+.

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Wed May 15, 2019 5:01 am

I picked up this C1 as a new-old-stock from a seller in Poland. It's just a cheap prototyping placeholder before I commit to an XU4, but this OS issue is really leaving me scratching my head.

I switched to a new monitor and managed to boot up Ubuntu 18 from the eMMC, so that confirms that the board, the card, the wiring and the screen are all compatible. But I can't get any version of Android to boot from either of my memory cards (the SD or the eMMC). I can see the bootloader logo, and I can see the Android updating image, but then the screen goes greyish-white and the blue led stays lit (no heartbeat) for over two hours. If I power-cycle the board after that, I get nothing on any screen and just the heartbeat.

I think I'll have to work through all the other android images to see if I can get any of them to work.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Wed May 15, 2019 10:59 am

Do you have another 8~16GB microSD UHS-1 card for testing?

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Wed May 15, 2019 3:15 pm

Success! I found an old 16Gb Class 10 SD laying around, and managed to boot to Android 4.4.4 with it. It's painfully slow, but I expect that's the limitation of the card.

It doesn't quite explain why I couldn't flash the same image to the eMMC, but that's an issue for another day.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Wed May 15, 2019 4:06 pm

Even USH-1 compatible SD card will be very slow too.
You have to figure out why your eMMC doesn't boot.

What is the PCB color of your eMMC module?
https://wiki.odroid.com/accessory/emmc/reference_chart

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Wed May 15, 2019 4:34 pm

It's a blue 8Gb unit with a red sticker, so the chart suggests it's for the U2 models instead of the C1. Surprisingly I've just managed to flash a third-party image to it (the Pocket Rocket Android 4.4.2) and it booted up lightning-fast, so it seems to be an issue between the Hardkernel images and this family of eMMC cards.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Wed May 15, 2019 4:40 pm

Do you mean you could flash the pocket-rocket image to the blue eMMC and booted well?
Did you connect the blue eMMC to the eMMC connector on the bottom side of C1 PCB?

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Wed May 15, 2019 4:42 pm

Yes to both.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Wed May 15, 2019 4:43 pm

I see. Glad to see you found a solution for the very old eMMC and C1 hardware.
These users thanked the author odroid for the post:
Richfilth (Wed May 15, 2019 4:45 pm)

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Wed May 15, 2019 4:46 pm

Thank you for the incredible support! I'll definitely by buying one of the newer boards once I've finished my prototyping phase.

Richfilth
Posts: 15
Joined: Mon May 13, 2019 4:19 pm
languages_spoken: english
ODROIDs: Odroid-C1
Has thanked: 3 times
Been thanked: 0
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by Richfilth » Thu May 16, 2019 5:15 pm

Just as an update: this all seems to have been a monitor/resolution issue. I switched to a smaller screen (7", driven by a standard RTD2662 controller) and I haven't had any further issues with booting any image from either the eMMC or the 16Gb card. So if anyone else is struggling in the same way, try switching screens.

User avatar
odroid
Site Admin
Posts: 32718
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 217 times
Been thanked: 367 times
Contact:

Re: Struggling with SDCard/eMMC install

Unread post by odroid » Thu May 16, 2019 5:20 pm

If your display doesn't 1080p mode, you have to manually configure the boot.ini file for the native resolution.
https://wiki.odroid.com/odroid-c1/os_im ... ce_bootini

But, C2/XU4/N2 has a feature of the automatic resolution detect.

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 1 guest