[SOLVED]Mono/Sonarr/Radarr keeps crashing and leaving blob files...

Post Reply
thatchunkylad1989
Posts: 243
Joined: Sun Dec 24, 2017 12:29 am
languages_spoken: english
ODROIDs: C2, XU4
Has thanked: 0
Been thanked: 2 times
Contact:

[SOLVED]Mono/Sonarr/Radarr keeps crashing and leaving blob files...

Unread post by thatchunkylad1989 » Mon Apr 29, 2019 12:26 am

https://i.imgur.com/sXBFKiy.png

Mono/Sonarr/Radarr keeps crashing and mono leaving blob files...

I'm using an Odroid XU4 and I keep getting left over blob files.. what are these and how do I make it stop????

Help?! I have searched but can't find anything recent; just a fyi, no issues on my PI3.
Last edited by thatchunkylad1989 on Wed May 15, 2019 9:00 pm, edited 2 times in total.

thatchunkylad1989
Posts: 243
Joined: Sun Dec 24, 2017 12:29 am
languages_spoken: english
ODROIDs: C2, XU4
Has thanked: 0
Been thanked: 2 times
Contact:

Re: [PLEASE HELP]Sonarr/Radarr keeps crashing and leaving blob files...

Unread post by thatchunkylad1989 » Sun May 12, 2019 8:16 pm

Bump, still having the issue. :( :( :( :(

User avatar
odroid
Site Admin
Posts: 31871
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 93 times
Been thanked: 255 times
Contact:

Re: [PLEASE HELP]Mono/Sonarr/Radarr keeps crashing and leaving blob files...

Unread post by odroid » Mon May 13, 2019 8:35 am

I've never heard about Mono/Sonarr/Radarr. In fact, I don't know what it is. :oops:
I hope other people can help you.

thatchunkylad1989
Posts: 243
Joined: Sun Dec 24, 2017 12:29 am
languages_spoken: english
ODROIDs: C2, XU4
Has thanked: 0
Been thanked: 2 times
Contact:

Re: [PLEASE HELP]Mono/Sonarr/Radarr keeps crashing and leaving blob files...

Unread post by thatchunkylad1989 » Mon May 13, 2019 10:25 pm

Thanks to Reddit user: iefbr14dog for the fix!

For anyone else wondering...
I also had mono crashes with Sonarr/Radarr on my XU4... I eventually figured out that mono would sometimes crash when its processes were switched between the Cortex A15 cores and Cortex A7 cores in the XU4. The Pi3 only has A53 cores so it doesn't have that issue... Also, the crashes on the XU4 can be very intermittent since the mono processes might not get switched between core types very often -- usually only happens if the XU4 starts to get a little busy.

I had to start both Sonarr and Radarr to ONLY run on the faster A15 cores (or A7 cores if you prefer) instead of letting the kernel decide where to run it. I ended up using the taskset command to do that. eg. "taskset -c 4-7 /usr/bin/mono --debug /path/to/NzdDrone.exe blahblah". That makes sure Sonarr only runs on cores 4-7 (the A15s).

Since doing that I've not had any more issues with mono related crashes. Hope this helps!
I had to add:
ExecStart=/usr/bin/taskset -c 4-7 /usr/bin/mono --debug /opt/Radarr/Radarr.exe -nobrowser
and the same for Sonarr.
These users thanked the author thatchunkylad1989 for the post (total 2):
luukvbaal (Tue May 14, 2019 6:14 am) • odroid (Tue May 14, 2019 8:43 am)

luukvbaal
Posts: 5
Joined: Mon Jan 14, 2019 3:11 am
languages_spoken: english
ODROIDs: XU4
Has thanked: 1 time
Been thanked: 0
Contact:

Re: [PLEASE HELP]Mono/Sonarr/Radarr keeps crashing and leaving blob files...

Unread post by luukvbaal » Tue May 14, 2019 6:14 am

Wow thanks for this! I've been experiencing the issues and couldn't figure it out.

User avatar
odroid
Site Admin
Posts: 31871
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 93 times
Been thanked: 255 times
Contact:

Re: [PLEASE HELP]Mono/Sonarr/Radarr keeps crashing and leaving blob files...

Unread post by odroid » Tue May 14, 2019 8:42 am

Great! Thank you for sharing the useful information.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 3 guests