Boot into Kodi

Post Reply
Soleil
Posts: 36
Joined: Tue Apr 30, 2019 9:20 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 2 times
Contact:

Boot into Kodi

Unread post by Soleil » Tue Apr 30, 2019 9:27 am

Hi All,

Would you please recommend which guide to use if I want to boot straight to Kodi? I want to achieve from UI perspective more or less what Coreelec does, but need to stick to Ubuntu as box will serve as firewall and will provide some other services too.
I'm new to Odroid but have plenty of Linux/Ubuntu experience.
Is it possible to achieve situation that kernel boot process, console messages will be shown to HDMI prior switching to Kodi?
My HDMI display FHD 1080p60 seems to be on but blank.

Thanks in advance.

p.s. this thread is super old, hence looking for something more up to date: viewtopic.php?t=8700#p68836

User avatar
odroid
Site Admin
Posts: 32367
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: Boot into Kodi

Unread post by odroid » Tue Apr 30, 2019 9:43 am

Did you already compile Kodi 18 on Ubuntu?
viewtopic.php?f=177&t=34438

Soleil
Posts: 36
Joined: Tue Apr 30, 2019 9:20 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: Boot into Kodi

Unread post by Soleil » Tue Apr 30, 2019 10:35 am

Fighting to get it compiled - stuck at the moment on flatbuffers missing.

Code: Select all

cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/local -DCORE_PLATFORM_NAME=aml CMakeFiles/-DENABLE_INTERNAL_FLATBUFFERS=ON CMakeFiles/-DENABLE_ALSA=ON -DENABLE_AIRTUNES=ON -DENABLE_UPNP=ON CMakeFiles/-DENABLE_INTERNAL_FMT=ON -DENABLE_INTERNAL_RapidJSON=ON CMakeFiles/-DENABLE_OPENGLES=ON -DENABLE_OPENGL=OFF -DENABLE_X=OFF CMakeFiles/-DVERBOSE=OFF -DENABLE_NEON=ON CMakeFiles/-DWITH_CPU=cortex-a73.cortex-a53 -DWITH_ARCH=aarch64 CMakeFiles/-DENABLE_PULSEAUDIO=OFF -DENABLE_CCACHE=ON CMakeFiles/-DENABLE_INTERNAL_FFMPEG=ON CMakeFiles/-DENABLE_APP_AUTONAME=OFF -DENABLE_DVDCSS=OFF -DENABLE_INTERNAL_CROSSGUID=OFF -DENABLE_OPTICAL=OFF CMakeFiles/-DENABLE_EVENTCLIENTS=ON -DENABLE_CAP=ON CMakeFiles/-DENABLE_VDPAU=OFF CMakeFiles/ ../kodi
-- Source directory: /root/stuff/kodi/kodi
-- Build directory: /root/stuff/kodi/kodi-build
-- Generator: Single-configuration: Release (Unix Makefiles)
-- CMake Version: 3.10.2
-- System type: Linux
-- Linker: GNU gold
-- Core system type: linux
-- Platform:
-- CPU: aarch64, ARCH: aarch64
-- Cross-Compiling: FALSE
-- Execute build artefacts on host: TRUE
-- Depends based build:
-- Could not find hardware support for SSE (missing: _SSE_TRUE _SSE_OK)
-- Could not find hardware support for SSE2 (missing: _SSE2_TRUE _SSE2_OK)
-- Could not find hardware support for SSE3 (missing: _SSE3_TRUE _SSE3_OK)
-- Could not find hardware support for SSSE3 (missing: _SSSE3_TRUE _SSSE3_OK)
-- Could not find hardware support for SSE4.1 (missing: _SSE41_TRUE _SSE41_OK)
-- Could not find hardware support for SSE4.2 (missing: _SSE42_TRUE _SSE42_OK)
-- Could not find hardware support for AVX (missing: _AVX_TRUE _AVX_OK)
-- Could not find hardware support for AVX2 (missing: _AVX2_TRUE _AVX2_OK)
-- NEON optimization enabled
-- Could NOT find MDNS (missing: MDNS_LIBRARY MDNS_INCLUDE_DIR)
-- Could NOT find PulseAudio (missing: PULSEAUDIO_LIBRARY PULSEAUDIO_MAINLOOP_LIBRARY PULSEAUDIO_SIMPLE_LIBRARY PULSEAUDIO_INCLUDE_DIR) (Required is at least version "2.0.0")
-- FFmpeg 4.0 not found, falling back to internal build
CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  [b]Could NOT find FlatBuffers (missing: FLATBUFFERS_FLATC_EXECUTABLE
  FLATBUFFERS_INCLUDE_DIR)
[/b]Call Stack (most recent call first):
  /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  cmake/modules/FindFlatBuffers.cmake:56 (find_package_handle_standard_args)
  cmake/scripts/common/Macros.cmake:366 (find_package)
  cmake/scripts/common/Macros.cmake:380 (find_package_with_ver)
  CMakeLists.txt:179 (core_require_dep)


-- Configuring incomplete, errors occurred!
See also "/root/stuff/kodi/kodi-build/CMakeFiles/CMakeOutput.log".
See also "/root/stuff/kodi/kodi-build/CMakeFiles/CMakeError.log".

Soleil
Posts: 36
Joined: Tue Apr 30, 2019 9:20 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: Boot into Kodi

Unread post by Soleil » Sat May 04, 2019 11:05 am

Bump - probably pretty obvious for most of you, but still would be great if someone could point to the right reading.
Should it me something like xorg basic install + mali + start?

Starting it from CLI currently gets me:

Code: Select all

 ERROR: Unable to create GUI. Exiting 
Sounds like X needs to be started first - whats the recommended way for N2? I need to stick to ubuntu for other reasons.

Got as far as installing xorg and running
xinit /usr/bin/kod
or kodi-standalone - in both cases login prompt disappears but no kodi UI - screen stays blank.

Getting mode details:

Code: Select all

# xinit /usr/lib/aarch64-linux-gnu/kodi/kodi-xrandr


X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-138-generic aarch64 Ubuntu
Current Operating System: Linux nic 4.9.170-27 #1 SMP PREEMPT Mon Apr 29 12:45:24 -03 2019 aarch64
Kernel command line: root=UUID=e131c178-9841-40fe-8823-96a304a09859 rootwait rw console=tty1 console=ttyS0,115200n8  no_console_suspend fsck.repair=yes net.ifnames=0 elevator=noop hdmimode=1080p60hz cvbsmode=576cvbs max_freq_a53=1896 max_freq_a73=1800 maxcpus=6 voutmode=hdmi  disablehpd=false cvbscable= overscan=100
Build Date: 25 October 2018  04:10:37PM
xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat May  4 04:17:27 2019
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
/usr/lib/aarch64-linux-gnu/kodi/kodi-xrandr: Failed to get size of gamma for output default
<screen id="0" minimum_w="1920" minimum_h="1080" current_w="1920" current_h="1080" maximum_w="1920" maximum_h="1080">
  <output name="default" connected="true" w="1920" h="1080" x="0" y="0" crtc="0" wmm="0" hmm="0">
    <mode id="0x2a4" name="1920x1080" w="1920" h="1080" hz="0.00000" current="true" preferred="false"/>
  </output>
</screen>
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

Soleil
Posts: 36
Joined: Tue Apr 30, 2019 9:20 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: Boot into Kodi

Unread post by Soleil » Tue May 07, 2019 8:24 am

Update: got Kodi to start on boot via lightdm autostart.

It was down to installing xubuntu-core (apt install xubuntu-core) and updating lightdm config /etc/lightdm/lightdm.conf.d/kodi.conf.

Code: Select all

[Seat:*]
autologin-user=kodi
autologin-user-timeout=0
autologin-session=kodi
greeter-session=lightdm-gtk-greeter
Current problem is that Kodi uses then software and drive CPU at 400% (4 cores constantly used). This is no good.

Kodi works only if using libgles2 and not mali-fbdev. With the latter it generates set of messages:

Code: Select all

==> /home/kodi/.kodi/temp/kodi.log <==
01:15:00.022 T:547708112912   ERROR: Previous line repeats 1 times.
01:15:00.022 T:547708112912   ERROR: GetCharacter: Unable to cache character (out of memory?)
01:15:00.028 T:547708112912   ERROR: Previous line repeats 5 times.
01:15:00.028 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_texture.glsl]
01:15:00.028 T:547708112912   ERROR: Previous line repeats 1 times.
01:15:00.028 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_fonts.glsl]
01:15:00.063 T:547708112912   ERROR: Previous line repeats 376 times.
01:15:00.063 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_texture_noblend.glsl]
01:15:00.063 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_fonts.glsl]
01:15:00.065 T:547708112912   ERROR: Previous line repeats 29 times.
01:15:00.065 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_texture_noblend.glsl]
01:15:00.065 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_fonts.glsl]
01:15:00.067 T:547708112912   ERROR: Previous line repeats 47 times.
01:15:00.067 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_texture_noblend.glsl]
01:15:00.067 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_texture.glsl]
01:15:00.067 T:547708112912   ERROR: Previous line repeats 1 times.
01:15:00.067 T:547708112912   ERROR: Invalid GUI Shader selected - [guishader_frag_fonts.glsl]
This brings me back to point of getting Kodi using HW provided, but there's no such binary so far and instructions to compile are not working:

It might bring discussion to:
viewtopic.php?f=177&t=34438#p253286

But this is for another nitght...

User avatar
odroid
Site Admin
Posts: 32367
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: Boot into Kodi

Unread post by odroid » Tue May 07, 2019 10:08 am

We will try to release a Kodi-fbdev package within a few days.
These users thanked the author odroid for the post:
CaptManiac (Tue May 07, 2019 2:07 pm)

Soleil
Posts: 36
Joined: Tue Apr 30, 2019 9:20 am
languages_spoken: english
Has thanked: 1 time
Been thanked: 2 times
Contact:

Re: Boot into Kodi

Unread post by Soleil » Tue May 07, 2019 5:24 pm

@odroid Super highly appreciated!

For records - compile instructions from here: viewtopic.php?t=34438#p253137 work ok'ish - had to remove example client compilation and it went through. Questionable item from instruction is files overwrite cp -r * /

I'll update that thread accordingly.

juanjo1024
Posts: 15
Joined: Sat Sep 02, 2017 10:07 pm
languages_spoken: english, spanish
ODROIDs: C2 N2
Has thanked: 0
Been thanked: 0
Contact:

Re: Boot into Kodi

Unread post by juanjo1024 » Sun May 12, 2019 7:13 am

hi everybody

@odroid. any news on the package ? thanks in advance

Juanjo

User avatar
odroid
Site Admin
Posts: 32367
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: Boot into Kodi

Unread post by odroid » Mon May 13, 2019 9:29 am

Not yet. We met an issue while testing the Kodi package.
Give us one more week. Sorry for the delay.

juanjo1024
Posts: 15
Joined: Sat Sep 02, 2017 10:07 pm
languages_spoken: english, spanish
ODROIDs: C2 N2
Has thanked: 0
Been thanked: 0
Contact:

Re: Boot into Kodi

Unread post by juanjo1024 » Mon Jun 03, 2019 9:10 am

@odroid: any luck?

User avatar
odroid
Site Admin
Posts: 32367
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: Boot into Kodi

Unread post by odroid » Mon Jun 03, 2019 10:48 am

We made a trial package but it had some critical issue with display output.
We will fix and release it within a few days.

juanjo1024
Posts: 15
Joined: Sat Sep 02, 2017 10:07 pm
languages_spoken: english, spanish
ODROIDs: C2 N2
Has thanked: 0
Been thanked: 0
Contact:

Re: Boot into Kodi

Unread post by juanjo1024 » Sat Aug 03, 2019 4:38 am

odroid wrote:
Mon Jun 03, 2019 10:48 am
We made a trial package but it had some critical issue with display output.
We will fix and release it within a few days.
something like a flickering between a console window and the video itself ? i get that with .184 kernel and kodi while playing a video, if i fiddle with skip and rewind. otherwise it plays lovely.

EDIT: NVM, debug info from the codec was interfering.. seems to be gone with some line removed from source

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 0 guests