Odroid HC2 doesn't boot anymore

Post Reply
MoikvanDoik
Posts: 4
Joined: Thu May 02, 2019 6:25 am
languages_spoken: english, german
ODROIDs: HC2, N2
Has thanked: 2 times
Been thanked: 0
Contact:

Odroid HC2 doesn't boot anymore

Unread post by MoikvanDoik » Thu May 02, 2019 6:18 pm

Hello everyone,

yesterday I wanted to shutdown my Odroid HC 2 with Openmediavault image running on it. I choosed the "shutdown" option in the omv interface.
I wanted to test another power supply (12V/4A) only to see if it works, which was a really bad idea.
Unfortunatly I did not get a flashing blue LED and the HC2 now doesn't boot anymore (even with the first power-supply).
The green led near the SATA-controler flashes for short time and stays off. The power led is solid red, no matter which power supply I use. I tested a few other micro sd-cards with various images. There is no visible damage on the board.
Do you think I destroyed my HC2 with the power supply? The 12V/4A power supply works well with other devices.
Thank you!

User avatar
odroid
Site Admin
Posts: 32368
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: Odroid HC2 doesn't boot anymore

Unread post by odroid » Fri May 03, 2019 10:39 am

Technically, any 12V/4A or 12V/10A PSU should not damage the HC2 board.
But the PSU could generate a surge or uncertain peak voltage might kill your HC2 board.
It is really hard to know remotely how/which part of the board was damaged.

BTW, did you flash ubuntu-18.04.1-4.14-minimal-odroid-xu4-20181203.img.xz with Etcher?
These users thanked the author odroid for the post:
MoikvanDoik (Fri May 03, 2019 5:34 pm)

MoikvanDoik
Posts: 4
Joined: Thu May 02, 2019 6:25 am
languages_spoken: english, german
ODROIDs: HC2, N2
Has thanked: 2 times
Been thanked: 0
Contact:

Re: Odroid HC2 doesn't boot anymore

Unread post by MoikvanDoik » Fri May 03, 2019 5:33 pm

Thank you for your answer.
I know that it's difficult to help in my case
I just flashed the "ubuntu-18.04.1-4.14-minimal-odroid-xu4-20181203.img.xz" image with etcher and tried it again, but unfortunately there is no blue led.
I think my board doesn't recognize sd-cards anymore or should there be a short blue light even without a micro sd?
I checked the power consumption. It only consumes 10-12 Watts for a few seconds, then it does nothing, except for the red power led.
A few weeks ago I installed the newest JMS578 Firmware, but that worked well. Is there a way to factory reset the board?
Thank you!

User avatar
odroid
Site Admin
Posts: 32368
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 147 times
Been thanked: 325 times
Contact:

Re: Odroid HC2 doesn't boot anymore

Unread post by odroid » Fri May 03, 2019 5:55 pm

There is no factory reset feature since it is not required.
JMS578 controller has no relation to the blue LED. Blue LED is controlled by the CPU GPIO.

I think some portion of the PMIC or CPU could be damaged by uncertain electrical shock.
And CPU doesn't run and it couldn't fetch a boot code from the SD card.
Sorry about that.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 2 guests