Snapping sound then no boot

Post Reply
MajicM
Posts: 4
Joined: Thu Dec 27, 2018 9:01 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Snapping sound then no boot

Unread post by MajicM » Thu Dec 27, 2018 9:11 pm

Hi, I've a C2 which I got around 2 years ago.

It's been sat happily running LibreElec for that time, switched on 24x7 apart from when on holiday for a week.

I recently upgraded a local device and gave the Odroid to my brother who only had it 5 days when he reported it made a sort of snapping sound (like a christmas cracker being pulled) and then there were no lights on.

I've managed to get it back off him over the Xmas period and found that there is the Red Power LED on but rather than it being solid it's flickering very fast.

See video:

https://drive.google.com/open?id=1ACQg- ... pgljlSbSe0

I've tried different SD cards etc, nothing else happens.

Is the board dead? Time to throw it away? :(

Thanks for any advice.

User avatar
mad_ady
Posts: 5664
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 9 times
Been thanked: 14 times
Contact:

Re: Snapping sound then no boot

Unread post by mad_ady » Thu Dec 27, 2018 9:47 pm

You should check with a different power supply.

MajicM
Posts: 4
Joined: Thu Dec 27, 2018 9:01 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Snapping sound then no boot

Unread post by MajicM » Thu Dec 27, 2018 10:27 pm

Thanks Ady.

My brother said he tested the original one and was outputting 5.3v but I'll try see if I have another PSU so small

User avatar
mad_ady
Posts: 5664
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 9 times
Been thanked: 14 times
Contact:

Re: Snapping sound then no boot

Unread post by mad_ady » Fri Dec 28, 2018 4:23 am

There's also a posibility that the on-board power regulator is damaged. You can try to power it up via usb-otg or gpio (bypassing the regulator).

MajicM
Posts: 4
Joined: Thu Dec 27, 2018 9:01 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Snapping sound then no boot

Unread post by MajicM » Fri Dec 28, 2018 5:55 pm

Ah, right!

I have an OTG cable knocking around somewhere, I'll try it later!

Thanks

User avatar
mad_ady
Posts: 5664
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 9 times
Been thanked: 14 times
Contact:

Re: Snapping sound then no boot

Unread post by mad_ady » Fri Dec 28, 2018 6:26 pm

Actually you just need a microusb cable, for power.

MajicM
Posts: 4
Joined: Thu Dec 27, 2018 9:01 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Snapping sound then no boot

Unread post by MajicM » Fri Dec 28, 2018 8:02 pm

Success! Just powered it with USB and everything is working! Thank you so much :)

User avatar
mad_ady
Posts: 5664
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 9 times
Been thanked: 14 times
Contact:

Re: Snapping sound then no boot

Unread post by mad_ady » Fri Dec 28, 2018 8:53 pm

It's more efficient (the c2 runs cooler) with the barrel connector, so you should still investigate the psu.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest