[Solved] USB-UART and MC1-solo

Post Reply
Posts: 10
Joined: Mon Apr 15, 2019 7:09 pm
languages_spoken: english
Has thanked: 1 time
Been thanked: 1 time

[Solved] USB-UART and MC1-solo

Unread post by Chad » Fri Jan 10, 2020 1:12 am

TLDR; Use the proper voltage power supply and you have a much better chance of success.

I'm trying to use a USB-UART connected to the USB3 of an N2 to monitor u-boot on the MC1-solo.

The connection died within a few seconds after the boot up of the MC1 and the N2 is throwing errors like:
kernel: [ 83.836359@4] usb 2-1-port1: over-current condition
whenever the USB-UART is plugged in. It didn't do this until after I'd applied power to the MC1.

I purchased the USB-UART from Ameridroid April 2019 and the MC1-solo within the past week from Hardkernel.

I presume the USB-UART is now dead.

edit with more information...
I'm certain that this USB-UART is dead now. Plugging it into the N2 generates the messages above and knocks other USB3 devices off as well. Plugging it into a BeagleBone Black via a USB Hub causes the USB to go into failure mode, recovered by a reboot. I don't see any particular damage to the USB-UART, but when plugged in it no longer lights up as it did. Thankfully it hasn't destroyed the USB hosts.

edited to remove stupid comments and add tldr.
Last edited by Chad on Fri Jan 10, 2020 10:43 am, edited 2 times in total.

User avatar
Site Admin
Posts: 33687
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
Has thanked: 511 times
Been thanked: 507 times

Re: USB-UART and MC1-solo

Unread post by odroid » Fri Jan 10, 2020 10:32 am

It is compatible with the MC1.
But your USB-UART adapter IC seems to be damaged. Sorry about that.

We saw a few of CP2012N IC on the Rev-2 PCB PCB was weaker and we added a couple of components to the Rev-3 PCB to add a reverse current protection.
We started to produce the Rev-3 from 5~6 months ago.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 7 guests