Page 1 of 1

Odroid Xu4 - Flcikering Display and corrupted/green artifacts

Posted: Thu Jun 13, 2019 1:26 am
by cleverest@gmail.com
Hi Everyone,

A friend of mine's Odroid is having issues, using multiple HDMI cables and displays, even a TV...what happens is green dot and wiggly line artifacts, sometimes minor, other times major across boot screen, boot videos, and emulationstation GUI...

We are not sure what's causing it but suspect the actual HDMI port, but could it also be a power draw issue? It's annoying to say the least? Anyone have experience in dealing with this? What was your solution? What IS the usual solution? Thank you for any help!

Re: Odroid Xu4 - Flcikering Display and corrupted/green artifacts

Posted: Thu Jun 13, 2019 10:53 am
by odroid
Which OS image do you use?
Did you try our official Ubuntu OS image to narrow down root causes?
File name : ubuntu-18.04.1-4.14-mate-odroid-xu4-20181203.img.xz
https://wiki.odroid.com/odroid-xu4/os_i ... 4/20181203

Re: Odroid Xu4 - Flcikering Display and corrupted/green artifacts

Posted: Sat Jun 22, 2019 11:03 am
by cleverest@gmail.com
No, I'm using the latest TheRA (The Retro Arena BASE Image), it works fine on my own Odroid which is identical. Whenever I use any SD card with this image on his Odroid, including my working one (in my system) it doesn't work, and his card doesn't work in my Odroid...So I have to conclude it's his card + His Odroid...I'm not sure what else it could be.

Re: Odroid Xu4 - Flcikering Display and corrupted/green artifacts

Posted: Sat Jun 22, 2019 3:00 pm
by phaseshifter
you meed a 4 amp 5 volt supply for the xu4..i suspect that it is the ports or cables most likely ...

the hdmi ports can be troublesome i have seen this myself..often a wabble of the given cable at the port end can revive the connection fixing the screen issue...some times you need to unplug and replug the cable...i am guessing it is an issue with the sets tolerance,,,, to certain devices

Re: Odroid Xu4 - Flcikering Display and corrupted/green artifacts

Posted: Sat Jun 22, 2019 3:04 pm
by cleverest@gmail.com
I'm using a 6amp because I have a sata drive connected. Ya, I think it's certain displays/cables. :-(

Re: Odroid Xu4 - Flcikering Display and corrupted/green artifacts

Posted: Sat Jun 22, 2019 3:18 pm
by phaseshifter
i dont know the exact pinpoint fault but the hdmi sockets become lose or warn you might say and also the solder connection them selves become a problem...
if that is of any constellation..it`s not some thing that you can fix at home,,it may not even be a work shop fix either due to the surface mount type connections to the board it`s self..
.unless they are geared up with the tools to reseat the socket...also the socket`s pins may be at fault..not fixable..there just warn ..so a new socket would be the answer but getting somebody / workshop to do it becomes a problem...is it cost effective..comes into the equation....phase....

Re: Odroid Xu4 - Flcikering Display and corrupted/green artifacts

Posted: Sat Jun 22, 2019 3:21 pm
by phaseshifter
hdmi standards may also play a part and leads that are not matched to the correct standard of its hdmi socket input am the actual set it`s self...

it could come to the point that it is just a component board replacement the complete hdmi input board..
again is it cost effective,,

his card may be corrupt flash it with what odroid said use the official image to further diagnose the issues

also steer away from kingston sd-cards i have found them to fault on many occasions...

Re: Odroid Xu4 - Flcikering Display and corrupted/green artifacts

Posted: Mon Jun 24, 2019 10:06 am
by odroid
I think some portion of the HDMI output hardware seems to have a problem.
Please contact "odroid at hardkernel dot com" with a link of this post.
They will help your RMA process if you purchased the board from our web-store directly.
Otherwise, contact your local distributor/reseller.