USB 2.0 port doesn't work

Moderators: mdrjr, odroid

USB 2.0 port doesn't work

Unread postby bcd » Tue Jul 17, 2018 8:47 pm

On one of our XU4s the USB2.0 port doesn't work. I think it never did, but I'm not 100% sure. I've tried multiple products on the port (different USB drives, a UVC camera and a keyboard dongle) but nothing seems to work (no info or new lines on the UART console at all when I connect these things on the USB2.0 port). These products all work on the either one of the USB3.0 ports, and on other odroids XU4’s USB2.0 ports.

I also reinstalled the Android OS, both the official one and the newer Android 7.1 that we normally use (lineage-14.1/Alpha-1.8_15.04.18). But it still doesn't work. Could this be a hardware problem? Does anyone have any tips?

Btw, lsusb seems normal:
Code: Select all
$ lsusb
Bus 003 Device 002: ID 05e3:0610
Bus 004 Device 002: ID 05e3:0616
Bus 006 Device 003: ID 0bda:8153
Bus 001 Device 001: ID 1d6b:0002
Bus 002 Device 001: ID 1d6b:0001
Bus 003 Device 001: ID 1d6b:0002
Bus 004 Device 001: ID 1d6b:0003
Bus 005 Device 001: ID 1d6b:0002
Bus 006 Device 001: ID 1d6b:0003
bcd
 
Posts: 2
Joined: Sun Jun 25, 2017 11:39 pm
languages_spoken: english
ODROIDs: XU4

Re: USB 2.0 port doesn't work

Unread postby odroid » Wed Jul 18, 2018 8:54 am

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub must be USB 2.0 port on the XU4 board.

Can you show me lsusb -t output on the latest Ubuntu 18.04 image?
User avatar
odroid
Site Admin
 
Posts: 28853
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Issues

Who is online

Users browsing this forum: No registered users and 3 guests