segfault followed by inability to boot XU4

Moderators: mdrjr, odroid

segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Wed Feb 28, 2018 1:09 pm

Hi everyone,
I've been happily using my xu4 as a headless lamp server, with the native ubuntumate, among other things for about a year. Last night I was ssh'ed in doing some innocuous task (i think i was changing the permissions on a folder), when I got a segmentation fault error. I dont remember what exact command I issued before the error and sadly I didnt save the command line output. Following that, nothing done from the command line worked. I tried opening a new ssh session, connecting to a samba shared drive, accessing the server through a browser etc, even plugging it into a monitor. Nothing worked. The blue heartbeat LED was still pulsing, but i unplugged it, waited and plugged it back in. Now all i get is the red LED indicating it is receiving power.

Any ideas about how to fix this, or at least grab the settings from various folders (or clone the entire hard drive?) I'd like to retrieve some data and configurations, but understand if the only option is a clean wipe of the eMMC.

Thank you so much!
Sam

XU4, ubuntumate (relatively up to date), 64gb eMMC.
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Wed Feb 28, 2018 2:06 pm

If you updated the kernel to 4.14.x, you might need to check the UAS compatibility with your HDD enclosure.

Which kernel version do you run now?
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Wed Feb 28, 2018 3:29 pm

I havent updated too recently, looking at my last saved terminal output, i was running Ubuntu 16.04.3 LTS (GNU/Linux 3.10.104-126 armv7l). That was a while ago, but i dont think ive upgraded recently. Naturally I have no way of checking now, do I?
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Wed Feb 28, 2018 5:15 pm

Sorry. I overlooked your situation.

Connect your storages (eMMC and HDD) to other Linux PC and backup important data first.

And recovery your eMMC and freshly flash the latest OS image since it is really hard to know what happened in your system.
Recovery: viewtopic.php?f=53&t=6173
Latest Ubuntu: https://wiki.odroid.com/odroid-xu4/os_i ... 4/20171212
Flashing: https://wiki.odroid.com/troubleshooting ... s#flashing
eMMC reader: viewtopic.php?f=53&t=2725
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby rooted » Wed Feb 28, 2018 6:14 pm

Assuming it's the filesystem and not a bad eMMC you should be able to place it in the micro SD adapter and plug it into a PC and attempt a e2fsck scan and mount.
User avatar
rooted
 
Posts: 5458
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Thu Mar 01, 2018 1:48 am

Thank you guys. I will try to back it up. Using ubuntu on a vm didnt work, but i'll try a computer that dual boots. Thanks again!
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Thu Mar 01, 2018 2:33 pm

I created a bootable ubuntu drive, so I am on a linux pc, but I am unsure about how to back up my data. Can you please tell me how? Sorry for being ignorant.
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Thu Mar 01, 2018 3:20 pm

This is what i tried, perhaps stupidly. I ran lsblk and then plugged in my eMMC and ran it again to verify the correct drive. then i tried e2fsck /dev/sdc but just got "bad magic number in superblock..." and that it could not be read or doesnt have a valid ext2/ext3/ext4 filesystem.
lsblk only recognized the size of the eMMC as 30mb and it is 64gb. Is there any way to save any files or am i toast?
Thanks!
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Thu Mar 01, 2018 7:10 pm

If the eMMC is not mountable on your Linux PC, the partition table seems to be corrupted too much.
In that case, it is very hard to recover it with e2fsck command.
Freshly flash the OS image with Etcher and use this backup method for future trouble shooting.
viewtopic.php?f=52&t=22930
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby rooted » Thu Mar 01, 2018 7:31 pm

You may be able to recover some files with a raw recovery tool, what important things are you trying to recover?
User avatar
rooted
 
Posts: 5458
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Fri Mar 02, 2018 2:48 pm

config files for sickbeard, sabnzb etc. In the future, is there a way to clone the contents of the emmc, so that if this were to happen again i could just install from it and pick up where i left off? Its fun enough, but setting up the server again is a bit of a hassle...
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby rooted » Fri Mar 02, 2018 6:06 pm

All the standard backup methods work, personally I would just use dd but there are other methods.
User avatar
rooted
 
Posts: 5458
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Wed Jul 11, 2018 2:30 pm

Hi all, I have recently had time to try to solve this issue, but to no avail. I tried the recovery/flashing method posed by odroid, but it didnt work. Looking down the thread that was linked to, i saw that others had had similar results, where both the red and blue lights remained solid for at least an hour without any repair seeming to take place. Furthermore, I cant seem to be able to flash the os onto the emmc, it is not being recognized as having enough space. Could it be an adapter issue?
I gave up completely on recovering any data...
Any thoughts? I would be a bit frustrated if I needed a new emmc. It was expensive.
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Wed Jul 11, 2018 3:59 pm

What happened when you tried this recovery process?
viewtopic.php?f=53&t=6173
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Thu Jul 12, 2018 12:48 am

Like other posters on that page, upon plugging it in with both cards attached, the red and blue lights both came on, but remained that way overnight. The blue light never started flashing.
Thanks for helping!
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Thu Jul 12, 2018 8:05 am

Did you set the slide-switch to "uSD" boot mode?
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Thu Jul 12, 2018 10:44 am

Yes. Just the one switch on the xu4.
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Thu Jul 12, 2018 11:13 am

Ok. Let's check one by one.

Did you download this file and flashed it to your SD card with Etcher. You didn't need to uncompress the file.
Code: Select all
android-4.4.4-alpha-5.8-sd2emmc_installer-odroidxu4-20171026.img.zip


Can you also check md5sum value?
Code: Select all
7f449636c8d70a92599b3ae693078667  android-4.4.4-alpha-5.8-sd2emmc_installer-odroidxu4-20171026.img.zip
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Mon Jul 16, 2018 4:28 am

Hi odroid,
Yes, i had flashed the file you mentioned and upon checking, it had the same ms5sum value.
What's the next step?
Thanks!
Sam
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Mon Jul 16, 2018 4:44 am

I just performed the recovery process again, and both lights are still solid after many minutes.
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Mon Jul 16, 2018 11:56 am

Something seems to be broken in your hardware so far.
Flash this latest image to your SD card and try to boot it without eMMC module. The slide switch position must "uSD" mode.
https://wiki.odroid.com/odroid-xu4/os_images/linux/ubuntu_4.14/20180501

If it doesn't boot, some portion of DRAM or CPU could be damaged.
Try SD boot and let me know the result.
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Sun Jul 22, 2018 5:33 am

Hi,
Good news I guess- I tried with an sd card and got the blue heartbeat. I didn’t have a monitor to test whether it booted, but the heartbeat is a sign it worked I think. So now it’s down to the emmc. If there is any way to erase and reflash it i would really appreciate it. I would ideally use an emmc for its speed and don’t want to buy a new one.
Thanks!
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Mon Jul 23, 2018 9:24 am

Please try to connect your XU4 to a TV or monitor via HDMI cable to double check the functionality.

BTW, Do you have an eMMC reader or writer?
viewtopic.php?f=53&t=2725
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Tue Jul 31, 2018 1:07 pm

Hi,
I connected it and it works! yay :)

i use a SD to micro SD (i have both samsung and sandisk) connected to the uSD to eMMC reader that came from hardkernel. is that my issue? can I simply not write to my eMMC?

Thanks!
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Tue Jul 31, 2018 1:19 pm

My SD to micro-SD didn't work.
viewtopic.php?f=53&t=2725#p36556

Did you have any problem while flashing OS image with Etcher?
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Tue Jul 31, 2018 1:38 pm

I didnt have any problem with the uSD, but it didnt work with the eMMC. im not sure if this is because it cant write or the card is somehow corrupted
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby JustAnotherSam » Tue Jul 31, 2018 1:42 pm

Etcher doesn't recognize the eMMC as its proper size (only 24mb) so it wont write to it because of insufficient space.
JustAnotherSam
 
Posts: 16
Joined: Tue Nov 15, 2016 6:53 pm
languages_spoken: english

Re: segfault followed by inability to boot XU4

Unread postby odroid » Tue Jul 31, 2018 3:51 pm

I think you need a USB-to-microSD adapter(a card reader) since your PC SD slot doesn't work properly.
User avatar
odroid
Site Admin
 
Posts: 28610
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Issues

Who is online

Users browsing this forum: No registered users and 2 guests