Meanwell PSU with HC-1 makes little sounds, noise

Moderators: mdrjr, odroid

Meanwell PSU with HC-1 makes little sounds, noise

Unread postby Francisco » Fri Jan 26, 2018 5:49 pm

For general info:

I attached a Meanwell PSU (35W, 5V) to a HC-1 and it makes little
sounds, audible little beeps of different frequencies and rhythms.

(no sound when not connected to the HC-1)

Annoying.
Francisco
 
Posts: 11
Joined: Tue Sep 05, 2017 10:24 pm
languages_spoken: english
ODROIDs: HC1

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby phaseshifter » Fri Jan 26, 2018 6:03 pm

sounds like a bad component in the power supply..to be more precise a capacitor/s causing incorrect oscillation in the switching circuit once under load

if you have access to a cro put it on the supply output when it is under load you can then look at the voltage..a dmm might also show variances in the voltage it may not be regulating holding the voltage constant...

if the sound is coming from the HC-1 then that is somewhat odd..it may be reacting to the bad voltage from the supply..
i would plug a standard 4 amp 5 vol h-k or other vendors supply on the board and see if it makes any difference....

is this your supply..??

https://www.power-supplies-australia.co ... gKfd_D_BwE
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!
phaseshifter
 
Posts: 2967
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby odroid » Sun Jan 28, 2018 11:50 am

When there is no load, the PSU output current is near zero.
So there should be no noise from the bad PSU if you don't connect the HC1.
User avatar
odroid
Site Admin
 
Posts: 28837
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby Francisco » Tue Jan 30, 2018 1:43 am

The sound is coming from the PSU, and only then it is powering the HC-1.

Sorry, I have no cro.

Yes, the link pasheshifter provides is the PSU.

I have two solutions:
a) Separate a long distance the PSU from the HC-1 so I don't hear it. (Happily, the PSU has a regulator so I can adjust the HC-1 to receive a good voltage even through long cables).
b) Check for a replacement unit at the provider.

Thanks a lot and happy odroing.
Francisco
 
Posts: 11
Joined: Tue Sep 05, 2017 10:24 pm
languages_spoken: english
ODROIDs: HC1

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby Francisco » Thu Feb 08, 2018 5:55 am

The provider has told me the PSU is not faulty. He has given me a 4700 microF condenser but nothing changes.

The PSU makes similar sound powering another SBC, even charging a mobile phone.

It's the way switched PSU works.

If anyone wants to hear how does it sound, I've left a recording in
http://www.martin13.fr/flute-solo-psu-orchestra.wav

I'm going into option a)

Thanks a lot.
Francisco
 
Posts: 11
Joined: Tue Sep 05, 2017 10:24 pm
languages_spoken: english
ODROIDs: HC1

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby odroid » Thu Feb 08, 2018 9:03 am

I guess the noise comes from an inductor or transformer in the PSU.
User avatar
odroid
Site Admin
 
Posts: 28837
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby phaseshifter » Fri Feb 09, 2018 3:48 am

hmm..something there is not right..it`s very noisy when it should not be ..at all ... switch modes are like a dime a dozen and all are very quiet when running even under high load currents... that one should not have passed Q.C...

the capacitor that he gave you to put on the output is merely there to cover any voltage drops/ripple due to it`s poor switching ..and will have no effect on the switching part of the circuit..and wont have any effect as the fault is way back in the switching circuit part of the supply...

without me going into extreme detail it could be a loose ferrite-core in the transformer that is vibrating throwing off noise..but my self it`s not operating at correct frequency in the primary switching part of the circuit..
Build It And They Will Come...Be Bold And Mighty Forces Will Come To Your Aid..!!!
phaseshifter
 
Posts: 2967
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby edibg » Thu Feb 15, 2018 3:56 am

Just from curiosity what is the model of the PSU ?
I had similar issue when I first power on XU4, but the PSU(cheap generic China made) switching frequency was 1.8kHz that is within the hearing zone, bad output filter and causing XU4 power circuit to make strange noises.

Usually the PSU should use 30+ kHz frequency and hearing anything from it means bad quality ( cold solder, dried silicone/resin over the coils or bad coils at all).

I personally use Meanwell RS-25-5(100mV output voltage ripple, but in practice I measured it to be less than 20mV), whit my XU4 that is switching around 36kHz and stopped the heardbeat led, and governor to "on demand" @ 600MHz min(used as NAS) - silence, no coil noise, no fan noise.
I do not know the amperage requirements of HC-1, but I guess it is around 4A, so I can recommend you Meanwell GS-25E05-P1J that is even 50mV output ripple.
edibg
 
Posts: 5
Joined: Wed Jan 31, 2018 6:07 am
Location: Bulgaria
languages_spoken: english
ODROIDs: XU4

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby Francisco » Thu Feb 15, 2018 8:08 am

Meanwell LRS 35-5 (35W, 5 V)
The noise comes from the PSU, not from the HC-1.
The PSU works a very high frequency but armonics...
Noise is not controlled in the QC according to their technical docs.
I've written to Meanwell, I'm waiting the answer.
Thanks for your suggestion.
Francisco
 
Posts: 11
Joined: Tue Sep 05, 2017 10:24 pm
languages_spoken: english
ODROIDs: HC1

Re: Meanwell PSU with HC-1 makes little sounds, noise

Unread postby Francisco » Sat Aug 04, 2018 4:24 pm

As of today I've not gotten any answer from Meanwell. I forget this subject.
BTW;
I saw a review of a HP printer telling the PSU made little noises,... So I think it's a widespread design problem.
Francisco
 
Posts: 11
Joined: Tue Sep 05, 2017 10:24 pm
languages_spoken: english
ODROIDs: HC1


Return to Issues

Who is online

Users browsing this forum: No registered users and 4 guests