HC2 troubleshooting with 1.8V FT232RL

Post Reply
S1one
Posts: 7
Joined: Sat Jun 08, 2024 5:02 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

HC2 troubleshooting with 1.8V FT232RL

Post by S1one »

Hello

I'm trying to troubleshoot HC2 that work for many years.

I bought following 1.8/3.3/5V adapter with a switch https://www.amazon.co.uk/Converter-Adap ... B08TX3KTP1 based on FT232RL.

Would I be able to connect it to HC2's UART?

I connect using this instruction https://wiki.odroid.com/accessory/devel ... _connector
HC2 GND to GND on adapter,
HC2 TXD to RX on adapter,
HC2 RXD to TX on adapter,
When I connect HC2 VCC to 1.8 VCC on adapter and connect power supply, board doesn't turn on , no red led on.
I also connected TXD to TX and RXD to RX.

I run
screen/dev/ttyUSB0 115200

but no single sign shows when booted from sdcard, even without VCC connected(red led on, blue led blinks).

What I'm doing wrong?

Thanks

User avatar
odroid
Site Admin
Posts: 42645
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 3754 times
Been thanked: 2115 times
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by odroid »

As described in the WiKi page https://wiki.odroid.com/accessory/devel ... _connector

Code: Select all

The VCC pin is not a power source but a reference voltage input.
It is used for detecting the IO voltage like a VIO or a VDDIO.
Support for I/O interface voltages down to 1.8 V is provided via a VIO pin.
Therefore, you should not connect the VCC pin if you don't use our original USB-UART adapter.
Once you set the interface voltage to 1.8V with the slide switch on your RT232RL adapter, just three wires GND, TXD and RXD connecting should be enough.
If you post a couple of pictures of how you connected the wiring, we might be able to give you some additional advice.

S1one
Posts: 7
Joined: Sat Jun 08, 2024 5:02 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by S1one »

Hi

Please find photos attached.
20240608_080021.jpg
20240608_080021.jpg (296.67 KiB) Viewed 364 times
20240608_075941.jpg
20240608_075941.jpg (386.78 KiB) Viewed 364 times

User avatar
odroid
Site Admin
Posts: 42645
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 3754 times
Been thanked: 2115 times
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by odroid »

You should swap the RXD and TXD lines.

S1one
Posts: 7
Joined: Sat Jun 08, 2024 5:02 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by S1one »

Hello

Thank you for your help.
I swapped RXD with TXD, but cannot connect while booting with screen or minicom.
I checked voltage with multimeter and power supply gives little above 12V.
Led red and green turn on, blue turns on, starts double blinking few times and finally it stops.
Checked voltage on TXD jumps to around -1V while blue led blinks, then drops to 0.
On receiving part RX during boot from 0.32V to -0.36V, stabilise at 0V.
This adapter has TX and RX LEDs, but they don't blink at all. I only got them to blink when connecting connectors on powered board, which causes random characters on minicom.

Is my odroid broken or adapter?

User avatar
mad_ady
Posts: 12098
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4 (HC1, HC2), C1+, C2, C4 (HC4), N1, N2, N2L, H2, H3+, Go, Go Advance, M1, M1S
Location: Bucharest, Romania
Has thanked: 663 times
Been thanked: 1322 times
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by mad_ady »

You can validate that your adapter works by disconnecting it from the odroid, and connecting its RX to its TX, thus creating a loopback connection.
If you start minicom (though I prefer screen /dev/ttyUSB0 115200). Anything you type in the terminal should be visible (echoed) on screen.

S1one
Posts: 7
Joined: Sat Jun 08, 2024 5:02 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by S1one »

Thanks @mad_ady.
I created loop as suggested and as soon as I type it appears on screen.
Which suggests faulty odroid.
It's just that those voltages and LEDs activity are surprising.
I would buy odroid's UART adapter https://www.odroid.co.uk/odroid-usb-uart, but because of low value fee price jumps from £12 to £27.64.
Tried to find it on Amazon, eBay or Facebook marketplace, but no luck.

User avatar
mad_ady
Posts: 12098
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4 (HC1, HC2), C1+, C2, C4 (HC4), N1, N2, N2L, H2, H3+, Go, Go Advance, M1, M1S
Location: Bucharest, Romania
Has thanked: 663 times
Been thanked: 1322 times
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by mad_ady »

Here's another experiment to try. Connect only GND between Odroid and your adapter, and RX from the adapter to Odroid's TX. Connect to the adapter with screen, as before and power on the odroid. You should see uboot messages, even if your adapter isn't rated for 1.8V.

S1one
Posts: 7
Joined: Sat Jun 08, 2024 5:02 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by S1one »

No luck with this one.

LEDs as described earlier, but no boot.

I tried new 64GB SDcard , but not really sure which Linux image I should use for HC2: https://wiki.odroid.com/odroid-xu4/os_i ... inux/start
Old Release (3.10.y) - Ubuntu 16.04 (20170731) ?

I don't remember which one I used back in 2020.

User avatar
odroid
Site Admin
Posts: 42645
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 3754 times
Been thanked: 2115 times
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by odroid »

Flash the latest OS image into your new SD card.
https://wiki.odroid.com/odroid-xu4/os_i ... l/20240506

Check the LEDs on your HC2 board with the SD card,
The red LED must be on and the blue LED must be blinking like heartbeat if the OS is running.

S1one
Posts: 7
Joined: Sat Jun 08, 2024 5:02 am
languages_spoken: english
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: HC2 troubleshooting with 1.8V FT232RL

Post by S1one »

Wasn't aware I can use latest OS image.

After flashing with ubuntu-24.04-6.6-minimal-odroid-xu4-20240506.img.xz system boots and I can access it over ssh.
Updating it now.

Too bad I couldn't get that adapter working, will try again.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest