usb 3.0 not working anymore on odroid xu4

Post Reply
proxymo
Posts: 44
Joined: Fri May 26, 2017 11:16 pm
languages_spoken: english
ODROIDs: xu4
Has thanked: 0
Been thanked: 2 times
Contact:

usb 3.0 not working anymore on odroid xu4

Post by proxymo »

Hi,

Does powering the odroid xu4 via con10 pin1 and pin2 bypass the power to usb 3.0 hub?

The usb 3.0 ports do not seem to work anymore.

lsusb -t | grep xhci returns:

/: Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
/: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M

which indicates that usb 3.0 are operating (5000M)


dmesg | grep usb3
[ 1.160620] exynos5_usb3drd_phy 12100000.phy: 12100000.phy supply vbus not found, using dummy regulator
[ 1.160735] exynos5_usb3drd_phy 12100000.phy: 12100000.phy supply vbus-boost not found, using dummy regulator
[ 1.161132] exynos5_usb3drd_phy 12500000.phy: 12500000.phy supply vbus not found, using dummy regulator
[ 1.161238] exynos5_usb3drd_phy 12500000.phy: 12500000.phy supply vbus-boost not found, using dummy regulator
[ 3.536727] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.04
[ 3.544712] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 3.551891] usb usb3: Product: xHCI Host Controller
[ 3.556728] usb usb3: Manufacturer: Linux 5.4.87-218 xhci-hcd
[ 3.562456] usb usb3: SerialNumber: xhci-hcd.8.auto

mad_ady
Posts: 9049
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 595 times
Been thanked: 573 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by mad_ady »

If you have a multimeter, see if the usb port has 5V power.

proxymo
Posts: 44
Joined: Fri May 26, 2017 11:16 pm
languages_spoken: english
ODROIDs: xu4
Has thanked: 0
Been thanked: 2 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by proxymo »

Oviously there is not power.

proxymo
Posts: 44
Joined: Fri May 26, 2017 11:16 pm
languages_spoken: english
ODROIDs: xu4
Has thanked: 0
Been thanked: 2 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by proxymo »

Well, I downloaded and compiled this nice utility: https://github.com/heiher/hubpower/blob ... hubpower.c
and checked the status and when checking the status of Bus4:dev1 and Bus6:dev1 which belong to usb3 I get:
Error in ioctl (read hub descriptor): Broken pipe
so definetely there is not power.

in dmesg:

xhci-hcd xhci-hcd.9.auto: Wrong hub descriptor type for USB 3.0 roothub

mad_ady
Posts: 9049
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 595 times
Been thanked: 573 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by mad_ady »

Is usb2 still working? Both on the usb2 and usb3 ports? Is ethernet still working?

proxymo
Posts: 44
Joined: Fri May 26, 2017 11:16 pm
languages_spoken: english
ODROIDs: xu4
Has thanked: 0
Been thanked: 2 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by proxymo »

Yes, usb2 and ethernet are still working.
The problem is that lsusb does not return the genesys controller:

Bus 006 Device 002: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

User avatar
odroid
Site Admin
Posts: 36385
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1431 times
Been thanked: 980 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by odroid »

The USB 3.0 hub controller seems to be damaged. :(

mad_ady
Posts: 9049
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 595 times
Been thanked: 573 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by mad_ady »

In this case aren't the usb3 ports running as usb2 (with usb2 devices plugged in)? I'm curious...
Is ethernet throughput reaching 1Gbps, or is it limited to 3-400Mbps?

User avatar
odroid
Site Admin
Posts: 36385
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1431 times
Been thanked: 980 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by odroid »

lsusb -t will tell us more information.

proxymo
Posts: 44
Joined: Fri May 26, 2017 11:16 pm
languages_spoken: english
ODROIDs: xu4
Has thanked: 0
Been thanked: 2 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by proxymo »

Code: Select all

root@odroid:~# lsusb -t
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=r8152, 5000M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=exynos-ohci/3p, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=exynos-ehci/3p, 480M
Seems to be on usb3 and eth speed is 1000Mb/s
Last edited by proxymo on Mon Jan 11, 2021 3:56 pm, edited 1 time in total.

User avatar
odroid
Site Admin
Posts: 36385
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1431 times
Been thanked: 980 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by odroid »

1GbE LAN port is okay and all the root 2.0 & 3.0 hubs in the CPU are still alive while the external USB 3.0 hub IC is dead.

proxymo
Posts: 44
Joined: Fri May 26, 2017 11:16 pm
languages_spoken: english
ODROIDs: xu4
Has thanked: 0
Been thanked: 2 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by proxymo »

And I guess, now I have to organize another funeral.
These users thanked the author proxymo for the post:
odroid (Mon Jan 11, 2021 3:59 pm)

mad_ady
Posts: 9049
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 595 times
Been thanked: 573 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by mad_ady »

I recommend a viking burrial at sea...
Though your xu4 is less broken than others I've seen...

proxymo
Posts: 44
Joined: Fri May 26, 2017 11:16 pm
languages_spoken: english
ODROIDs: xu4
Has thanked: 0
Been thanked: 2 times
Contact:

Re: usb 3.0 not working anymore on odroid xu4

Post by proxymo »

No, the funeral is for the GL3521.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest