HDD won't stay in standby ("reset SuperSpeed USB device")

Post Reply
xeno103
Posts: 2
Joined: Fri Oct 05, 2018 4:24 pm
languages_spoken: english, korean
ODROIDs: HC-2
Has thanked: 0
Been thanked: 0
Contact:

HDD won't stay in standby ("reset SuperSpeed USB device")

Post by xeno103 »

The WD Red 4TB 3.5" HDD I connected to my new HC2 keeps spinning up every few minutes after it's been put in standby.

For the first couple of days after I installed the drive, the Load Cycle Count kept increasing regularly at a rate of roughly once every 10 minutes. At this point, the drive was brand new, and wasn't used or filled at all other than being formatted to ext4.

So I looked through the wiki, and updated the JMS578 firmware with the spindown timer disabled (-t 0), which put a stop to the Load Cycle Count increasing. But standby or sleep commands using hdparm still don't seem to stick, with the drive inevitably waking up after a few minutes.

So I googled the issue and tried the following:

Code: Select all

# sync
# echo 1 > /proc/sys/vm/block_dump
# dmesg -c | grep '/dev/sda'
This showed that a "reset SuperSpeed USB device using xhci-hcd" error occurs after all or most of the unwanted spinups. The PSU I'm using is the one supplied by the Hardkernel store when I purchased the HC2.

Code: Select all

odroid@odroid:~$ dmesg
[28844.036434] sd 0:0:0:0: [sda] tag#0 uas_eh_abort_handler 0 uas-tag 1 inflight: CMD
[28844.036443] sd 0:0:0:0: [sda] tag#0 CDB: opcode=0x85 85 06 20 00 00 00 00 00 00 00 00 00 00 00 e5 00
[28844.052436] scsi host0: uas_eh_device_reset_handler start
[28844.180561] usb 4-1: reset SuperSpeed USB device number 2 using xhci-hcd
[28844.202270] scsi host0: uas_eh_device_reset_handler success
[28844.202390] sd 0:0:0:0: [sda] tag#0 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x0e
[28844.202398] sd 0:0:0:0: [sda] tag#0 Sense Key : 0x0 [current] [descriptor]
[28844.202404] sd 0:0:0:0: [sda] tag#0 ASC=0x0 ASCQ=0x1d
[28844.202411] sd 0:0:0:0: [sda] tag#0 CDB: opcode=0x85 85 06 20 00 00 00 00 00 00 00 00 00 00 00 e5 00
Other than that, I've tried disabling the WD idle3 timer.

Code: Select all

odroid@odroid:~$ sudo idle3ctl -g103 --force /dev/sda
Idle3 timer is disabled
And I edited /etc/smartd.conf so that the only uncommented line is the following, to no avail.

Code: Select all

/dev/sda -a -d sat -n standby,15,q
Other than this specific issue, I'm not experiencing any immediate problems with the performance or stability of the drive. I just finished using rsync to transfer 3TB worth of data to the drive in question from another new WD Red 4TB that I hooked up to the HC2's USB2.0 port. I didn't experience any interruptions and the speed remained around 20MB/s throughout.

Below is some basic info I've seen requested in similar threads.

Code: Select all

odroid@odroid:~$ uname -a
Linux odroid 4.14.73-149 #1 SMP PREEMPT Sun Sep 30 23:32:27 -03 2018 armv7l armv7l armv7l
GNU/Linux

Code: Select all

odroid@odroid:~/JMS578FwUpdater$ sudo ./JMS578FwUpdate -d /dev/sda -v
Bridge Firmware Version: v173.1.0.1

Code: Select all

odroid@odroid:~$ fdisk -l | grep sd
Disk /dev/sda: 3.7 TiB, 4000787030016 bytes, 7814037168 sectors
Partition 1 does not start on physical sector boundary.
Disk /dev/sdb: 3.7 TiB, 4000787030016 bytes, 7814037168 sectors
/dev/sdb1     34      32767      32734   16M Microsoft reserved
/dev/sdb2  32768 7814033407 7814000640  3.7T Microsoft basic data

Code: Select all

odroid@odroid:~$ lsusb -t
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=r8152, 5000M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=uas, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=exynos-ohci/3p, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=exynos-ehci/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=uas, 480M
This is my first real dive into the linux world so everything's new, and I'm learning a lot through this troubleshooting process, but at this point I'd really appreciate some guidance. I want to be certain that the system will work reliably, and this whole situation isn't very reassuring.

Darkhand
Posts: 15
Joined: Wed Nov 04, 2015 11:03 pm
languages_spoken: english
ODROIDs: XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: HDD won't stay in standby ("reset SuperSpeed USB device"

Post by Darkhand »

Try disabling smartd and see if you still have the spinups. smartd can act funky with USB drives since the controllers don't follow the ATA spec very well.

If that solves it, how do you have it configured? You can also try reducing the default smartd polling time by editing the /etc/default/smartmontools file.

Uncomment:

Code: Select all

#smartd_opts="--interval=1800"
and change the interval (in seconds) to how often you want smartd to check the disk.

xeno103
Posts: 2
Joined: Fri Oct 05, 2018 4:24 pm
languages_spoken: english, korean
ODROIDs: HC-2
Has thanked: 0
Been thanked: 0
Contact:

Re: HDD won't stay in standby ("reset SuperSpeed USB device"

Post by xeno103 »

I just tried disabling smartd and then putting the drive on standby, but it still spins up ten minutes later.
I also discovered that putting the drive to sleep yields the "reset SuperSpeed..." error, while putting it on standby doesn't.

The following are the commands I wrote and the results I got.
Please feel free to point out anything I may have missed or could still attempt.

Code: Select all

odroid@odroid:~$ sudo smartctl -a -d sat /dev/sda | grep 193
193 Load_Cycle_Count        0x0032   200   200   000    Old_age   Always       -       299

odroid@odroid:~$ sudo service smartd stop
odroid@odroid:~$ sudo systemctl disable smartd.service
odroid@odroid:~$ dmesg
odroid@odroid:~$ sudo hdparm -y /dev/sda

/dev/sda:
 issuing standby command
I waited 10 minutes and got the following result.

Code: Select all

odroid@odroid:~$ sudo hdparm -C /dev/sda

/dev/sda:
 drive state is:  active/idle
odroid@odroid:~$ dmesg
odroid@odroid:~$ sudo smartctl -a -d sat /dev/sda | grep 193
193 Load_Cycle_Count        0x0032   200   200   000    Old_age   Always       -       300
Perhaps more importantly, the following is what I got when I tried putting the drive to sleep instead of standby.

Code: Select all

odroid@odroid:~$ sudo hdparm -Y /dev/sda

/dev/sda:
 issuing sleep command
odroid@odroid:~$ sudo hdparm -C /dev/sda

/dev/sda:
SG_IO: bad/missing sense data, sb[]:  70 00 02 00 00 00 00 0a 00 00 00 00 04 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 drive state is:  unknown
odroid@odroid:~$ dmesg
[63328.039649] sd 0:0:0:0: [sda] tag#0 uas_eh_abort_handler 0 uas-tag 1 inflight: CMD
[63328.039659] sd 0:0:0:0: [sda] tag#0 CDB: opcode=0x85 85 06 20 00 00 00 00 00 00 00 00 00 00 40 e5 00
[63328.055646] scsi host0: uas_eh_device_reset_handler start
[63328.183787] usb 4-1: reset SuperSpeed USB device number 2 using xhci-hcd
[63328.205604] scsi host0: uas_eh_device_reset_handler success
[63328.205724] sd 0:0:0:0: [sda] tag#0 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x0e
[63328.205731] sd 0:0:0:0: [sda] tag#0 Sense Key : 0x0 [current] [descriptor]
[63328.205737] sd 0:0:0:0: [sda] tag#0 ASC=0x0 ASCQ=0x1d
[63328.205744] sd 0:0:0:0: [sda] tag#0 CDB: opcode=0x85 85 06 20 00 00 00 00 00 00 00 00 00 00 40 e5 00
odroid@odroid:~$ sudo smartctl -a -d sat /dev/sda | grep 193
193 Load_Cycle_Count        0x0032   200   200   000    Old_age   Always       -       301
Is this a hardware defect? If so, will I be able to get an exchange or refund on this?

mad_ady
Posts: 8820
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 586 times
Been thanked: 529 times
Contact:

Re: HDD won't stay in standby ("reset SuperSpeed USB device"

Post by mad_ady »

It doesn't look like a drive fault. I assume there is no process writing data to the disk behind your back (like rtorrent, etc), right? There may be processes which try to monitor disk health parameters (like temperature) that run periodically. I had munin and webmin try to read temperature from the disk which caused the disk to spin up. Smartmontools might do it as well. Try disabling such tools and see if it helps.
There may also be programs that periodically scan a directory for changes (though they should be using inotify instead).

Lipown
Posts: 1
Joined: Sun Nov 22, 2020 6:54 am
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: HDD won't stay in standby ("reset SuperSpeed USB device")

Post by Lipown »

How you had solved it please? I have the same issue.

User avatar
odroid
Site Admin
Posts: 35871
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean
ODROIDs: ODROID
Has thanked: 1316 times
Been thanked: 910 times
Contact:

Re: HDD won't stay in standby ("reset SuperSpeed USB device")

Post by odroid »

Lipown wrote:
Sun Nov 22, 2020 6:55 am
How you had solved it please? I have the same issue.
Which kernel version and OS image do you use?

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest