Did my HC2 break after half a week?

Post Reply
Patagonicus
Posts: 3
Joined: Sat Jun 20, 2020 4:11 pm
languages_spoken: english,german
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Did my HC2 break after half a week?

Post by Patagonicus » Sat Jun 20, 2020 4:33 pm

I got an HC2 on Wednesday and now it consistently hangs at boot. Is this a hardware defect?

I'm using an HC2 bought from Hardkernel directly together with a power supply and Hardkernel's USB UART adapter. For MicroSD cards I'm using Sandisk Extreme Pro 32GB, of which I bought multiple new ones. The system worked fine for a couple of days. I had a SATA SSD connected to it for a bit, but I've since disconnected it.

Since it stopped booting I've reformatted the MicroSD cards with the official Ubuntu 18.04 (both minimal and Mate) and Armbian Buster and Focal, but none of them have been able to boot fully.

For Ubuntu it looks normal for about ~3s into the boot process, then nothings logged for a bit and at 15s I get messages about thermal zones and device-mapper, then nothing, even when waiting >5 minutes. For Armbian Buster it's quite after "Starting Kernel ...", but I get "[ 15.208724] Internal error: Oops - undefined instruction: 0 [#1] PREEMPT" (also with a 15s timestamp, which I find suspicious). For Armbian Focal it hangs after "Starting Kernel ...". I've attached the full log for the Ubuntu boot.

Does anyone have an idea what the problem might be? Or what else I can do to debug this? I really like the idea of the HC2 and was going to build a setup with multiple of them after evaluating it, but this is not looking very promising. Sending it for RMA isn't really an option (and I knew this when ordering, but I didn't think it was going to break that quickly) - I was going to buy further units from local suppliers, but got the first one from Hardkernel directly to get the UART and case as well which weren't available locally.
Attachments
boot.log
(19.31 KiB) Downloaded 14 times

User avatar
odroid
Site Admin
Posts: 34562
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 809 times
Been thanked: 700 times
Contact:

Re: Did my HC2 break after half a week?

Post by odroid » Mon Jun 22, 2020 11:14 am

I think all of the thermal sensors in the SoC were damaged by uncertain root causes.
I've never seen this phenomenon.
We will contact you soon.

Patagonicus
Posts: 3
Joined: Sat Jun 20, 2020 4:11 pm
languages_spoken: english,german
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: Did my HC2 break after half a week?

Post by Patagonicus » Tue Jun 23, 2020 2:59 am

Thanks! Since you mention the thermal sensors: do you think it might have been overheating? I remember the machine no longer accepting SSH connections and then rebooting it. But at that point it had been running for at least half a day and, I think, was idling. It was also sitting on my desk with some space around it, so overheating sounds unlikely to me.

I'll report back once the replacement has arrived, but I'm pretty sure that the rest (power supply, SD card) is ok.

User avatar
odroid
Site Admin
Posts: 34562
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 809 times
Been thanked: 700 times
Contact:

Re: Did my HC2 break after half a week?

Post by odroid » Tue Jun 23, 2020 9:11 am

I don't think so.
I hope you can have a test result within few days.

Patagonicus
Posts: 3
Joined: Sat Jun 20, 2020 4:11 pm
languages_spoken: english,german
ODROIDs: HC2
Has thanked: 0
Been thanked: 0
Contact:

Re: Did my HC2 break after half a week?

Post by Patagonicus » Mon Jun 29, 2020 10:36 pm

So, the replacement unit arrived on Friday. It has been working fine since then and I was compiling a lot of stuff on it (~100% load for hours at a time). It runs with all three of my SD cards and various images. Seems like I really just got unlucky with the first one. Thanks for handling this so quickly and easily!

User avatar
odroid
Site Admin
Posts: 34562
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 809 times
Been thanked: 700 times
Contact:

Re: Did my HC2 break after half a week?

Post by odroid » Tue Jun 30, 2020 9:06 am

Glad to hear that. :D

If you don't mind, please send us the broken unit for our failure analysis.
Any slow and cheap shipment would be fine.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 6 guests