[SOLVED] XU4 not fully booting from eMMC

Moderators: mdrjr, odroid

[SOLVED] XU4 not fully booting from eMMC

Unread postby Faroul » Mon Aug 20, 2018 2:39 am

Hi,

I had my XU4 running a long time on debian as a little ftp-server for my projects, system on eMMC, ftp-data on a SSD connected via USB3. Runs well for years.

Now while talking to a friend, we agreed to having a vice-versa "remote-backup" (both at a 200Mbit line), so I got a new SSD and a USB3-case and connected it to the second USB3-Port. Setup worked well, but as I copied a larger file via Samba for testing, the odriod froze.
I restarted, froze again on copying.
So I disconnected the new SSD and tried to reboot again - nothing, not avail via SSH (I don't have a monitor and keyboard connected usually).

So I connected it to a monitor. It boots up, shoing the usual messages, but I don't get a login-prompt.

Even connecting a USB keyboard is logged in console, but I cannot type anything...

I set up a µSD with a clean armbian, the odriod works for now (did not connect anything else than monitor, keyboard and network yet), but I cannot find a way to read any data from the eMMC card, not on windows (using extfs-drivers) nor on the odriod (looks like the "usb mass storage" is recognized as such, but no device to mount), nothing show up with eMMC connected directly.

As the eMMC is obviously not totally broken, any way to read data from it? Some settings etc would be nice to restore (yes, I forgot backups, shame on me) or any other idea to recover full boot of the eMMC?

Thanks

Faroul
Faroul
 
Posts: 3
Joined: Mon Aug 20, 2018 1:36 am
languages_spoken: english german
ODROIDs: XU4

Re: XU4 not fully booting from eMMC

Unread postby odroid » Mon Aug 20, 2018 10:05 am

Do you have an eMMC compatible reader/adapter?
viewtopic.php?f=53&t=2725
User avatar
odroid
Site Admin
 
Posts: 28853
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: XU4 not fully booting from eMMC

Unread postby Faroul » Tue Aug 21, 2018 5:27 am

OMG - it was just the fucking USB-SDCard-Adapter....
I digged my ole USB2 adapter and it works (the FAT32 Boot parition show up), and using paragons LinuxFS I can read all files.

Thanks for that hint *blush*

Now I can save all files, and think of a good backup-solution...

I found that thread about backups in here, but maybe I'll do just some rsync of the configs and some files - anything else isn't really important to backup :)

Thanks for your help!
Faroul
 
Posts: 3
Joined: Mon Aug 20, 2018 1:36 am
languages_spoken: english german
ODROIDs: XU4

Re: [SOLVED] XU4 not fully booting from eMMC

Unread postby odroid » Tue Aug 21, 2018 9:19 am

Glad to hear you found a compatible adapter. :)
User avatar
odroid
Site Admin
 
Posts: 28853
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [SOLVED] XU4 not fully booting from eMMC

Unread postby Faroul » Thu Aug 23, 2018 5:18 am

Just for your records which might help: it's a "LogiLink CR0007"; cheap, USB2, but works :)
Faroul
 
Posts: 3
Joined: Mon Aug 20, 2018 1:36 am
languages_spoken: english german
ODROIDs: XU4


Return to Issues

Who is online

Users browsing this forum: No registered users and 3 guests