Problem with shutdown

Moderators: mdrjr, odroid

Problem with shutdown

Unread postby Cestunange » Sun Jan 07, 2018 8:32 pm

Hi,
I didn't find a solution in this forum or any other yet.

The shutdown procedure is stopped at a black screen with a cursor. The power stays on and the card is hot.

When I tried "stand by", I can't awake the card with the mouse or the keyboard.

When I want to reboot, it's the same that the power off, only a black screen with cursor.

Any solutions ?

Thanks
Cestunange
 
Posts: 8
Joined: Fri Jan 05, 2018 3:15 am
languages_spoken: english, french
ODROIDs: XU4
Ubuntu 16.04 LTS
Linux odroid 4.14.12-98 #1 armv7

Re: Problem with shutdown

Unread postby odroid » Mon Jan 08, 2018 10:33 am

I saw a similar shutdown issue very rarely. Less than 1 time per ~100 shutdowns.
But after updating to kernel 4.14.6 or higher, I've never met the issue.
I'm also running 4.14.12 now.

Do you meet the issue every shutdown?
Which USB devices and power supply do you use?
User avatar
odroid
Site Admin
 
Posts: 28267
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Problem with shutdown

Unread postby Cestunange » Fri Jan 12, 2018 8:03 pm

Hi,

Yes I have the same issue every shutdown.

I have a bluetooth adaptater and a wifi (TP-Link tl-wn725n) adaptater plugged with USB.
The power supply is CWT AC adaptater KPC-020B (output: 5V-4A
Do you think the power is not enough ?

The WI-Fi is not working... another problem.
lsusb command :
Code: Select all
odroid@odroid:~$ sudo lsusb
[sudo] Mot de passe de odroid :
Bus 006 Device 002: ID 0bda:8153 Realtek Semiconductor Corp.
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 05e3:0616 Genesys Logic, Inc. hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 003 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Cestunange
 
Posts: 8
Joined: Fri Jan 05, 2018 3:15 am
languages_spoken: english, french
ODROIDs: XU4
Ubuntu 16.04 LTS
Linux odroid 4.14.12-98 #1 armv7

Re: Problem with shutdown

Unread postby odroid » Sat Jan 13, 2018 10:27 am

RTL8188EUS driver might not be enabled in Kernel 4.14.
You have to build your own kernel.

If you have a DMM, measure voltage on the 5V rail of 30pin header to check your power supply.
It must be stable at 4.8V~5.2V.
https://wiki.odroid.com/odroid-xu4/hard ... connectors
User avatar
odroid
Site Admin
 
Posts: 28267
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Problem with shutdown

Unread postby Cestunange » Mon Jan 15, 2018 5:26 am

Ok, I resolved my Wi-Fi problem by buying a new one ! TL-WN823N. It's working and seems stable after a tiny configuration in command line...

I don't have a DMM, I don't know how to measure the power.

I flashed my eMMC, so I hope my kernel and Mate is clean. But I have the same shutdown issue...

Thanks for your help.
Cestunange
 
Posts: 8
Joined: Fri Jan 05, 2018 3:15 am
languages_spoken: english, french
ODROIDs: XU4
Ubuntu 16.04 LTS
Linux odroid 4.14.12-98 #1 armv7

Re: Problem with shutdown

Unread postby odroid » Mon Jan 15, 2018 9:46 am

What is the PCB color of your eMMC?
https://wiki.odroid.com/accessory/emmc/reference_chart

Also let me know your current kernel version.
Mine is
Code: Select all
odroid@odroid:~$ uname -a                                                                                                                 
Linux odroid 4.14.13-100 #1 SMP PREEMPT Fri Jan 12 19:09:58 UTC 2018 armv7l armv7l armv7l GNU/Linux
User avatar
odroid
Site Admin
 
Posts: 28267
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Problem with shutdown

Unread postby Cestunange » Fri Jan 19, 2018 10:43 pm

I think I have eMMC 5.1.
There is a stick on it with 32 written but I can see the logo in the corner like the 5.1v.

The uname command :
Linux odroid 4.14.5-92 #1 SMP PREEMPT Mon Dec 11 15:48:15:UTC 2017 armv7l armv7l armv7l GNU/Linux

Thanks
Cestunange
 
Posts: 8
Joined: Fri Jan 05, 2018 3:15 am
languages_spoken: english, french
ODROIDs: XU4
Ubuntu 16.04 LTS
Linux odroid 4.14.12-98 #1 armv7

Re: Problem with shutdown

Unread postby odroid » Fri Jan 19, 2018 11:01 pm

Refer this link to update your system software.
https://wiki.odroid.com/odroid-xu4/os_i ... st-upgrade
User avatar
odroid
Site Admin
 
Posts: 28267
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Problem with shutdown

Unread postby Cestunange » Sat Jan 20, 2018 11:13 pm

I have an issue. First time...
Code: Select all
odroid@odroid:~$ sudo apt upgrade
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?


Should I try with Software Updater ?
Cestunange
 
Posts: 8
Joined: Fri Jan 05, 2018 3:15 am
languages_spoken: english, french
ODROIDs: XU4
Ubuntu 16.04 LTS
Linux odroid 4.14.12-98 #1 armv7

Re: Problem with shutdown

Unread postby Cestunange » Sat Jan 20, 2018 11:27 pm

Ok. After a restart, problem update solved.

And uname :
Code: Select all
Linux odroid 4.14.13-100 #1 SMP PREEMPT Fri Jan 12 19:09:58 UTC 2018 armv7l armv7l armv7l GNU/Linux


But no changes for the shutdown yet.
Reboot is good.
Suspend is quit good : it shuts properly down, only red LED is on and a few consumption of power (heatsink is gently warm). But impossible to start with keyboard, mouse or power button, I have to unplug it...
When I try to shutdown. it shuts down, stays with the black screen, only the red LED is on and lots of power consumption, the heatsink is hot. So I have to unplug...
Cestunange
 
Posts: 8
Joined: Fri Jan 05, 2018 3:15 am
languages_spoken: english, french
ODROIDs: XU4
Ubuntu 16.04 LTS
Linux odroid 4.14.12-98 #1 armv7

Re: Problem with shutdown

Unread postby odroid » Sun Jan 21, 2018 3:01 pm

Suspend/sleep function should not work properly due to some missing features in the Kernel.
Please run poweroff command on the terminal for shutdown and let me know the result.
After "poweroff", the current is less than 2mA even the red LED is still on.

Do you have a USB-UART kit?
If yes, please capture the kernel log while it runs the shutdown process.
User avatar
odroid
Site Admin
 
Posts: 28267
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Problem with shutdown

Unread postby Cestunange » Sat Jan 27, 2018 10:22 pm

The result is the same that I described before. It seems like the reel power off is when I suspend it...

Sorry, I don't have a USB-UART kit.

Thanks
Cestunange
 
Posts: 8
Joined: Fri Jan 05, 2018 3:15 am
languages_spoken: english, french
ODROIDs: XU4
Ubuntu 16.04 LTS
Linux odroid 4.14.12-98 #1 armv7

Re: Problem with shutdown

Unread postby phaseshifter » Sat Jan 27, 2018 10:34 pm

pls run this code first..
Code: Select all
apt update && apt upgrade && apt dist-upgrade


after that if the problem still occurs can you try reflash your emmc..with the latest image.20171212.????

https://wiki.odroid.com/odroid-xu4/os_i ... buntu_4.14
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2854
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Problem with shutdown

Unread postby Cestunange » Sun Jan 28, 2018 7:52 pm

I did the update and I reflashed the eMMC with 20171212... twice...
Cestunange
 
Posts: 8
Joined: Fri Jan 05, 2018 3:15 am
languages_spoken: english, french
ODROIDs: XU4
Ubuntu 16.04 LTS
Linux odroid 4.14.12-98 #1 armv7

Re: Problem with shutdown

Unread postby odroid » Mon Jan 29, 2018 10:01 am

If the "poweroff" command doesn't work properly with Kernel 4.14.9(or higher), your XU4 seems to have a hardware issue.
Please contact "odroid at hardkernel dot com" with a link of this thread.
She will help your RMA process if you purchased the board from us directly.
Otherwise, contact your local distributor. Sorry for the inconvenience caused.
User avatar
odroid
Site Admin
 
Posts: 28267
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Issues

Who is online

Users browsing this forum: No registered users and 1 guest