Problem installing Kodi on Odroid XU4

Moderators: mdrjr, odroid

Problem installing Kodi on Odroid XU4

Unread postby ross03 » Mon Jul 24, 2017 5:23 pm

I have an Odroid XU4 running Version 2.27 of Max2play. The device is connected by HDMI to a Panasonic TV. I have never seen any video output from Maxp2play, even on initialisation.

I tried a few weeks ago to install Kodi on an Odroid XU4. Initially I tried by just hitting the “Start Kodi / XBMC” button on the appropriate web interface page. I got an error message saying not successful, so after some searching I tried pasting in a link to a .deb version supposedly for XU4. After that installation I had an error message about GUI, I forget exactly the message but something like “unable to create GUI existing”.

Today I did a fresh install to version 2.27 and tried again by hitting the Start Kodi / XBMC button.

This returns the following details in the yellow detailed log at the top of the screen.

Trying to launch … NOT successful Click here to show detailed information
sudo: unable to resolve host OdroidXU4
Use Interface eth0 with -m 00:1e:06:31:13:96
Stopping Squeezelite
Stopping Shairport
pulseaudio: no process found
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)
xdpyinfo: unable to open display “:0”.
Traceback (most recent call last):
File “/usr/local/share/kodi/FEH.py”, line 174, in
if (1 == 1 and badColorDepth()):
File “/usr/local/share/kodi/FEH.py”, line 153, in badColorDepth
return bitDepth
UnboundLocalError: local variable ‘bitDepth’ referenced before assignment

Is there something I’m doing wrong here?

Thanks in advance for any replies.
ross03
 
Posts: 2
Joined: Mon Jul 24, 2017 5:17 pm
languages_spoken: english

Re: Problem installing Kodi on Odroid XU4

Unread postby odroid » Mon Jul 24, 2017 7:53 pm

Because Max2Play might use their own build, you would have a faster answer from the Max2Play forum probably.
User avatar
odroid
Site Admin
 
Posts: 24632
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Problem installing Kodi on Odroid XU4

Unread postby gregb49 » Sun Aug 13, 2017 6:28 am

As a newbie here, I hope I can help. KODI will only run under kernel 3.10, it seems, not under 4.9. If you flash 16.04 kernel 3.10 to your eMMC card then it will work fine until you update, upgrade and dist-upgrade, when something seems to get broken. So don't update etc. How that works security wise, I don't know.
XU4 Ubuntu 16.04.3
gregb49
 
Posts: 14
Joined: Mon Feb 06, 2017 8:30 pm
languages_spoken: english
ODROIDs: XU4 Ubuntu 16.04 Kernel 4.9


Return to Issues

Who is online

Users browsing this forum: No registered users and 3 guests