Odroid 64GB emmc card bad

Moderators: odroid, mdrjr

Odroid 64GB emmc card bad

Unread postby lordcy » Mon Aug 20, 2018 10:51 am

I purchased a 64GB emmc card to run OMV on my XU4 in 2015 from Hardkernel. I have working SD card readers and on the emmc I can see only 30.61MB of the 64GB card (please see attached picture). I'm using the most recent Win 32 Disk imager from Hardkernel. I have attempted the emmc recovery process for the XU4 but both the red and blue lights stay solid for over 30 minutes with no change to the blue light. I have also tried loading an linux image on SD card and trying to format emmc but that fails too. Odroid XU4 has been connected to a UPS the entire time with no electrical issues that I'm aware of. I also don't think OMV is doing a heavy load on emmc so that shouldn't be the issue either. I'm willing to do more troubleshooting if needed to get this working. Please advise. Thanks.

LordCy
Attachments
64GBemmcissue.JPG
64GBemmcissue.JPG (37.23 KiB) Viewed 313 times
lordcy
 
Posts: 14
Joined: Sun Dec 21, 2014 12:19 pm
Location: New Orleans, LA, USA
languages_spoken: English
ODROIDs: Odroid-C1

Re: Odroid 64GB emmc card bad

Unread postby odroid » Mon Aug 20, 2018 10:58 am

Your system could detect the FAT partition only and it shows the small partition size.

Try Etcher for flashing OMV OS image.
https://wiki.odroid.com/troubleshooting ... s#flashing

BTW, do you have a compatible reader adapter?
viewtopic.php?f=53&t=2725
User avatar
odroid
Site Admin
 
Posts: 29083
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Odroid 64GB emmc card bad

Unread postby lordcy » Mon Aug 20, 2018 11:21 am

I just tried Etcher with the same results. No, I don't have that specific USB emmc reader but I do have 3 others that have worked in the past to flash this emmc card successfully. The emmc card always gets hot now when trying to access it via usb readers or when physically attached to XU4 while troubleshooting.

LordCy
lordcy
 
Posts: 14
Joined: Sun Dec 21, 2014 12:19 pm
Location: New Orleans, LA, USA
languages_spoken: English
ODROIDs: Odroid-C1

Re: Odroid 64GB emmc card bad

Unread postby odroid » Mon Aug 20, 2018 11:49 am

Do you have a USB-UART kit to monitor the eMMC recovery process?
User avatar
odroid
Site Admin
 
Posts: 29083
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Odroid 64GB emmc card bad

Unread postby lordcy » Mon Aug 20, 2018 2:23 pm

No, I do not. I just placed an order for one and will post the results once I receive it. Thanks.

LordCy
lordcy
 
Posts: 14
Joined: Sun Dec 21, 2014 12:19 pm
Location: New Orleans, LA, USA
languages_spoken: English
ODROIDs: Odroid-C1

Re: Odroid 64GB emmc card bad

Unread postby lordcy » Fri Aug 24, 2018 2:42 pm

This is what I get from the recovery image via usb uart. Thanks.

Code: Select all
U-Boot 2017.05-00002-gd0752a9-dirty (Sep 08 2017 - 11:33:04 +0900) for ODROID-XU4

CPU:   Exynos5422 @ 800 MHz
Model: Odroid XU4 based on EXYNOS5422
Board: Odroid XU4 based on EXYNOS5422
Type:  xu4
DRAM:  2 GiB
MMC:   EXYNOS DWMMC: 0, EXYNOS DWMMC: 1
MMC Device 0 ( SD ): 119.3 GiB
mmc_init: -110, time 86
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Press quickly 'Enter' twice to stop autoboot:  0
reading boot.ini
3480 bytes read in 4 ms (849.6 KiB/s)
cfgload addr = 0x50000000, Loading boot.ini from FAT
cfgload: applying boot.ini...
cfgload: fatload mmc 0:1 40008000 bl1.bin
reading bl1.bin
15616 bytes read in 5 ms (3 MiB/s)
cfgload: emmc open 1
eMMC OPEN Failed.!!
cfgload: movi w z f 1 40008000
mmc block write, dev 1, addr 0x40008000, blk start 0, blk cnt 30
mmc_init: -110, time 81
cfgload: emmc close 1
eMMC CLOSE Failed.!!
cfgload: fatload mmc 0:1 40008000 bl2.bin
reading bl2.bin
14592 bytes read in 5 ms (2.8 MiB/s)
cfgload: emmc open 1
eMMC OPEN Failed.!!
cfgload: movi w z b 1 40008000
mmc block write, dev 1, addr 0x40008000, blk start 30, blk cnt 32
mmc_init: -110, time 81
cfgload: emmc close 1
eMMC CLOSE Failed.!!
cfgload: fatload mmc 0:1 40008000 u-boot.bin
reading u-boot.bin
620062 bytes read in 39 ms (15.2 MiB/s)
cfgload: emmc open 1
eMMC OPEN Failed.!!
cfgload: movi w z u 1 40008000
mmc block write, dev 1, addr 0x40008000, blk start 62, blk cnt 1440
mmc_init: -110, time 83
cfgload: emmc close 1
eMMC CLOSE Failed.!!
cfgload: fatload mmc 0:1 40008000 tzsw.bin
reading tzsw.bin
262144 bytes read in 18 ms (13.9 MiB/s)
cfgload: emmc open 1
eMMC OPEN Failed.!!
cfgload: movi w z t 1 40008000
mmc block write, dev 1, addr 0x40008000, blk start 1502, blk cnt 512
mmc_init: -110, time 81
cfgload: emmc close 1
eMMC CLOSE Failed.!!
cfgload: mw.l 40008000 0 4000;
cfgload: mmc dev 0
switch to partitions #0, OK
mmc0 is current device
cfgload: mmc write 40008000 0x07df 0x0020

MMC write: dev # 0, block # 2015, count 32 ... 32 blocks written: OK
cfgload: mmc dev 0
switch to partitions #0, OK
mmc0 is current device
cfgload: fatload mmc 0:1 40008000 zImage-dtb
reading zImage-dtb
4716296 bytes read in 266 ms (16.9 MiB/s)
cfgload: movi write kernel 1 40008000
mmc block write, dev 1, addr 0x40008000, blk start 2047, blk cnt 16384
mmc_init: -110, time 81
cfgload: fatload mmc 0:1 40000000 system_aa
reading system_aa
134217728 bytes read in 7422 ms (17.2 MiB/s)
cfgload: fatload mmc 0:1 48000000 system_ab
reading system_ab
134217728 bytes read in 7429 ms (17.2 MiB/s)
cfgload: fatload mmc 0:1 50000000 system_ac
reading system_ac
110907512 bytes read in 6139 ms (17.2 MiB/s)
cfgload: fatload mmc 0:1 61000000 cache.img
reading cache.img
6348948 bytes read in 354 ms (17.1 MiB/s)
cfgload: fdisk -c 1 1024 0 256 100
No MMC device available
### ERROR ### Please RESET the board ###


LordCy
lordcy
 
Posts: 14
Joined: Sun Dec 21, 2014 12:19 pm
Location: New Orleans, LA, USA
languages_spoken: English
ODROIDs: Odroid-C1

Re: Odroid 64GB emmc card bad

Unread postby odroid » Fri Aug 24, 2018 2:51 pm

mmc_init: -110, time 86 means the CPU couldn't detect the eMMC module while your 128GB micro-SD card was fine.

Try to clean the connectors on the eMMC module as well as XU4 board with a cotton swab and alcohol.
If it doesn't help, your eMMC module might be damaged by unknown electrical shock.
User avatar
odroid
Site Admin
 
Posts: 29083
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Odroid 64GB emmc card bad

Unread postby lordcy » Sun Aug 26, 2018 3:52 am

I cleaned the connectors and tried again but still nothing. I am using a UPS so I'm not sure how I would have gotten electrical shock to the board. Any chance for an RMA? Thanks.

LordCy
lordcy
 
Posts: 14
Joined: Sun Dec 21, 2014 12:19 pm
Location: New Orleans, LA, USA
languages_spoken: English
ODROIDs: Odroid-C1

Re: Odroid 64GB emmc card bad

Unread postby odroid » Fri Aug 31, 2018 10:38 am

Contact "odroid at hardkernel dot com" with a link of my post.
She will help your RMA process if you purchased the board from us directly.
Otherwise, contact your local distributor.

But, the warranty period has gone too far.
viewtopic.php?f=53&t=661
User avatar
odroid
Site Admin
 
Posts: 29083
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Hardware and peripherals

Who is online

Users browsing this forum: No registered users and 4 guests